You are here > News sv ru pl es fr

Problems caused by Steam update

Sunday 8 December 2013 at 15:31

Hi everybody,

As most of you has noticed, the latest steam update has broken PlayOnLinux and PlayOnMac support.

Indeed, 3 december 2013 steam updates causes problems with wine.

A new wine version (1.7.8) was released yesterday (Friday 6th december), fixing the issue.

Most of your games should work with this version.

Nevertheless, some games require patched wine versions. For those cases, we don't have a solution yet. We are working on rebuilding each of those patched versions with wine 1.7.8, but it can take time. We also need time to adapt PlayOnLinux/PlayOnMac scripts to this wine version, because some game are not fully compatible.

To use wine 1.7.8 for a game you've already installd (only for games that do not require patches) :
Open PlayOnLinux/PlayOnMac -> Click on configure button -> Select the game (left column) -> Install wine 1.7.8 if needed, by clicking "+" button -> Select wine 1.7.8  -> Close the window.
You can now try to run your game, it should work.

Note: Patched wine version have a name after the version :
1.7.1 = Unpatched version
1.5.7-vertex_shader = Patched version

In case of question, don't hesitate to post on the forum. You can also ask for a patched 1.7.8 wine version.

If you want to help us, you can still help us to test steam games with recent wine version, and tell us if it works, so that we can update scripts.

Thank you

Tinou

Comments

Author Replies
HobiOne Sunday 8 December 2013 at 17:03

Rank: Guest

OK, so how come only versions up to Wine 1.7.7 can be seen in PlayonMac!?
theone Sunday 8 December 2013 at 20:25

Rank: Guest

Can't see Wine 1.8 on the Wine Versions list, as HobiOne said, only up to 1.7.7...
Quentin PÂRIS Monday 9 December 2013 at 10:57

Rank: Admin

Admin

1.7.8 is now available for Mac, with winemac support
dannyboycoleman Tuesday 10 December 2013 at 8:49

Rank: Member

Age of Empires II HD doesn't work. Steam loads fine but when I go to play AoE it opens a window on a "first time setup" then never loads the game.
whyfrown Tuesday 10 December 2013 at 20:39

Rank: Guest

Regarding Age of Empires II HD, you might try some of the steps on this page:
http://steamcommunity.com/app/221380/discussions/0/864972620921616729/

I haven't yet, but am about to.
whyfrown Wednesday 11 December 2013 at 2:09

Rank: Guest

Never mind about that last post. I changed steam to use wine 1.7.8, and now Age of Empires II HD works great in wine, even without x11. I'm not sure if multiplayer works yet. That's the one problem.
siridun Wednesday 18 December 2013 at 19:38

Rank: Guest

The games that need Dotnet35, don't run.
With Wine 1.7.8, how to install Dotnet35 ??
eviltonberry Thursday 26 December 2013 at 17:22

Rank: Member

Because Steam will certainly release updates in the future which may cause this kind of break to happen again, would it be possible to add a feature into PoL where the user can choose which Wine version to use when installing (similar to how it can be set after it has been installed)? In the script, the variable "WORKING_WINE_VERSION" could act as the script's default, known to be working version when the script was created. However, give the end user the choice to install using a different version in case the install is failing under the set Wine version. I would think reasonable choices would be like "script", "default", "latest", or a specific version. I'm not 100% sure where to place this, so my apologies if this is the wrong place for what is essentially a feature request (didn't seem right to put this under "Bugs"). Is something like this suggestion possible or does it go against the design of how PoL is meant to work? Thanks in advance.
vanderpool5 Friday 27 December 2013 at 23:16

Rank: Guest

I'm very new to linux and i really need some help with getting skyrim to work. i had it working a month or so ago but now (I had not played games in so long because of college) my skyrim does not work. any help is appreciated

BOSSoNe Saturday 4 January 2014 at 13:44

Rank: Guest

Hi,
first Happy New Year and thank you for good work on PlayOnLinux.
Is it possible to have a wine 1.7.9 release with patchs for Tomb Raider 2013 ? This game hang on login screen.
Have a nice day !
jorchin Wednesday 8 January 2014 at 7:18

Rank: Guest

Hi, i have a sirius problem D: i wanna play torchlight 2 on mac, but i have to use steam, so i run steam on play on mac but in 1.7.10/8/5 1.5.25/23 version's always that i put the verification code in steam is close unexpectedly and appear a message in playonmac that say the same that the program close unexpectedly, what i have to do?
Auricon Sunday 12 January 2014 at 2:19

Rank: Guest

I have spent most of the day fiddling with wine. (and learning more about my mac in the process)

I have the same problem as the original poster. I am having trouble accessing my steam account through wine (to presumably download Dark Souls to go with my wrapper) seeing as it doesn't let me download the game otherwise.

Steam seems to crash after verification and update (it's had me verify 3 times now)

Would changing steam write access help?

Thank you
Auricon Sunday 12 January 2014 at 2:20

Rank: Guest

I have spent most of the day fiddling with wine. (and learning more about my mac in the process)

I have the same problem as the original poster. I am having trouble accessing my steam account through wine (to presumably download Dark Souls to go with my wrapper) seeing as it doesn't let me download the game otherwise.

Steam seems to crash after verification and update (it's had me verify 3 times now)

Would changing steam write access help?

Thank you
Jereasd Wednesday 22 January 2014 at 0:48

Rank: Guest

Auricon what is your wine version? 1.7.7? Change it to 1.7.8 or newer.. Should help.
Guest Monday 27 January 2014 at 8:22

Rank: Guest

I just found out about PlayOnMac and thought I would give it a try... What a complete waste of time. Get it together or give up.

Post a comment

Pseudo :

Mail :

:

BBCode

Smileys :

Message :

Il n'y a rien à voir ici