You are here    Bugs    PlayOnLinux    Bug    Ticket #5698 nl sv ru pl es de fr

Bug #5698 on PlayOnLinux

Missing libpng12.so.0 on Ubuntu 18.04 for WINE 3.10 x64

Added by Mystic-Mirage on 2018-06-14 14:46:29 - Comment or update this ticket

Statut:
New
Priority:
High
Assigned to:
Nobody
Last update:
2018-06-14 17:52:58
Description, steps to reproduce:
000d:err:wincodecs:PngEncoder_CreateInstance Failed writing PNG because unable to find libpng12.so.0

 

Ubuntu 18.04 doesn't have libpng12.so. There is libpng16.so instead.

Steps to reproduce (Ubuntu 18.04 required):

  1. Fetch 64-bit WINE version 3.10
  2. Create a new 64-bit prefix
  3. Try to install vcrun2015 via winetricks -- it will fail due to the error above.

History

Update by ImperatorS79 on 2018-06-14 15:16:41

Could you try something like :

cd /usr/lib64/
sudo ln -sf libpng12.so.0 libpng16.so.0

If it does not work (or do something worse), you can revert it with :

sudo rm /usr/lib64/libpng12.so.0

 

Update by ImperatorS79 on 2018-06-14 15:21:15

Sous Ubuntu, remplacer /usr/lib64 par /lib/x86_64-linux-gnu/

Update by ImperatorS79 on 2018-06-14 15:22:35

In English (sorry) :

On ubuntu, replace /usr/lib64 by /lib/x86_64-linux-gnu

Update by Mystic-Mirage on 2018-06-14 15:37:34

After:

ln -s /usr/lib/x86_64-linux-gnu/libpng16.so.16.34.0 /usr/lib/x86_64-linux-gnu/libpng12.so.0
ln -s /usr/lib/i386-linux-gnu/libpng16.so.16.34.0 /usr/lib/i386-linux-gnu/libpng12.so.0

Installing of vcrun2015 still fails with:

libpng warning: Application built with libpng-1.2.49 but running with 1.6.34
000d:err:menubuilder:convert_to_native_icon error 0x80004005 initializing encoder

Update by ImperatorS79 on 2018-06-14 17:52:58

Ok, seems there are not compatible. It is one more dependencie problem with the pol version of wine.
The best way for you is to find a copy of libpng12 and install it on your system.

Or you can try to download wine from here and unpack it inside .PlayOnlinux (where wine version are installed).

I will report this back to the devs