The forum

File does not exits ; it will be created when pol is updated

POL_Functions

Author Replies
intera Wednesday 20 February 2013 at 15:34
interaAnonymous

 playonlinux
Traceback (most recent call last):
  File "mainwindow.py", line 36, in <module>
    import guiv3 as gui, install, options, wine_versions as wver, sp, configure, threading, debug, gui_server
  File "/usr/share/playonlinux/python/configure.py", line 39
    except IOError as e: # File does not exits ; it will be created when pol is updated
                    ^
SyntaxError: invalid syntax
/usr/share/playonlinux/playonlinux: line 138: python2.6: command not found
 playonlinux
Traceback (most recent call last):
  File "mainwindow.py", line 36, in <module>
    import guiv3 as gui, install, options, wine_versions as wver, sp, configure, threading, debug, gui_server
  File "/usr/share/playonlinux/python/configure.py", line 39
    except IOError as e: # File does not exits ; it will be created when pol is updated
                    ^
SyntaxError: invalid syntax
/usr/share/playonlinux/playonlinux: line 138: python2.6: command not found


intera Wednesday 20 February 2013 at 15:36
interaAnonymous

Basically I am on elive (which is a lenny based distro) with python 2.5.2 all required packages installed (as in Python, wx python ...) and still cannot get it to work.

Line 139 of the script seems to be looking for POL_Functions and cannot find it .... neither can I ... so what did I do wrong????

Quentin PÂRIS Wednesday 20 February 2013 at 15:44
Quentin PÂRIS
Admin

Hi

1 - Ensure that you have the latest POL version
2 - Try to remove .playonlinux folder
3 - Restart POL
intera Wednesday 20 February 2013 at 16:01
interaAnonymous

I cannot find a .playonlinux directory and I installed from your repository with apt-get after adding the repo to apt source lists

intera Wednesday 20 February 2013 at 16:02
interaAnonymous

file deb.playonlinux.com_dists_lenny_*
deb.playonlinux.com_dists_lenny_main_binary-i386_Packages: ASCII Pascal program text
deb.playonlinux.com_dists_lenny_Release: Jan 22 14:32:44 MET 1991\\011Erlang JAM file - version 4.2
deb.playonlinux.com_dists_lenny_Release.gpg: PGP signature

intera Wednesday 20 February 2013 at 16:04
interaAnonymous

Origin: PlayOnLinux
Label: PoL
Suite: lenny
Codename: lenny
Version: 5.0
Date: Tue, 22 Jan 2013 20:38:03 UTC
Architectures: i386 amd64
Components: main
Description: PlayOnLinux permits you to install windows applications on linux thanks to wine - Visit : http://www.playo$

Quentin PÂRIS Wednesday 20 February 2013 at 16:06
Quentin PÂRIS
Admin

You must have a .PlayOnLinux in your home folder
intera Wednesday 20 February 2013 at 16:09
interaAnonymous

am afraid not, but as it never launched successfully, maybe it was never created?

intera Wednesday 20 February 2013 at 16:30
interaAnonymous

ok upgraded to python 2.6 manually, now it complains about wxversion
will keep you posted

intera Thursday 21 February 2013 at 10:26
interaAnonymous

ok had to downgrade back to python 2.5.2 as 2.6 was wreaking havoc on my system now python 2.5.6 reports a syntax error and that is why it does not work. here is the error:

File "mainwindow.py", line 36, in
import guiv3 as gui, install, options, wine_versions as wver, sp, configure, threading, debug, gui_server
File "/usr/share/playonlinux/python/configure.py", line 39
except IOError as e: # File does not exits ; it will be created when pol is updated
^
SyntaxError: invalid syntax


as you can see except IOError as e: seems to displease v.2.5.6 which comes as standard on lenny. so why make a lenny package if you cannot run on said platform??? or maybe I need to download an older copy of your scripts, in any case please could you let me know what to do?

ta

Quentin PÂRIS Thursday 21 February 2013 at 11:21
Quentin PÂRIS
Admin

PlayOnLinux runs perfectly on Lenny... I don't know what's the problem but you have something wrong on your system
intera Thursday 21 February 2013 at 11:43
interaAnonymous

the distro I have is called elive (http://www.elivecd.org) and is based on debian 5.0.8 codename lenny, python 2.5.2

Here are a few specs:

$ python --version
Python 2.5.2
python
Python 2.5.2 (r252:60911, Jan 24 2010, 14:53:14)
[GCC 4.3.2] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import sys
>>> print sys.path
['', '/usr/lib/python2.5', '/usr/lib/python2.5/plat-linux2', '/usr/lib/python2.5/lib-tk', '/usr/lib/python2.5/lib-dynload', '/usr/lib/python2.5/site-packages', '/usr/lib/python2.5/site-packages/Numeric', '/usr/lib/python2.5/site-packages/PIL', '/var/lib/python-support/python2.5', '/var/lib/python-support/python2.5/gtk-2.0']
>>> quit()

python
Python 2.5.2 (r252:60911, Jan 24 2010, 14:53:14)
[GCC 4.3.2] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import wx
Traceback (most recent call last):
File "", line 1, in
ImportError: No module named wx
>>>


as you can see there is no module named wx found by python.

launching playonlinux results in the following error:
playonlinux
Traceback (most recent call last):
File "mainwindow.py", line 36, in
import guiv3 as gui, install, options, wine_versions as wver, sp, configure, threading, debug, gui_server
File "/usr/share/playonlinux/python/configure.py", line 39
except IOError as e: # File does not exits ; it will be created when pol is updated
^
SyntaxError: invalid syntax
/usr/share/playonlinux/playonlinux: line 138: python2.6: command not found


you seem to launch python2.6 and the only python I have is 2.5.2, so that could be the problem. am I supposed to run 2.6???

besides that, python report a syntax error when lauching mainwindow.py as stated above

so really I welcome any idea, if you need to know more about the system in order to form a decent diagnostic please do ask I would be very obliged if you could help me tackle this problem

Thanks




Edited by intera


petch Thursday 21 February 2013 at 12:53
petch
Developer

I confirm that it doesn't install on eLive;
Tested in LiveCD configuration (installation requires a payware proprietary kernel module):
apt-get install playonlinux
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
icoutils libhtml-parser-perl libhtml-tagset-perl libhtml-tree-perl
libwww-perl python-wxgtk2.8 python-wxversion
Suggested packages:
libterm-readline-gnu-perl libterm-readline-perl-perl libio-socket-ssl-perl
wx2.8-doc wx2.8-examples python-xml
Recommended packages:
libmailtools-perl libhtml-format-perl libcompress-zlib-perl
The following NEW packages will be installed:
icoutils libhtml-parser-perl libhtml-tagset-perl libhtml-tree-perl
libwww-perl playonlinux python-wxgtk2.8 python-wxversion
0 upgraded, 8 newly installed, 0 to remove and 5 not upgraded.
Need to get 14.3MB of archives.
After this operation, 62.4MB of additional disk space will be used.
Do you want to continue [Y/n]?
WARNING: The following packages cannot be authenticated!
libhtml-tagset-perl libhtml-parser-perl libhtml-tree-perl libwww-perl
icoutils python-wxversion python-wxgtk2.8
Install these packages without verification [y/N]? y
Get:1 http://deb.playonlinux.com lenny/main playonlinux 4.1.9 [4011kB]
Get:2 http://debian.elivecd.org lenny/main libhtml-tagset-perl 3.20-2 [13.5kB]
Get:3 http://debian.elivecd.org lenny/main libhtml-parser-perl 3.56-1+lenny1 [110kB]
Get:4 http://debian.elivecd.org lenny/main libhtml-tree-perl 3.23-1 [209kB]
Get:5 http://debian.elivecd.org lenny/main libwww-perl 5.813-1+lenny2 [374kB]
Get:6 http://debian.elivecd.org lenny/main icoutils 0.26.0-2 [66.0kB]
Get:7 http://debian.elivecd.org lenny/main python-wxversion 2.6.3.2.2-3+lenny1 [23.6kB]
Get:8 http://debian.elivecd.org lenny/main python-wxgtk2.8 2.8.7.1-1.1+lenny1 [9445kB]
Fetched 14.3MB in 35s (400kB/s)
Selecting previously deselected package libhtml-tagset-perl.
(Reading database ... 80904 files and directories currently installed.)
Unpacking libhtml-tagset-perl (from .../libhtml-tagset-perl_3.20-2_all.deb) ...
Selecting previously deselected package libhtml-parser-perl.
Unpacking libhtml-parser-perl (from .../libhtml-parser-perl_3.56-1+lenny1_i386.deb) ...
Selecting previously deselected package libhtml-tree-perl.
Unpacking libhtml-tree-perl (from .../libhtml-tree-perl_3.23-1_all.deb) ...
Selecting previously deselected package libwww-perl.
Unpacking libwww-perl (from .../libwww-perl_5.813-1+lenny2_all.deb) ...
Selecting previously deselected package icoutils.
Unpacking icoutils (from .../icoutils_0.26.0-2_i386.deb) ...
Selecting previously deselected package python-wxversion.
Unpacking python-wxversion (from .../python-wxversion_2.6.3.2.2-3+lenny1_all.deb) ...
Selecting previously deselected package python-wxgtk2.8.
Unpacking python-wxgtk2.8 (from .../python-wxgtk2.8_2.8.7.1-1.1+lenny1_i386.deb) ...
Selecting previously deselected package playonlinux.
Unpacking playonlinux (from .../playonlinux_4.1.9_all.deb) ...
Processing triggers for man-db ...
Setting up libhtml-tagset-perl (3.20-2) ...
Setting up libhtml-parser-perl (3.56-1+lenny1) ...
Setting up libhtml-tree-perl (3.23-1) ...
Setting up libwww-perl (5.813-1+lenny2) ...
Setting up icoutils (0.26.0-2) ...
Setting up python-wxgtk2.8 (2.8.7.1-1.1+lenny1) ...
Setting up python-wxversion (2.6.3.2.2-3+lenny1) ...
Setting up playonlinux (4.1.9) ...
gconf-schemas is /usr/sbin/gconf-schemas
[eliveuser ~]$ playonlinux
Traceback (most recent call last):
File "mainwindow.py", line 36, in
import guiv3 as gui, install, options, wine_versions as wver, sp, configure, threading, debug, gui_server
File "/usr/share/playonlinux/python/configure.py", line 39
except IOError as e: # File does not exits ; it will be created when pol is updated
^
SyntaxError: invalid syntax
/usr/share/playonlinux/playonlinux: line 138: python2.6: command not found
intera Thursday 21 February 2013 at 13:09
interaAnonymous

Thanks petch now I know it is not just me ;-) do you think there is a way we can make it work at all???? that would be great!!!!

/Patrick

petch Thursday 21 February 2013 at 13:56
petch
Developer

It no longer works on Lenny either:
debian:/home/petchema# apt-get install playonlinux
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
avahi-daemon cabextract icoutils imagemagick libavahi-core5 libdaemon0
libgd2-noxpm libgphoto2-2 libgphoto2-port0 libgraphviz4 libieee1284-3
libilmbase6 libjasper1 libltdl3 libmagick10 libnss-mdns libopenexr6 libsane
libsane-extras libwine libwine-alsa libwine-cms libwine-gl libwine-gphoto2
libwine-ldap libwine-print libwine-sane libwmf0.2-7 libwxbase2.8-0
libwxgtk2.8-0 python-wxgtk2.8 python-wxversion sane-utils ttf-liberation
wine wine-bin wine-utils xbitmaps xterm
Suggested packages:
avahi-autoipd libterm-readline-gnu-perl libterm-readline-perl-perl
libgd-tools gphoto2 gtkam libjasper-runtime libwmf-bin html2ps hpoj hplip
wine-doc wx2.8-doc wx2.8-examples python-xml unpaper binfmt-support
ttf-mscorefonts-installer winbind avscan klamav clamav xfonts-cyrillic
The following NEW packages will be installed:
avahi-daemon cabextract icoutils imagemagick libavahi-core5 libdaemon0
libgd2-noxpm libgphoto2-2 libgphoto2-port0 libgraphviz4 libieee1284-3
libilmbase6 libjasper1 libltdl3 libmagick10 libnss-mdns libopenexr6 libsane
libsane-extras libwine libwine-alsa libwine-cms libwine-gl libwine-gphoto2
libwine-ldap libwine-print libwine-sane libwmf0.2-7 libwxbase2.8-0
libwxgtk2.8-0 playonlinux python-wxgtk2.8 python-wxversion sane-utils
ttf-liberation wine wine-bin wine-utils xbitmaps xterm
0 upgraded, 40 newly installed, 0 to remove and 0 not upgraded.
Need to get 42.9MB of archives.
After this operation, 167MB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://deb.playonlinux.com lenny/main playonlinux 4.1.9 [4011kB]
Get:2 http://archive.debian.org lenny/main xbitmaps 1.0.1-2 [26.6kB]
Get:3 http://archive.debian.org lenny/main libavahi-core5 0.6.23-3lenny3 [115kB]
Get:4 http://archive.debian.org lenny/main libdaemon0 0.12-2lenny1 [12.5kB]
Get:5 http://archive.debian.org lenny/main avahi-daemon 0.6.23-3lenny3 [88.0kB]
Get:6 http://archive.debian.org lenny/main cabextract 1.2-3+lenny1 [55.2kB]
Get:7 http://archive.debian.org lenny/main icoutils 0.26.0-2 [66.0kB]
Get:8 http://archive.debian.org lenny/main libgd2-noxpm 2.0.36~rc1~dfsg-3+lenny1 [221kB]
Get:9 http://archive.debian.org lenny/main libltdl3 1.5.26-4+lenny1 [177kB]
Get:10 http://archive.debian.org lenny/main libgraphviz4 2.20.2-3 [536kB]
Get:11 http://archive.debian.org lenny/main libilmbase6 1.0.1-2+nmu2 [118kB]
Get:12 http://archive.debian.org lenny/main libjasper1 1.900.1-5.1+lenny2 [146kB]
Get:13 http://archive.debian.org lenny/main libopenexr6 1.6.1-3+lenny3 [262kB]
Get:14 http://archive.debian.org lenny/main libwmf0.2-7 0.2.8.4-6+lenny1 [176kB]
Get:15 http://archive.debian.org lenny/main libmagick10 7:6.3.7.9.dfsg2-1~lenny4 [3996kB]
Get:16 http://archive.debian.org lenny/main imagemagick 7:6.3.7.9.dfsg2-1~lenny4 [1429kB]
Get:17 http://archive.debian.org lenny/main libgphoto2-port0 2.4.1-3 [136kB]
Get:18 http://archive.debian.org lenny/main libgphoto2-2 2.4.1-3 [1331kB]
Get:19 http://archive.debian.org lenny/main libieee1284-3 0.2.11-5 [28.8kB]
Get:20 http://archive.debian.org lenny/main libnss-mdns 0.10-3 [24.0kB]
Get:21 http://archive.debian.org lenny/main libsane-extras 1.0.19.11 [187kB]
Get:22 http://archive.debian.org lenny/main libsane 1.0.19-23 [3487kB]
Get:23 http://archive.debian.org lenny/main libwine 1.0.1-1 [8761kB]
Get:24 http://archive.debian.org lenny/main libwine-alsa 1.0.1-1 [101kB]
Get:25 http://archive.debian.org lenny/main libwine-cms 1.0.1-1 [60.1kB]
Get:26 http://archive.debian.org lenny/main libwine-gl 1.0.1-1 [382kB]
Get:27 http://archive.debian.org lenny/main libwine-gphoto2 1.0.1-1 [61.6kB]
Get:28 http://archive.debian.org lenny/main libwine-ldap 1.0.1-1 [109kB]
Get:29 http://archive.debian.org lenny/main libwine-print 1.0.1-1 [158kB]
Get:30 http://archive.debian.org lenny/main libwine-sane 1.0.1-1 [59.3kB]
Get:31 http://archive.debian.org lenny/main libwxbase2.8-0 2.8.7.1-1.1+lenny1 [677kB]
Get:32 http://archive.debian.org lenny/main libwxgtk2.8-0 2.8.7.1-1.1+lenny1 [3415kB]
Get:33 http://archive.debian.org lenny/main wine-bin 1.0.1-1 [704kB]
Get:34 http://archive.debian.org lenny/main wine-utils 1.0.1-1 [569kB]
Get:35 http://archive.debian.org lenny/main wine 1.0.1-1 [43.6kB]
Get:36 http://archive.debian.org lenny/main xterm 235-2 [471kB]
Get:37 http://archive.debian.org lenny/main python-wxversion 2.6.3.2.2-3+lenny1 [23.6kB]
Get:38 http://archive.debian.org lenny/main python-wxgtk2.8 2.8.7.1-1.1+lenny1 [9445kB]
Get:39 http://archive.debian.org lenny/main sane-utils 1.0.19-23 [204kB]
Get:40 http://archive.debian.org lenny/main ttf-liberation 1.04.93-1 [1007kB]
Fetched 42.9MB in 1min1s (692kB/s)
Extracting templates from packages: 100%
Preconfiguring packages ...
Selecting previously deselected package xbitmaps.
(Reading database ... 57565 files and directories currently installed.)
Unpacking xbitmaps (from .../xbitmaps_1.0.1-2_all.deb) ...
Selecting previously deselected package libavahi-core5.
Unpacking libavahi-core5 (from .../libavahi-core5_0.6.23-3lenny3_i386.deb) ...
Selecting previously deselected package libdaemon0.
Unpacking libdaemon0 (from .../libdaemon0_0.12-2lenny1_i386.deb) ...
Selecting previously deselected package avahi-daemon.
Unpacking avahi-daemon (from .../avahi-daemon_0.6.23-3lenny3_i386.deb) ...
Selecting previously deselected package cabextract.
Unpacking cabextract (from .../cabextract_1.2-3+lenny1_i386.deb) ...
Selecting previously deselected package icoutils.
Unpacking icoutils (from .../icoutils_0.26.0-2_i386.deb) ...
Selecting previously deselected package libgd2-noxpm.
Unpacking libgd2-noxpm (from .../libgd2-noxpm_2.0.36~rc1~dfsg-3+lenny1_i386.deb) ...
Selecting previously deselected package libltdl3.
Unpacking libltdl3 (from .../libltdl3_1.5.26-4+lenny1_i386.deb) ...
Selecting previously deselected package libgraphviz4.
Unpacking libgraphviz4 (from .../libgraphviz4_2.20.2-3_i386.deb) ...
Selecting previously deselected package libilmbase6.
Unpacking libilmbase6 (from .../libilmbase6_1.0.1-2+nmu2_i386.deb) ...
Selecting previously deselected package libjasper1.
Unpacking libjasper1 (from .../libjasper1_1.900.1-5.1+lenny2_i386.deb) ...
Selecting previously deselected package libopenexr6.
Unpacking libopenexr6 (from .../libopenexr6_1.6.1-3+lenny3_i386.deb) ...
Selecting previously deselected package libwmf0.2-7.
Unpacking libwmf0.2-7 (from .../libwmf0.2-7_0.2.8.4-6+lenny1_i386.deb) ...
Selecting previously deselected package libmagick10.
Unpacking libmagick10 (from .../libmagick10_7%3a6.3.7.9.dfsg2-1~lenny4_i386.deb) ...
Selecting previously deselected package imagemagick.
Unpacking imagemagick (from .../imagemagick_7%3a6.3.7.9.dfsg2-1~lenny4_i386.deb) ...
Selecting previously deselected package libgphoto2-port0.
Unpacking libgphoto2-port0 (from .../libgphoto2-port0_2.4.1-3_i386.deb) ...
Selecting previously deselected package libgphoto2-2.
Unpacking libgphoto2-2 (from .../libgphoto2-2_2.4.1-3_i386.deb) ...
Selecting previously deselected package libieee1284-3.
Unpacking libieee1284-3 (from .../libieee1284-3_0.2.11-5_i386.deb) ...
Selecting previously deselected package libnss-mdns.
Unpacking libnss-mdns (from .../libnss-mdns_0.10-3_i386.deb) ...
Selecting previously deselected package libsane-extras.
Unpacking libsane-extras (from .../libsane-extras_1.0.19.11_i386.deb) ...
Selecting previously deselected package libsane.
Unpacking libsane (from .../libsane_1.0.19-23_i386.deb) ...
Selecting previously deselected package libwine.
Unpacking libwine (from .../libwine_1.0.1-1_i386.deb) ...
Selecting previously deselected package libwine-alsa.
Unpacking libwine-alsa (from .../libwine-alsa_1.0.1-1_i386.deb) ...
Selecting previously deselected package libwine-cms.
Unpacking libwine-cms (from .../libwine-cms_1.0.1-1_i386.deb) ...
Selecting previously deselected package libwine-gl.
Unpacking libwine-gl (from .../libwine-gl_1.0.1-1_i386.deb) ...
Selecting previously deselected package libwine-gphoto2.
Unpacking libwine-gphoto2 (from .../libwine-gphoto2_1.0.1-1_i386.deb) ...
Selecting previously deselected package libwine-ldap.
Unpacking libwine-ldap (from .../libwine-ldap_1.0.1-1_i386.deb) ...
Selecting previously deselected package libwine-print.
Unpacking libwine-print (from .../libwine-print_1.0.1-1_i386.deb) ...
Selecting previously deselected package libwine-sane.
Unpacking libwine-sane (from .../libwine-sane_1.0.1-1_i386.deb) ...
Selecting previously deselected package libwxbase2.8-0.
Unpacking libwxbase2.8-0 (from .../libwxbase2.8-0_2.8.7.1-1.1+lenny1_i386.deb) ...
Selecting previously deselected package libwxgtk2.8-0.
Unpacking libwxgtk2.8-0 (from .../libwxgtk2.8-0_2.8.7.1-1.1+lenny1_i386.deb) ...
Selecting previously deselected package wine-bin.
Unpacking wine-bin (from .../wine-bin_1.0.1-1_i386.deb) ...
Selecting previously deselected package wine-utils.
Unpacking wine-utils (from .../wine-utils_1.0.1-1_i386.deb) ...
Selecting previously deselected package wine.
Unpacking wine (from .../archives/wine_1.0.1-1_i386.deb) ...
Selecting previously deselected package xterm.
Unpacking xterm (from .../archives/xterm_235-2_i386.deb) ...
Selecting previously deselected package python-wxversion.
Unpacking python-wxversion (from .../python-wxversion_2.6.3.2.2-3+lenny1_all.deb) ...
Selecting previously deselected package python-wxgtk2.8.
Unpacking python-wxgtk2.8 (from .../python-wxgtk2.8_2.8.7.1-1.1+lenny1_i386.deb) ...
Selecting previously deselected package playonlinux.
Unpacking playonlinux (from .../playonlinux_4.1.9_all.deb) ...
Selecting previously deselected package sane-utils.
Unpacking sane-utils (from .../sane-utils_1.0.19-23_i386.deb) ...
Selecting previously deselected package ttf-liberation.
Unpacking ttf-liberation (from .../ttf-liberation_1.04.93-1_all.deb) ...
Processing triggers for man-db ...
Processing triggers for menu ...
Processing triggers for hal ...
Regenerating hal fdi cache ...
Restarting Hardware abstraction layer: hald.
Setting up xbitmaps (1.0.1-2) ...
Setting up libavahi-core5 (0.6.23-3lenny3) ...
Setting up libdaemon0 (0.12-2lenny1) ...
Setting up avahi-daemon (0.6.23-3lenny3) ...
Reloading system message bus config...done.
Starting Avahi mDNS/DNS-SD Daemon: avahi-daemon.
Setting up cabextract (1.2-3+lenny1) ...
Setting up icoutils (0.26.0-2) ...
Setting up libgd2-noxpm (2.0.36~rc1~dfsg-3+lenny1) ...
Setting up libltdl3 (1.5.26-4+lenny1) ...
Setting up libgraphviz4 (2.20.2-3) ...
Setting up libilmbase6 (1.0.1-2+nmu2) ...
Setting up libjasper1 (1.900.1-5.1+lenny2) ...
Setting up libopenexr6 (1.6.1-3+lenny3) ...
Setting up libwmf0.2-7 (0.2.8.4-6+lenny1) ...
Updating font configuration of libwmf0.2-7...
Cleaning up category type1..
Cleaning up category truetype..
Updating category truetype..
Updating category type1..
Setting up libmagick10 (7:6.3.7.9.dfsg2-1~lenny4) ...
Setting up imagemagick (7:6.3.7.9.dfsg2-1~lenny4) ...
Setting up libgphoto2-port0 (2.4.1-3) ...
Setting up libgphoto2-2 (2.4.1-3) ...
Setting up libieee1284-3 (0.2.11-5) ...
Setting up libnss-mdns (0.10-3) ...
First installation detected...
Checking NSS setup...
Setting up libsane-extras (1.0.19.11) ...
Setting up libsane (1.0.19-23) ...
Adding scanner group...
.udevdb or .udev presence implies active udev. Aborting MAKEDEV invocation.
.udevdb or .udev presence implies active udev. Aborting MAKEDEV invocation.
Setting up libwine (1.0.1-1) ...
Setting up libwine-alsa (1.0.1-1) ...
Setting up libwine-cms (1.0.1-1) ...
Setting up libwine-gl (1.0.1-1) ...
Setting up libwine-gphoto2 (1.0.1-1) ...
Setting up libwine-ldap (1.0.1-1) ...
Setting up libwine-print (1.0.1-1) ...
Setting up libwine-sane (1.0.1-1) ...
Setting up libwxbase2.8-0 (2.8.7.1-1.1+lenny1) ...
Setting up libwxgtk2.8-0 (2.8.7.1-1.1+lenny1) ...
Setting up wine-bin (1.0.1-1) ...
Setting up wine-utils (1.0.1-1) ...
Setting up wine (1.0.1-1) ...
Setting up xterm (235-2) ...
Setting up sane-utils (1.0.19-23) ...
Adding saned group and user...
Adding user saned to group scanner
saned disabled; edit /etc/default/saned
Setting up ttf-liberation (1.04.93-1) ...
Updating fontconfig cache for /usr/share/fonts/truetype/ttf-liberation
Setting up python-wxgtk2.8 (2.8.7.1-1.1+lenny1) ...
Setting up python-wxversion (2.6.3.2.2-3+lenny1) ...
Setting up playonlinux (4.1.9) ...
gconf-schemas is /usr/sbin/gconf-schemas
Processing triggers for menu ...
$ playonlinux
Traceback (most recent call last):
File "mainwindow.py", line 36, in
import guiv3 as gui, install, options, wine_versions as wver, sp, configure, threading, debug, gui_server
File "/usr/share/playonlinux/python/configure.py", line 39
except IOError as e: # File does not exits ; it will be created when pol is updated
^
SyntaxError: invalid syntax
/usr/share/playonlinux/playonlinux: line 138: python2.6: command not found


Two choices here, repair Python 2.5 compatibility, or drop Lenny (and Etch) compatibility.
intera Friday 22 February 2013 at 18:56
interaAnonymous

Indeed, compatibility with lenny has been broken, maybe you should make a lenny compatible version available for download??

Let me know your thoughts on this!!!!

/Patrick

petch Friday 22 February 2013 at 19:37
petch
Developer

We won't maintain two separate versions, if that was your suggestion.
intera Saturday 23 February 2013 at 15:00
interaAnonymous

mmmh no, my idea was more like make a previous version available for download, one that hadn't broken the lenny compatibility yet ;-) ... Let me know what you guys think as there are a lot of people still on lenny out there ;-)

petch Saturday 23 February 2013 at 15:59
petch
Developer

Since programs to not work in isolation (they must work with operating systems that evolve, they communicate thru the network with external services,...), keeping a version functional is work, that's what I can maintainance. And as I said, it won't happen, there's simply not enough manpower to split it.

Edited by petch