The forum

league of legends

store

Author Replies
Jump to the page: 1 - 2
petch Friday 15 March 2013 at 19:41
petch
Developer

Given the error message, it could be the result of installing IE6 in this virtual drive.
Now that it seems we have a solution for having a working store, I'd suggest reinstalling LoL from scratch Remove the virtual drive before reinstalling, or select "Erase virtual drive" when asked.
Once the installation is completed, don't forget to switch Wine version to 1.5.24-LeagueOfLegendsShop.
We need some more testing before default Wine version can be changed in the script.
Ronin DUSETTE Friday 15 March 2013 at 19:44
Ronin DUSETTE
Admin

petch - Just so I know for future reference, what are some things that you are looking at that say that ie6 is causing an issue? Im trying to make notes of things like this. lol (pun intended)

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
krissi Friday 15 March 2013 at 19:46
krissiAnonymous

okey reinstall :D
do i need to update patch ?

Edited by krissi

petch Friday 15 March 2013 at 20:11
petch
Developer


Unhandled exception: unimplemented function urlmon.dll.FindMimeFromData called in 32-bit code (0x7bc4d670).

Quote

Some function is missing from urlmon.dll, it's not the expected version (probably older than expected).
I'm almost sure it's a DLL that's replaced when you install IE6 in a virtual drive, since the install script "re-registers" this DLL. That could be confirmed by installing that component in a clean virtual drive.

@krissi: what do you mean by update patch, what patch?

Edited by petch

krissi Friday 15 March 2013 at 20:52
krissiAnonymous

I am reinstalling lol and I see that the install is diffrent, should I run the game and see if the Icons show or should I install the patch that make the icons work.
petch Friday 15 March 2013 at 22:29
petch
Developer

I think the shop icons won't show correctly without the patch, the problem is still not fixed in Wine as far as I know.
It's not difficult to check anyway: just try without the patch ;)
krissi Saturday 16 March 2013 at 10:55
krissiAnonymous

okey i have reinstalled lol and install wine 1.5.24-LeagueOfLegendsShop i do not crash when i go in store but store is just black screen, and i had to install Legue of legends patch to fix icons in game shop.
krissi Saturday 16 March 2013 at 13:05
krissiAnonymous

i got in store but i have to wait a long time to get it working
Thank you :)

there is some bug in runes i can't see them or buy them

Edited by krissi

xpander Saturday 16 March 2013 at 14:37
xpander

you have to wait even longer for runes
takes about 5-10 minutes before it loads. so go make a coffe or smoke in the mean time :D
petch Saturday 16 March 2013 at 19:36
petch
Developer

I read something like that on the AppDB too, so I'm not sure there's a fix for that yet...
hilongo Wednesday 23 October 2013 at 19:44
hilongoAnonymous

Hello People ... I'm new here and joined because I am trying to run League of Legends on Linux, using PlayOnLinux.
I have the latest version of POL and was able to install the game, run it and log in without a problem ... I can even spectate games live .... But the one thing I cannot do is to join a game ... I have tried to join a custom game, a Coop vs AI game and even to the tutorial, with no success... all goes well until the part when all the players' portraits should appear .... after a while I get a "connection error" dialogue.

Any tips on this?
My distro is a LinuxMint 15: olivia (x86-64)

I have wine 1.7 on the LoL prefix... and after reading th last couple of posts I'll try changing to a previous on, and see if that helps.

Thanks in advance
xpander Saturday 26 October 2013 at 12:04
xpander

Hello People ... I'm new here and joined because I am trying to run League of Legends on Linux, using PlayOnLinux.
I have the latest version of POL and was able to install the game, run it and log in without a problem ... I can even spectate games live .... But the one thing I cannot do is to join a game ... I have tried to join a custom game, a Coop vs AI game and even to the tutorial, with no success... all goes well until the part when all the players' portraits should appear .... after a while I get a "connection error" dialogue.

Any tips on this?
My distro is a LinuxMint 15: olivia (x86-64)

I have wine 1.7 on the LoL prefix... and after reading th last couple of posts I'll try changing to a previous on, and see if that helps.

Thanks in advance

Quote from hilongo


just wait ...it takes long time.. when everybody else have loaded the game then the ones that play under linux should start loading.. takes 2-3 min sadly:( 

if you still cannot
then try to change your /etc/hosts files
depending on your desktop: sudo pluma /etc/hosts or sudo gedit /etc/hosts

and
change the line

127.0.0.1    localhost.localdomain

to 127.0.0.1    localhost.localdomain    arch

arch is my hostname, check your hostname from terminal the one behind the @ 
Like yourname@something

hilongo Friday 1 November 2013 at 19:51
hilongoAnonymous

Well ... waiting didn't work, but changing the /etc/hosts file did the trick!!

Thankyou very much!! :D