The forum

MS Office 2010 - how to install SP1?

Errors on running the SP installation file

Author Replies
Jump to the page: 1 - 2
nmeyne Tuesday 2 April 2013 at 23:32
nmeyneAnonymous

OK - Chose 4.2.1 deb package and installed from Terminal.

Did not have CURL... needed this. Installed OK

nick@neptune:~$ sudo dpkg -i PlayOnLinux_4.2.1.deb
[sudo] password for nick:
Selecting previously unselected package playonlinux.
(Reading database ... 201931 files and directories currently installed.)
Unpacking playonlinux (from PlayOnLinux_4.2.1.deb) ...
Setting up playonlinux (4.2.1) ...
gconf-schemas is /usr/sbin/gconf-schemas
Processing triggers for man-db ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for gconf2 ...
nick@neptune:~$


Started POL and
Installed MS fonts:

nick@neptune:~$ playonlinux
[main] Message: PlayOnLinux (4.2.1) is starting
[clean_tmp] Message: Cleaning temp directory
[POL_Config_Write] Message: Config write: VDRIVES_LINK_MADE TRUE
[Check_OpenGL] Message: 32bits direct rendering is enabled
[Check_OpenGL] Message: 64bits direct rendering is enabled
[POL_System_CheckFS] Message: Checking filesystem for /home/nick/.PlayOnLinux/
[main] Message: Filesystem is compatible
[install_plugins] Message: Checking plug-in: Capture...
[install_plugins] Message: -->Installing plug-in: 'Capture'.
[maj_check] Message: Web version : 1364915804
[maj_check] Message: Current local version :
[maj_check] Message: Updating list
[install_plugins] Message: Checking plug-in: ScreenCap...
[install_plugins] Message: -->Installing plug-in: 'ScreenCap'.
[install_plugins] Message: Checking plug-in: PlayOnLinux Vault...
[install_plugins] Message: -->Installing plug-in: 'PlayOnLinux Vault'.
[POL_SetupWindow_Init] Message: Creating new window for pid 19802
[POL_Config_Write] Message: Config write: FIRST_FIRST_USE TRUE
[POL_Config_Write] Message: Config write: LAST_TIMESTAMP 1364915804
[POL_Call] Message: Calling POL_Internal_InstallFonts
[POL_Call] Message: ----- Starting function POL_Internal_InstallFonts -----
[POL_GPG_auth_script] Message: Checking signature of POL_Internal_InstallFonts
[POL_GPG_install_key] Message: Importing PlayOnLinux public key
[POL_Source] Message: POL GPG : Good signature
--- Licence translated into your language ---
These fonts were provided by Microsoft
etc etc....

So, all was going well until at the end of the install, those RPC errors started to come up:

err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
fixme:ole:NdrCorrelationInitialize (0xa47da54, 0xa47d654, 1024, 0x0): stub
fixme:ole:NdrCorrelationInitialize (0xa47da54, 0xa47d654, 1024, 0x0): stub
fixme:rpc:handle_bind_error unexpected status value 1765
err:rpc:RpcAssoc_BindConnection rejected bind for reason 0
err:msi:ITERATE_Actions Execution halted, action L"CAInstallSppPlugin.x86" returned 1603
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:msi:load_ttf_name_id Unable to open font file L"C:\\\\windows\\\\Fonts\\\\ARIALUNI.TTF"
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
fixme:advapi:SetNamedSecurityInfoW L"ose" 2 4 (nil) (nil) 0x11d90074 (nil)
fixme:advapi:SetNamedSecurityInfoW L"osppsvc" 2 4 (nil) (nil) 0x11d8fb8c (nil)
fixme:advapi:SetNamedSecurityInfoW L"osppsvc" 2 4 (nil) (nil) 0x11d8fb8c (nil)
fixme:advapi:SetNamedSecurityInfoW L"C:\\\\users\\\\Public\\\\Microsoft\\\\OfficeSoftwareProtectionPlatform\\\\" 1 4 (nil) (nil) 0x119921e4 (nil)
fixme:ole:NdrCorrelationInitialize (0x33d248, 0x33ce48, 1024, 0x0): stub
fixme:rpc:NdrStubCall2 new correlation description not implemented
fixme:ole:NdrCorrelationFree (0x33d248): stub
fixme:ole:NdrCorrelationInitialize (0x33d274, 0x33ce74, 1024, 0x0): stub
fixme:rpc:NdrStubCall2 new correlation description not implemented
fixme:ntdll:NtFsControlFile FSCTL_PIPE_IMPERSONATE: impersonating self
fixme:ole:NdrCorrelationFree (0x33d274): stub
fixme:ole:NdrCorrelationInitialize (0x33d234, 0x33ce34, 1024, 0x0): stub
fixme:advapi:UnregisterTraceGuids 0: stub
fixme:advapi:UnregisterTraceGuids 0: stub
[POL_Wine] Message: Wine return: 0

At this point we have a POL screen asking to pick an icon from the many in the office suite - a bit of a guessing game, and I'm not sure if this gives enough context for the apps to run. e.g. powerpoint fails (see below). Word, Excel, Access and Pub seem OK though.

The previous POL sorted this out for me and picked the icons for me. Looks like this fails on the (possibly) later version.


[POL_SetupWindow_icon_menu] Message: icon_menu answer: EXCEL.EXE
[POL_SetupWindow_textbox] Message: textbox answer: EXCEL
[POL_Shortcut] Message: Shortcut created: EXCEL.EXE EXCEL
[POL_SetupWindow_icon_menu] Message: icon_menu answer: WINWORD.EXE
[POL_SetupWindow_textbox] Message: textbox answer: WORD
[POL_Shortcut] Message: Shortcut created: WINWORD.EXE WORD
[POL_SetupWindow_icon_menu] Message: icon_menu answer: MSACCESS.EXE
[POL_SetupWindow_textbox] Message: textbox answer: ACCESS
icons-brut: clr_important field in bitmap should be zero
icons-brut: clr_important field in bitmap should be zero
icons-brut: clr_important field in bitmap should be zero
icons-brut: clr_important field in bitmap should be zero
icons-brut: clr_important field in bitmap should be zero
icons-brut: clr_important field in bitmap should be zero
[POL_Shortcut] Message: Shortcut created: MSACCESS.EXE ACCESS
[POL_SetupWindow_icon_menu] Message: icon_menu answer: POWERPNT.EXE
[POL_SetupWindow_textbox] Message: textbox answer: POWERPNT
[POL_Shortcut] Message: Shortcut created: POWERPNT.EXE POWERPNT
[POL_SetupWindow_icon_menu] Message: icon_menu answer: MSPUB.EXE
[POL_SetupWindow_textbox] Message: textbox answer: MSPUB
[POL_Shortcut] Message: Shortcut created: MSPUB.EXE MSPUB
/usr/share/playonlinux/bash/install: line 28: 20941 Killed bash "$PLAYONLINUX/bash/manual_install"

[POL_System_CheckFS] Message: Checking filesystem for POWERPNT.EXE
[POL_Wine] Message: Running wine- POWERPNT.EXE (Working directory : /home/nick/.PlayOnLinux/wineprefix/MSOffice/drive_c/Program Files/Microsoft Office/Office14)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
[POL_Wine] Message: Wine return: 0

...so powepoint would not run... at least not from POWERPNT.EXE


[POL_System_CheckFS] Message: Checking filesystem for WINWORD.EXE
[POL_Wine] Message: Running wine- WINWORD.EXE (Working directory : /home/nick/.PlayOnLinux/wineprefix/MSOffice/drive_c/Program Files/Microsoft Office/Office14)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
[POL_Wine] Message: Wine return: 0
[POL_System_CheckFS] Message: Checking filesystem for EXCEL.EXE
[POL_Wine] Message: Running wine- EXCEL.EXE (Working directory : /home/nick/.PlayOnLinux/wineprefix/MSOffice/drive_c/Program Files/Microsoft Office/Office14)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
[POL_Wine] Message: Wine return: 0
[POL_System_CheckFS] Message: Checking filesystem for MSACCESS.EXE
[POL_Wine] Message: Running wine- MSACCESS.EXE (Working directory : /home/nick/.PlayOnLinux/wineprefix/MSOffice/drive_c/Program Files/Microsoft Office/Office14)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
[POL_Wine] Message: Wine return: 0
[POL_System_CheckFS] Message: Checking filesystem for MSPUB.EXE
[POL_Wine] Message: Running wine- MSPUB.EXE (Working directory : /home/nick/.PlayOnLinux/wineprefix/MSOffice/drive_c/Program Files/Microsoft Office/Office14)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
[POL_Wine] Message: Wine return: 0

So here I am... is it worth proceeding to the upgrade? Or start over somehow? This seems broken?

Nick
Ronin DUSETTE Tuesday 2 April 2013 at 23:43
Ronin DUSETTE
Admin

OK - Chose 4.2.1 deb package and installed from Terminal.

Did not have CURL... needed this. Installed OK

nick@neptune:~$ sudo dpkg -i PlayOnLinux_4.2.1.deb
[sudo] password for nick:
Selecting previously unselected package playonlinux.
(Reading database ... 201931 files and directories currently installed.)
Unpacking playonlinux (from PlayOnLinux_4.2.1.deb) ...
Setting up playonlinux (4.2.1) ...
gconf-schemas is /usr/sbin/gconf-schemas
Processing triggers for man-db ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for gconf2 ...
nick@neptune:~$

Quote


See how much more sexy it is when we have all of that output? :) Tells you a LOT about whats going on.

Started POL and
Installed MS fonts:

Quote

Normal.

So, all was going well until at the end of the install, those RPC errors started to come up:

Quote

That happened last time, and it was all good.

At this point we have a POL screen asking to pick an icon from the many in the office suite - a bit of a guessing game, and I'm not sure if this gives enough context for the apps to run. e.g. powerpoint fails (see below). Word, Excel, Access and Pub seem OK though.

The previous POL sorted this out for me and picked the icons for me. Looks like this fails on the (possibly) later version.

Quote

Icons are only automatically chosen if there is a script for whatever you are running. Because there is not a script SPECIFICALLY for SP1, you would have to choose that manually.

So here I am... is it worth proceeding to the upgrade? Or start over somehow? This seems broken?

Quote


Well, what did you change in your last installs from now? It was just working before reinstalling, which means that you may have installed a dependency or changed an option or something since the last install, considering that it worked a few minutes ago, and the original Office installed fine, and the SP1 worked, even after a "POL crash", so it stands to reason that it should work now. Um not sure why it wouldnt load.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Tuesday 2 April 2013 at 23:49
Ronin DUSETTE
Admin

You can create another Shortcut for PP by doing the following:

Open POL

Click Configure

Select your virtual drive on the left of the new window

Click "Make a new shortcut from this virtual drive"

Select the powerpoint.exe (or whatever it is from the list)

Click Next

Give it a name

Click Next

That should do it for you. If everything else works, excellent. Im not sure what would cause PP not to work. Again, I do not use Office if I can avoid it at all costs. lol

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
nmeyne Tuesday 2 April 2013 at 23:56
nmeyneAnonymous

Thanks, yes, I've tried that and it won't run this time, when it did previously. I think I will have to uninstall it all again in POL (I think POL and Wine are OK?) and then retry, staying as close to the previous install options as possible.

Thanks,

Nick
Ronin DUSETTE Tuesday 2 April 2013 at 23:58
Ronin DUSETTE
Admin

Yes. You had no POL errors, so you should be fine on that.

ALWAYS keep the basic install options. Dont change folders or anything.

Im glad that we are getting this at least a little closer to working. This could eventually go into a script to supplement the Office 2010 script, to support the SP1 patch. If we get it worked out, a script can be written, so it will be easier for everyone else. :)

Thank YOU, for your patience. I understand that its arduous.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
nmeyne Wednesday 3 April 2013 at 1:24
nmeyneAnonymous

I now know why the install seemed to worked better the first time! It's because I searched for and found the pre-existing script for the install which re-installs wine and handles all the icons properly. Sorry! VERY IMPORTANT to search for a script first and not use the 'non-listed program' option on the first install of 2010! This handles the complex 2010 install and program launching very nicely. Do not attempt to do it yourself as I did! I'm afraid I DID change an option in the install by removing Outlook (no folder changes or anything else) and it's possible that this caused knock-on errors...

On the upgrade to SP1, you need to follow your instructions above and run the sp1 exe in the virtual drive established by the original install script, but i suspect there is something missing, because I still get install errors. The SP1 update appears successful in that the version number has changed, but reports failure at the end. I think a companion script for the SP1 (or a generic 'handler' for any other nasty MS Office SP's) would be a good idea, even if only to stop the persistent moaning of those who cannot do without their latest 2010 and would not tolerate a messy upgrade.

The upgrade terminal output is here.... something nasty happens at the beginning... perhaps the nice script above leaves a few problems for the SP1 to inherit? Maybe my removal of Outlook upset it? Or perhaos the original supplied MSoffice script is not completely up to date (it does a lot of re-installing of stuff I thought I had already) Or missing something at the end... see below ...playonlinux.cfg?

nick@neptune:~$ playonlinux
[main] Message: PlayOnLinux (4.2.1) is starting
[clean_tmp] Message: Cleaning temp directory
[Check_OpenGL] Message: 32bits direct rendering is enabled
[Check_OpenGL] Message: 64bits direct rendering is enabled
[POL_System_CheckFS] Message: Checking filesystem for /home/nick/.PlayOnLinux/
[main] Message: Filesystem is compatible
[install_plugins] Message: Checking plug-in: Capture...
[install_plugins] Message: Checking plug-in: ScreenCap...
[install_plugins] Message: Checking plug-in: PlayOnLinux Vault...
[maj_check] Message: List is up to date
Traceback (most recent call last):
File "/usr/share/playonlinux/python/configure.py", line 599, in setwinedebug
playonlinux.SetSettings('WINEDEBUG', new_winedebug, self.s_prefix)
File "/usr/share/playonlinux/python/lib/playonlinux.py", line 89, in SetSettings
fichier = open(cfile,"r").readlines()
IOError: [Errno 2] No such file or directory: u'/home/nick/.PlayOnLinux//wineprefix/default/playonlinux.cfg'
Traceback (most recent call last):
File "/usr/share/playonlinux/python/configure.py", line 599, in setwinedebug
playonlinux.SetSettings('WINEDEBUG', new_winedebug, self.s_prefix)
File "/usr/share/playonlinux/python/lib/playonlinux.py", line 89, in SetSettings
fichier = open(cfile,"r").readlines()
IOError: [Errno 2] No such file or directory: u'/home/nick/.PlayOnLinux//wineprefix/default/playonlinux.cfg'
Traceback (most recent call last):
File "/usr/share/playonlinux/python/configure.py", line 599, in setwinedebug
playonlinux.SetSettings('WINEDEBUG', new_winedebug, self.s_prefix)
File "/usr/share/playonlinux/python/lib/playonlinux.py", line 89, in SetSettings
fichier = open(cfile,"r").readlines()
IOError: [Errno 2] No such file or directory: u'/home/nick/.PlayOnLinux//wineprefix/default/playonlinux.cfg'
[POL_System_CheckFS] Message: Checking filesystem for /home/nick/.adobe
[POL_Wine] Message: Running wine-1.5.16 /home/nick/.adobe (Working directory : /home/nick/.PlayOnLinux)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
wine: Invalid handle.
[POL_Wine] Error: Wine seems to have crashed

If your program is running, just ignore this message.
[POL_SetupWindow_Init] Message: Creating new window for pid 31787
FalseRegistered PID: 31547 (Missing)
Registered PID: 31787 (Missing)
nick@neptune:~$ playonlinux
[main] Message: PlayOnLinux (4.2.1) is starting
[clean_tmp] Message: Cleaning temp directory
[Check_OpenGL] Message: 32bits direct rendering is enabled
[Check_OpenGL] Message: 64bits direct rendering is enabled
[POL_System_CheckFS] Message: Checking filesystem for /home/nick/.PlayOnLinux/
[main] Message: Filesystem is compatible
[install_plugins] Message: Checking plug-in: Capture...
[install_plugins] Message: Checking plug-in: ScreenCap...
[install_plugins] Message: Checking plug-in: PlayOnLinux Vault...
Traceback (most recent call last):
File "/usr/share/playonlinux/python/configure.py", line 599, in setwinedebug
playonlinux.SetSettings('WINEDEBUG', new_winedebug, self.s_prefix)
File "/usr/share/playonlinux/python/lib/playonlinux.py", line 89, in SetSettings
fichier = open(cfile,"r").readlines()
IOError: [Errno 2] No such file or directory: u'/home/nick/.PlayOnLinux//wineprefix/default/playonlinux.cfg'
Traceback (most recent call last):
File "/usr/share/playonlinux/python/configure.py", line 599, in setwinedebug
playonlinux.SetSettings('WINEDEBUG', new_winedebug, self.s_prefix)
File "/usr/share/playonlinux/python/lib/playonlinux.py", line 89, in SetSettings
fichier = open(cfile,"r").readlines()
IOError: [Errno 2] No such file or directory: u'/home/nick/.PlayOnLinux//wineprefix/default/playonlinux.cfg'
Traceback (most recent call last):
File "/usr/share/playonlinux/python/configure.py", line 599, in setwinedebug
playonlinux.SetSettings('WINEDEBUG', new_winedebug, self.s_prefix)
File "/usr/share/playonlinux/python/lib/playonlinux.py", line 89, in SetSettings
fichier = open(cfile,"r").readlines()
IOError: [Errno 2] No such file or directory: u'/home/nick/.PlayOnLinux//wineprefix/default/playonlinux.cfg'
[maj_check] Message: List is up to date
[POL_System_CheckFS] Message: Checking filesystem for /home/nick/Documents/Software/Windows/English_Office_Professional_Plus_2010_W32_X17-75238/officesuite2010sp1-kb2460049-x86-fullfile-en-us.exe
[POL_Wine] Message: Running wine-1.5.16 /home/nick/Documents/Software/Windows/English_Office_Professional_Plus_2010_W32_X17-75238/officesuite2010sp1-kb2460049-x86-fullfile-en-us.exe (Working directory : /home/nick/.PlayOnLinux)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
fixme:heap:HeapSetInformation 0x110000 1 (nil) 0
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:storage:create_storagefile Storage share mode not implemented.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:dom_pi_get_attributes created dummy map for <?xml ?>
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:dom_pi_get_attributes created dummy map for <?xml ?>
err:mscoree:LoadLibraryShim error reading registry key for installroot
err:mscoree:LoadLibraryShim error reading registry key for installroot
err:mscoree:LoadLibraryShim error reading registry key for installroot
err:mscoree:LoadLibraryShim error reading registry key for installroot
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
fixme:advapi:SetNamedSecurityInfoW L"C:\\\\users\\\\Public\\\\Microsoft\\\\OfficeSoftwareProtectionPlatform\\\\" 1 -2147483644 (nil) (nil) 0x20bdbc4 (nil)
fixme:advapi:SetNamedSecurityInfoW L"C:\\\\users\\\\Public\\\\Microsoft\\\\OfficeSoftwareProtectionPlatform\\\\tokens.dat" 1 -2147483644 (nil) (nil) 0x20bdc5c (nil)
fixme:advapi:SetNamedSecurityInfoW L"C:\\\\users\\\\Public\\\\Microsoft\\\\OfficeSoftwareProtectionPlatform\\\\Cache\\\\" 1 -2147483644 (nil) (nil) 0x20bdbc4 (nil)
fixme:advapi:SetNamedSecurityInfoW L"C:\\\\users\\\\Public\\\\Microsoft\\\\OfficeSoftwareProtectionPlatform\\\\Cache\\\\cache.dat" 1 -2147483644 (nil) (nil) 0x20bdc6c (nil)
fixme:reg:RegSetKeySecurity :(0x10ac,4,0x20bca00): stub
fixme:reg:RegSetKeySecurity :(0x10b0,4,0x20bca00): stub
fixme:reg:RegSetKeySecurity :(0x10b4,4,0x20bca00): stub
fixme:reg:RegSetKeySecurity :(0x10b4,4,0x20bca00): stub
fixme:reg:RegSetKeySecurity :(0x10b4,4,0x20bca00): stub
fixme:reg:RegSetKeySecurity :(0x10ac,4,0x20bca00): stub
fixme:reg:RegSetKeySecurity :(0x10b0,4,0x20bca00): stub
fixme:reg:RegSetKeySecurity :(0x10b4,4,0x20bca00): stub
fixme:reg:RegSetKeySecurity :(0x10b4,4,0x20bca00): stub
fixme:reg:RegSetKeySecurity :(0x10ac,4,0x20bca00): stub
fixme:reg:RegSetKeySecurity :(0x10b0,4,0x20bca00): stub
fixme:reg:RegSetKeySecurity :(0x10ac,4,0x20bca00): stub
fixme:reg:RegSetKeySecurity :(0x10b0,4,0x20bca00): stub
fixme:reg:RegSetKeySecurity :(0x10ac,4,0x20bca00): stub
fixme:reg:RegSetKeySecurity :(0x10b0,4,0x20bca00): stub
fixme:reg:RegSetKeySecurity :(0x10b4,4,0x20bca00): stub
fixme:reg:RegSetKeySecurity :(0x10b4,4,0x20bdc30): stub
fixme:reg:RegSetKeySecurity :(0x10b8,4,0x20bdc30): stub
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:heap:HeapSetInformation 0x110000 0 0x33fde8 4
fixme:advapi:RegisterTraceGuidsW (0x1043d32, 0x14277e8, {bf3736e4-23ae-47c3-b472-a03c2c3550fe}, 1, 0x33fdd0, (null), (null), 0x14277f0,): stub
fixme:advapi:RegisterTraceGuidsW (0x1043d32, 0x1427808, {ff1671c8-2eea-42b3-8143-a8da2634c369}, 1, 0x33fdd0, (null), (null), 0x1427810,): stub
fixme:ole:CoInitializeSecurity ((nil),-1,(nil),(nil),0,3,(nil),0,(nil)) - stub!
fixme:advapi:RegisterEventSourceW ((null),L"Office Software Protection Platform Service"): stub
fixme:advapi:ReportEventW (0xcafe4242,0x0004,0x0000,0x40000384,(nil),0x0000,0x00000000,(nil),(nil)): stub
fixme:advapi:DeregisterEventSource (0xcafe4242) stub
fixme:advapi:RegisterTraceGuidsW (0x6f01b6a5, 0x6f15e4a8, {bf3736e4-23ae-47c3-b472-a03c2c3550fe}, 1, 0xa4e320, (null), (null), 0x6f15e4b0,): stub
fixme:advapi:RegisterTraceGuidsW (0x6f01b6a5, 0x6f15e4c8, {ff1671c8-2eea-42b3-8143-a8da2634c369}, 1, 0xa4e320, (null), (null), 0x6f15e4d0,): stub
fixme:advapi:RegisterEventSourceW ((null),L"Office Software Protection Platform Service"): stub
fixme:advapi:ReportEventW (0xcafe4242,0x0004,0x0000,0x4000042a,(nil),0x0001,0x00000000,0x1a8698,(nil)): stub
fixme:advapi:DeregisterEventSource (0xcafe4242) stub
fixme:advapi:RegisterEventSourceW ((null),L"Office Software Protection Platform Service"): stub
fixme:advapi:ReportEventW (0xcafe4242,0x0000,0x0000,0x40000386,(nil),0x0001,0x00000000,0x1547c0,(nil)): stub
fixme:advapi:DeregisterEventSource (0xcafe4242) stub
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
fixme:ole:NdrCorrelationInitialize (0xa59da54, 0xa59d654, 1024, 0x0): stub
fixme:rpc:NdrStubCall2 new correlation description not implemented
fixme:ole:NdrCorrelationFree (0xa59da54): stub
fixme:ole:NdrCorrelationInitialize (0xa59dc1c, 0xa59d81c, 1024, 0x0): stub
fixme:rpc:NdrStubCall2 new correlation description not implemented
fixme:ntdll:NtFsControlFile FSCTL_PIPE_IMPERSONATE: impersonating self
err:rpc:I_RpcReceive we got fault packet with status 0x80070241
fixme:ole:NdrCorrelationInitialize (0xa59d408, 0xa59d008, 1024, 0x0): stub
fixme:rpc:NdrStubCall2 new correlation description not implemented
fixme:ole:NdrCorrelationFree (0xa59d408): stub
err:msi:ITERATE_Actions Execution halted, action L"CAInstallSppPlugin.x86" returned 1603
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:msi:load_ttf_name_id Unable to open font file L"C:\\\\windows\\\\Fonts\\\\ARIALUNI.TTF"
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
fixme:advapi:SetNamedSecurityInfoW L"ose" 2 4 (nil) (nil) 0x6ff914 (nil)
fixme:advapi:SetNamedSecurityInfoW L"osppsvc" 2 4 (nil) (nil) 0x16c5b7c (nil)
fixme:advapi:SetNamedSecurityInfoW L"osppsvc" 2 4 (nil) (nil) 0x16c5b7c (nil)
fixme:advapi:SetNamedSecurityInfoW L"C:\\\\users\\\\Public\\\\Microsoft\\\\OfficeSoftwareProtectionPlatform\\\\" 1 4 (nil) (nil) 0x1ac247c (nil)
[POL_Wine] Error: Wine seems to have crashed

If your program is running, just ignore this message.
[POL_SetupWindow_Init] Message: Creating new window for pid 32491
fixme:advapi:RegisterEventSourceW ((null),L"Office Software Protection Platform Service"): stub
fixme:advapi:ReportEventW (0xcafe4242,0x0000,0x0000,0x40000387,(nil),0x0000,0x00000000,0x84e8c4,(nil)): stub
fixme:advapi:DeregisterEventSource (0xcafe4242) stub
[POL_SetupWindow_Close] Message: Closing window for pid 32491
[POL_Wine] Message: Wine return: 255

At this point the windows installer pop up returns 'update failed' when it appears to have been successful for at least the main parts of office.

So I think there is still something to look at here, but for many, I'm sure having working versions of most of 2010 at SP1 will be good enough until there is a script!

Thank you VERY MUCH for your help here.

Nick

Ronin DUSETTE Wednesday 3 April 2013 at 1:37
Ronin DUSETTE
Admin

I now know why the install seemed to worked better the first time! It's because I searched for and found the pre-existing script for the install which re-installs wine and handles all the icons properly. Sorry! VERY IMPORTANT to search for a script first and not use the 'non-listed program' option on the first install of 2010! This handles the complex 2010 install and program launching very nicely. Do not attempt to do it yourself as I did! I'm afraid I DID change an option in the install by removing Outlook (no folder changes or anything else) and it's possible that this caused knock-on errors...

Quote



Yeah. That is why we write scripts in the first place. :)

On the upgrade to SP1, you need to follow your instructions above and run the sp1 exe in the virtual drive established by the original install script, but i suspect there is something missing, because I still get install errors. The SP1 update appears successful in that the version number has changed, but reports failure at the end. I think a companion script for the SP1 (or a generic 'handler' for any other nasty MS Office SP's) would be a good idea, even if only to stop the persistent moaning of those who cannot do without their latest 2010 and would not tolerate a messy upgrade.

Quote


Yes. There will be issues. But if it works, it works. You will almost always get errors when running anything in wine. But if it works, it works.

A companion script is not an option, since the script should deal with the install itself. Most of it has to do with .NET, and since MS is so closed with anything, the open-source community has to figure it out on their own. Again, this is another reason I, and many others, do not use proprietary software; situations just like this. :)

As long as its installed, and the features work, that s good. The way that I told you to do it is how you would run ANY executable in that virtual drive. Its a basic of PlayOnLinux. A script would still need to be written to support the install of this upgrade in the same virtual drive where the original script installed Office 2010. You could always read the scripting documentation and write a script to install this patch.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
nmeyne Wednesday 3 April 2013 at 1:54
nmeyneAnonymous

Quote: "You could always read the scripting documentation and write a script to install this patch"

..maybe a retirement project, and by then the world will have moved off 2010 and onto open source tools and formats!

Good enough for now I think. Thanks!

N.
Ronin DUSETTE Wednesday 3 April 2013 at 2:15
Ronin DUSETTE
Admin

hahaha. well put, sir. well put.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
b00lean1337 Wednesday 3 April 2013 at 9:54
b00lean1337Anonymous

I had the same problem, I googled slipstream office 2010 sp1 and created a new install :)
Ronin DUSETTE Wednesday 3 April 2013 at 18:24
Ronin DUSETTE
Admin

Excellent. I totally forgot that you could do that. Good info!

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts