The forum

Xorg Crash

during steam client startup

Author Replies
spixx Sunday 28 April 2013 at 17:07
spixxAnonymous

Hello!
Hardware: Nvidia Geeforece 480
Dist: Centos-6.4
Kernel: 2.6.32-358.6.1.el6.x86_64
Graphical: kmod-nvidia-304xx-304.88-1.el6.elrepo.x86_64
nvidia-x11-drv-304xx-304.88-1.el6.elrepo.x86_64
nvidia-x11-drv-304xx-32bit-304.88-1.el6.elrepo.x86_64
Wine version: 1.5.29 and 1.5.26 (both 32 and 64 bits)

What happens: When starting Steam client the login window appears, when logging in the update occurs, but when "logging into steam blaha" happens Xorg crashes.

xsession-errors:<snip>
gnome-session: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
gnome-settings-daemon: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

<snip>

XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"^M
      after 1543 requests (1543 known processed) with 0 events remaining.^M
python: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"^M
      after 145 requests (137 known processed) with 0 events remaining.^M
nm-applet: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
[POL_Wine] ^[[1;34mMessage:^[[0m Wine return: 1
[POL_SetupWindow_Init] ^[[1;34mMessage:^[[0m Creating new window for pid 29616
No protocol specified
Unable to access the X Display, is $DISPLAY set properly?
Exception TypeError: 'join() takes exactly 2 arguments (1 given)' in <module 'threading' from '/usr/lib64/python2.6/threading.pyc'> ignored



Debug: <snip>
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
fixme:win:RegisterDeviceNotificationA (hwnd=0x200ac, filter=0x32e3ec,flags=0x00000004) returns a fake device notification handle!
fixme:win:RegisterDeviceNotificationW (hwnd=0x10110, filter=0x1089e9cc,flags=0x00000000) returns a fake device notification handle!
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
      after 1543 requests (1543 known processed) with 0 events remaining.
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
      after 145 requests (137 known processed) with 0 events remaining.
    
Full debug: debug.txt

Screen options: Running separate X server per screen with Xinerama

Suspects:

  • Nvidia settings, since I get unknow screen and the $DISPLAY problems.
  • ?!?

If more info might be needed please ask. Thanks in advanced!


petch Sunday 28 April 2013 at 18:48
petch
Developer

That's probably a video driver bug, see if you can upgrade it (at the moment latest stable is 310, latest beta 319).
Ronin DUSETTE Sunday 28 April 2013 at 19:17
Ronin DUSETTE
Admin

This is your problem right here. I will say it for sure:


Screen options: Running separate X server per screen with Xinerama

Quote


If you are running Xinerama, you get NO compositing on anything. Xinerama does not play well with this (Trust me. I lost many nights of sleep trying to get around this with a dual-card, 3+ monitor setup). As soon as Xinerama is activated, your nividia cards implementation of the Xinerama feature turns off Compositing automatically, and will not let both be on at once. Xinerama is being phased out slowly (as drivers mans. get more support for xrandr), but its still an issue.

If you are running Xinerama, you will NOT get graphics acceleration, and cannot play games. Period. This wont change until Mir finishes and we see what it can do, or if X.org completely removes Xinerama and ONLY uses XrandR, which is still going to be sometime away.

Turn of Xinerama, and try it on one monitor, and see if it works. Im almost positive you will see better results.

Also, I noticed that your Linux kernel is WAY out of date.

Yours is 2.6.32.

Newest stable is 3.8.10.

Just something that you may want to look at, as kernel updates usually have lots of bugfixes. This doesnt appear to be part of it, but I just wanted to make you aware of it. :)

PS: THANK YOU for posting up so much valid information. If you hadnt posted up your screen options, I never would have noticed that, and we would have been chasing our tails for quite a while. hahaha

Edited by RoninDusette


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
spixx Sunday 28 April 2013 at 19:41
spixxAnonymous

That's probably a video driver bug, see if you can upgrade it (at the moment latest stable is 310, latest beta 319).
Sadly I do not wish to build the drivers myself but I will await and see if I can find a more recent version in the testing branch

It actually "worked" with the TwinView option but then Xorg has only one big virtual screen moving the game screen to the far right of one of my two monitors.

Yours is 2.6.32.

Newest stable is 3.8.10.

Running CentOS like a boss ;) I do not like either the release of Fedora nor of Ubuntu. And I'm to lazy since the installer only works properly in Centos ;) I know my troubles would go away with a more Desktop-esk Dist but then again I could just as easily install windows then right :-).

I will see if I can upgrade to later kernel (this is not a huge problem) but the reason for the post was to see if I've missed anything since the more people checking up might see that "configThing=Yes" instead of "configThing=yes".

PS I know how troublesome it is to find info sometimes since I do know a bit about linux/UNIX I tend to post as much info as I can since it might help others in 10 years (don't you hate a post with your exact trouble saying "SOLVED" with no Info on how :).

I will try the changed screen settings (minus Xinerama).


spixx Sunday 28 April 2013 at 19:53
spixxAnonymous

Did not work better with the Twinview no xinerama either.

Xorg.conf

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 580"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "Stereo" "0"
Option "nvidiaXineramaInfoOrder" "DFP-3"
Option "metamodes" "DFP-0: nvidia-auto-select +1920+0, DFP-3: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection
Ronin DUSETTE Sunday 28 April 2013 at 19:55
Ronin DUSETTE
Admin

TwinView turns doesnt turn off Compositing, Xinerama does. Thats exactly what the problem is. :)

CentOS is just fine. I have no problem with that. hahaha. CentOS is one of the good ones. You dont have to run Ubuntu/debian (You know there are multiple versions of Ubuntu that have KDE, XFCE, LXDE, and other desktop environments, right?) or fedora or whatever. CentOS is dope.

But yeah. If you dont run Xinerama, it will work. For sure.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Sunday 28 April 2013 at 20:04
Ronin DUSETTE
Admin

Delete your x.org file and configure it directly from nvidia-settings

Trust me, that error was from composite being off. You even said that it worked before on twinview, which enforces that more.

You should really never had to go to the /etc/X11/xorg.conf file and do anything anymore, its old, and is really just there for legacy support. Delete, and then run nvidia-settings (as sudo) from your desktop, and configure it like that.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Sunday 28 April 2013 at 20:07
Ronin DUSETTE
Admin

It actually "worked" with the TwinView option but then Xorg has only one big virtual screen moving the game screen to the far right of one of my two monitors.

Quote


Yes, it will work in TwinView, but may not give the exact performance you are looking for. The error you posted was because Composite is off, because xinerama was activated.

Also, in your xorg.conf file, there is nothing in there to tell it to roll with twinview as opposed to xinerama. You have to actually explicitly state it.

That notwithstanding, you should really just delete your xorg.conf file, and let nvidia-settings build it for you.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Sunday 28 April 2013 at 20:10
Ronin DUSETTE
Admin

Here is the link from my thread on UbuntuForums regarding this issue. Most of it is based in xorg.conf configs, thinking that would get me around the issue. It didnt, and it caused more harm and headache than good. hahaha

http://ubuntuforums.org/showthread.php?t=2069419

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Sunday 28 April 2013 at 20:16
Ronin DUSETTE
Admin

Also, like I said, run it with one monitor on and one monitor only. no twinview, no xinerama, no multiple monitors. We need to test this at its base with only one monitor using the methods stated above (deleting the xorg.conf file and making a new one only through nvidia-settings).

Another method you can try is Nvidia's BASE MOSAIC mode. I cannot help you with that, but its has been reported to work, but not too well (Window managers cant differentiate between screens).

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
spixx Tuesday 30 April 2013 at 17:05
spixxAnonymous

Thanks for the responses.
I did as recommended and am now running twinview instead :) it works "almost" the thing that was the problem was the full-screen gaming, so in the end I started running the applications (TF2) in windowed borderless.

In the end the following xorg.conf is used (giving a bit wonky FPS though):

Section "Screen"

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 580"
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 580"
BusID "PCI:3:0:0"
Screen 1
EndSection


# Removed Option "metamodes" "DFP-0: nvidia-auto-select +0+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "Stereo" "0"
Option "nvidiaXineramaInfoOrder" "DFP-0"
Option "metamodes" "DFP-0: nvidia-auto-select +0+0, DFP-3: nvidia-auto-select +1920+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "Stereo" "0"
Option "metamodes" "DFP-3: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
Ronin DUSETTE Tuesday 30 April 2013 at 18:39
Ronin DUSETTE
Admin

Thats good. Glad you got it running.

Section "Extensions"
Option "Composite" "Enable"
EndSection

Quote


As a rule of them, declare things like this at the top of your xorg.conf file :)

Also, even if Composite was enabled right here, in xinerama, it is shut off (you can see it in the xorg log file). Sucks, because I want to use more monitors. haha

TwinView is not made for 3 monitors, and you are declaring 3 monitors but only 2 Screens, so it will format all kinds of wonky, just like you said. Unfortunately, at this time, there arent too many elegant workarounds. haha

Just remember, your best bet is to always just run your nvidia-settings to set this stuff, as it will automatically put what needs to be in the xorg.conf file without having to do it yourself. Save yourself the hassle. :) haha

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
rickyzhang Friday 5 July 2013 at 6:13
rickyzhangAnonymous

Hi guys,
I upgrade to Fedora 19 yesterday. Unfortunately GNOME 3.8 crashed. I check .xsession-erros:

gnome-session-is-accelerated: No composite extension.
gnome-session-check-accelerated: Helper exited with code 256
gnome-session-is-accelerated: No composite extension.
gnome-session-check-accelerated: Helper exited with code 256

** (process:6700): WARNING **: software acceleration check failed: Child process exited with code 1

** (gnome-session-quit:6866): WARNING **: Failed to call logout: The name org.gnome.SessionManager was not provided by any .service files

Mine is GTX590 with dual GPUs on the same card and using dual monitors. I'm using Xinerama in NVIDIA driver with latest version 319.32. In default, NVIDIA disable Composite extensions. I tried enabling composite and see how it goes. GNOME 3.8 can run but mouse pointer doesn't point to the right place. MATE runs perfectly.

I'm digging into Xorg.0.log. It said:
[ 13.580] (II) Module "ramdac" already built-in
[ 13.580] (WW) NVIDIA: The Composite and Xinerama extensions are both enabled, which
[ 13.580] (WW) NVIDIA: is an unsupported configuration. The driver will continue
[ 13.580] (WW) NVIDIA: to load, but may behave strangely.

Anyway, I'm not sure what is new in GNOME 3.8. But it must require something different from before.

I haven't tried TwinView yet. Can windows move across two X Screen in TwinView? I looked into example in NVIDIA driver README document. It seems to me that it uses the same GPU across two screens.
petch Friday 5 July 2013 at 13:03
petch
Developer

Using TwinView at home, I can indeed move windows between screens, no problem.
rickyzhang Friday 5 July 2013 at 16:16
rickyzhangAnonymous

Yes, I can confirm with that now. After reading NVIDIA document, I figure it out how to enable dual GPUs on Twinview. I'm using SLI here. Although both GPUs live in the same GTX590 card, it works. I can run GNOME 3.8 with composite extension on. glxgears can run across two monitors.

BTW, I think you can use Twinview on more than two monitors if using SLI. I found a sample in recent NVIDIA driver document (http://us.download.nvidia.com/XFree86/Linux-x86_64/319.32/README/sli.html)

Attached is my xorg.conf in case anyone need a sample to start with:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 319.32  (buildmeister@swio-display-x64-rhel04-14)  Wed Jun 19 15:50:37 PDT 2013

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 310.19  (buildmeister@swio-display-x86-rhel47-08.nvidia.com)  Thu Nov  8 02:08:55 PST 2012

Section "ServerLayout"
    Identifier     "Layout0"
    #Screen      0  "Screen0" 0 0
    Screen      0  "Screen0" 0 0
    #Screen      1  "Screen1" 1920 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    #Option         "Xinerama" "1"
    Option         "Xinerama" "0"
EndSection

Section "Files"
    FontPath        "/usr/share/fonts/default/Type1"
EndSection

Section "Module"
    Load           "extmod"
    Load           "dbe"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from data in "/etc/sysconfig/keyboard"
    Identifier     "Keyboard0"
    Driver         "keyboard"
    Option         "XkbLayout" "us"
    Option         "XkbModel" "pc105"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LG Electronics E2241"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "LG Electronics E2241"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 590"
    BusID          "PCI:3:0:0"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 590"
    BusID          "PCI:4:0:0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option          "SLI" "Mosaic"
    Option          "BaseMosaic" "True"
    Option          "metamodes" "GPU-0.DFP-0: 1920x1080+0+0, GPU-1.DFP-1: 1920x1080+1920+0"
#    Option         "metamodes" "nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option          "SLI" "Mosaic"
    Option          "BaseMosaic" "True"
    Option          "metamodes" "GPU-0.DFP-0: 1920x1080+0+0, GPU-1.DFP-1: 1920x1080+1920+0"
#    Option         "metamodes" "nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    #Option         "Composite" "Disable"
    Option         "Composite" "Enable"
EndSection

Ronin DUSETTE Saturday 6 July 2013 at 2:55
Ronin DUSETTE
Admin

This is not new. All dual GPUs can do that if they are in the same card. You actually dont even need to use the complicated xorg.conf that you used, unless your card supports BasicMosaic, which a lot of cards do not run. This is not SLI in a true sense.

The thing at hand, is you cannot communicate on 2 separate GPUs on 2 separate cards will NOT let Composite be enabled if Xinerama is on. BasicMosaic cannot be run between two different cards.

Really, if you have dual GPUs in the same card (or more exactly, 2 framebuffers), then you dont need to do any of this. Any Linux DE worth its salt will automatically pick it up.

For instance, I am now running an Nvidia GT 640, and have 2 monitors and a TV hooked up, using all 3 plugs in the back of it, and it runs at full acceleration, and is governed by the system itself (via xrandr and KDE's display settings), which is all plug and play.


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
You are here: Index > PlayOnLinux > Xorg Crash