The forum

POL cannot find file "curl (from cURL)"

program won't start without it

Author Replies
Fuzzy Penquin Friday 10 May 2013 at 6:04
Fuzzy PenquinAnonymous

Hi guys, I'm new to Play on Linux and Wine. I just installed Wine, then POL v4.1, both from my software repository. When I opened up Play on Linux, it started up and as it did so it mentioned that two specific files were missing (I don't remember which ones), but continued to boot up. Once up it said a new version was available (v4.2) so I figured it would be good to update it. I came here and downloaded the Ubuntu .deb files in the downloads section of this website. After a clean and problem-free installation I attempted to start the new version....well, it gave me the error "cannot find curl (from cURL)" and said that it can't start without it, and thus it didn't start. So I uninstalled and tried the generic file download off the same Downloads page. Same result: "can't find curl (from cURL)".

Are my files corrupted, or am I missing something (a possibility)? How do I get "curl" and where do I put it? Should I go back to the older version in my software repository, since that one appeared to work (i.e., it started up)?

My computer is running Linux Mint v14 (Ubuntu-based). I've only been using Linux for a few months now, so I'm new to that as well....

Fuzzy Penquin
petch Friday 10 May 2013 at 7:03

Install the package named curl, it's missing from dependencies (
Fuzzy Penquin Sunday 12 May 2013 at 3:54
Fuzzy PenquinAnonymous

Hi Petch,

Thank you for your quick reply and the link. I went to that page, but didn't find a download option, only found a description of the bug and it's patch. Is there a page element that my browser might be blocking? I'm running Firefox with NoScript and Ad Block Plus. I disabled NoScript and nothing changed, and the only thing Ad Block Plus seems to be blocking is an ad on the left-hand margin under the "Ads" heading. Am I missing something?

Sorry to be such a slow newbie! Your help is very appreciated. :-)

-Fuzzy Penquin
petch Sunday 12 May 2013 at 8:59

That was a link to the problem description alright, it's not fixed yet.
What you need to do is install curl, that's all.
Fuzzy Penquin Monday 13 May 2013 at 4:01
Fuzzy PenquinAnonymous

Oh, LOL, glad to know I wasn't missing something then. :-) Ok where/how do I get curl? I really have no idea what I'm doing just yet, so I'm hoping that this isn't going to require a trip into Terminal since I don't yet have any understanding of it.

Thanks for your patience! :-)
Ronin DUSETTE Tuesday 14 May 2013 at 17:41

open a terminal and type:

sudo apt-get install curl

Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Fuzzy Penquin Thursday 16 May 2013 at 5:11
Fuzzy PenquinAnonymous

Yay! Thank you for the code snippet and help, my POL v4.2 starts up now. :-)

Hopefully I can take it from here without having to bug you guys for more help, LOL. Thanks again! :-)
petch Thursday 16 May 2013 at 13:07

By the way the latest is 4.2.1 and it fixes one or two annoying bugs (main one being broken scripts list updates)