The forum

World of Tanks Low FPS

Author Replies
Jump to the page: 1 - 2 - 3
didymos Wednesday 31 July 2013 at 0:51
didymosAnonymous

So it means that playonlinux will always use Intel rather than NVIDIA chipset?
When I install this drivers after starting game I got:

[POL_SetupWindow_Init] Message: Creating new window for pid 10786
[POL_Call] Message: Calling POL_Install_VideoDriver
[POL_Call] Message: ----- Starting function POL_Install_VideoDriver -----
[POL_GPG_auth_script] Message: Checking signature of POL_Install_VideoDriver
[POL_GPG_install_key] Message: Importing PlayOnLinux public key
[POL_Source] Message: POL GPG : Good signature
[POL_Wine_SetVideoDriver] Message: Set wine video driver
[POL_LoadVar_Device] Message: Gettings GPU informations
[POL_SetupWindow_menu] Message: menu answer: 01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 540M] (rev a1)
[POL_LoadVar_Device] Message: VendorID : 10de
[POL_LoadVar_Device] Message: DeviceID : 0df4
[POL_Wine_SetVideoDriver] Message: Detected video driver: nv4_disp.dll
[POL_Wine] Message: Running wine-1.5.24 regedit /home/didymos/.PlayOnLinux//tmp/VGA_ID_fix.reg (Working directory : /home/didymos/.PlayOnLinux/tmp)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
fixme:ntdll:NtConnectPort (0x5b0c1170,L"\\\\ThemeApiPort",0x33eefc,(nil),(nil),(nil),0x33ef0c,0x33ef08),stub!
fixme:ntdll:NtConnectPort (0x5b0c1170,L"\\\\ThemeApiPort",0x33e64c,(nil),(nil),(nil),0x33e65c,0x33e658),stub!
[POL_Wine] Message: Wine return: 0
[POL_Call] Message: ----- Ending function POL_Install_VideoDriver -----
[POL_SetupWindow_Close] Message: Closing window for pid 10786
Ronin DUSETTE Wednesday 31 July 2013 at 1:33
Ronin DUSETTE
Admin

It shouldnt. Installing this should tell it to use the nvidia card, but I believe Petch mentioned something that he had to fix in order to get this working.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
petch Wednesday 31 July 2013 at 1:47
petch
Developer

The point of this component is just to set a hint in the registry about what videocard is "installed". In the end, it's up to Wine and/or to the applications to take into account this hint and adjust what features they use from DirectX or OpenGL;
And in the case of DirectX, they'll always be Wine translating it to OpenGL in the middle, so how those changes based on a hint translate into modifications of the OpenGL calls received by the video driver are... complex, if not random.
So there's no guarantee that it has any positive effect.

Edited by petch

Ronin DUSETTE Wednesday 31 July 2013 at 1:51
Ronin DUSETTE
Admin

Ah. Is this specifically because of the AMD card and the integrated graphics being on the same system, right? I know bumblebee or whatever is supposed to do that nvidia cards, but isnt there some solution for AMD cards?

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
petch Wednesday 31 July 2013 at 1:54
petch
Developer

[POL_LoadVar_Device] Message: Gettings GPU informations
[POL_SetupWindow_menu] Message: menu answer: 01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 540M] (rev a1)
[POL_LoadVar_Device] Message: VendorID : 10de
[POL_LoadVar_Device] Message: DeviceID : 0df4
[POL_Wine_SetVideoDriver] Message: Detected video driver: nv4_disp.dll


From what I can read, when called in an interactive context, my change worked as intended.
Ronin DUSETTE Wednesday 31 July 2013 at 1:54
Ronin DUSETTE
Admin

I looked it up, and it looks like you can use the optirun command to make it choose the better card.

Its worth trying, I think, but Im unsure of how to use optirun before launching a POL installed app.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
petch Wednesday 31 July 2013 at 1:56
petch
Developer

Simply as
$ optirun playonlinux

There was a failed attempt at adding an optirun/primusrun/... integration into PoL, which failed, so there's nothing more specific at present time.
Ronin DUSETTE Wednesday 31 July 2013 at 1:57
Ronin DUSETTE
Admin

http://www.playonlinux.com/en/topic-8888-DIABLO_III_Using_Optirunbumblebee_in_3_steps.html

Yeah. That was about the simplest thing that I can find for it.

Hopefully if he tries that, it will work.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
petch Wednesday 31 July 2013 at 1:59
petch
Developer

From what I read (Sunday 28 July 2013 at 20:37 message) he already did.
Ronin DUSETTE Wednesday 31 July 2013 at 2:00
Ronin DUSETTE
Admin

Ah. Sorry. Im a little scatterbrained right now. Got some bad news at work and my headset is dead, so I cannot even work. Its got me in a mood, so to speak. Sorry. lol

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
didymos Wednesday 31 July 2013 at 18:53
didymosAnonymous

thanks guys for discussion.
Yes, I was using optirun as well as primus without any progress...
Ronin DUSETTE Thursday 1 August 2013 at 1:52
Ronin DUSETTE
Admin

I dont know what to tell ya, then.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
petch Sunday 22 September 2013 at 11:57
petch
Developer

There's a patched Wine 1.5.9-WorldOfTanks, does it work any better than the plain 1.5.24 used by the script?
geertt2 Sunday 22 September 2013 at 14:05
geertt2Anonymous

With 1.5.9-WorldofTanks Wine, I am unable to connect to the server. I type in my password, fails to connect to network, clients auto closes. I am using Ubuntu 12.04 LTS Precise. If anyone is able to help.

Also, I am getting low fps with my nvidia 260 card as well when running Wine 1.5.24. I believe I am running with the 319 post prelease version of nvidia drivers.

Edited by geertt2

petch Sunday 22 September 2013 at 14:40
petch
Developer

If you can connect with 1.5.24, maybe it's time for a build of this patch on top of a newer version of Wine than 1.5.9?
geertt2 Monday 23 September 2013 at 8:46
geertt2Anonymous

If you can connect with 1.5.24, maybe it's time for a build of this patch on top of a newer version of Wine than 1.5.9?

Quote from petch

I am able to connect with 1.5.24 however, 1.5.24 does not have the "raw and performance" patch that 1.5.9 does if I am do understand winehq correctly.

I think the situation is 1.5.24 works however have performance issues which was patched in 1.5.9-Worldoftanks (disable-dynamic-vertex-buffers.patch). But so far I haven't found a reason as to why I am unable to connect to server with the 1.5.9 version of wine. Im going to test it again.

Edit: I tested the 1.5.9-World of tanks wine build and again have have the same situation I mentioned above. I typed in my password, it fails to connect to network (world of tanks server) but was able to connect to the update server at launcher just fine for some reason. Anyone else encounter similar problems?

Edited by geertt2

JuanLuna Monday 7 October 2013 at 13:15
JuanLunaAnonymous

hi.. how did you install World of tanks on linux(Playonlinux).. uppon patching i always got this critical error: an unhandled exception is occurd the application will be restarded. can anyone help me.newbie here. thanks in advance

BTW im using ubuntu12.04LTS

and my pc specs:
AMD FX(tm)-4100 Quad-Core Processor × 4
ATI HD5570 Sapphire
12GB of Ram
xpander Monday 7 October 2013 at 18:20
xpander

get a wine 1.7.1 with d3d command stream patches and it will run super good.
arch users can grab from here: https://aur.archlinux.org/packages/wine-d3dstream/

video: http://www.youtube.com/watch?v=HUO1ohc_PCM

Edited by xpander

petch Monday 7 October 2013 at 21:45
petch
Developer

Is that the same as 1.7.1-CSMT Wine build in PoL?
xpander Tuesday 8 October 2013 at 5:13
xpander

Is that the same as 1.7.1-CSMT Wine build in PoL?

Quote from petch


i think so.

CSMT is the registry key needed also (Content Stream Multi Threading)