The forum

The Sims 3

"Device 0 cannot run this title"

Author Replies
Jitterro Wednesday 29 May 2013 at 21:45
JitterroAnonymous

Hi!

First off, a disclaimer - total n00b here. I apologize for the potential incoherency of my posts.

I'm running Debian 6.0. I've been trying to get The Sims 3 running with PlayOnLinux 4.2.1, and I've managed to install it successfully from the game disc. However, when I try to run the game, I get this error message as a pop-up:

Unable to start game

Device 0 cannot run this title.
No supported graphics card detected. Please check your system hardware.

Quote


I have an NVIDIA GT218 GeForce210, which should be fine, I think. I've updated to the proprietary binary drivers, but the same error message still appears.

Here's the message that the debugger gives me:

Direct3D9 is not available without OpenGL.

Quote


Unfortunately, I've lost track of everything I've done in trying to get this to work. I know I've tried running 32-bit to no avail. After reading this thread, I wondered if it was because I'm using two monitors (I seem to recall some resolution issues with The Sims 3 in Wine), but I'm not using TwinView.

Any ideas? Again, really sorry if I'm not making much sense. I'll try to explain as best as I can. I'm also sorry if somebody's posted a solution before; I can't figure out how to search the forums...
Ronin DUSETTE Wednesday 29 May 2013 at 22:27
Ronin DUSETTE
Admin

The debugger puts out a lot more information than that... lol

If you are using 2 monitors, and they arent in twin view, then they are in Xinerama, and hence compositing is disabled. There is no way around this. Try running only one monitor plugged in or in twinview.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Jitterro Wednesday 29 May 2013 at 23:27
JitterroAnonymous

The debugger puts out a lot more information than that... lol

If you are using 2 monitors, and they arent in twin view, then they are in Xinerama, and hence compositing is disabled. There is no way around this. Try running only one monitor plugged in or in twinview.

Quote from DJYoshaBYD


I've now tried running only one monitor, switching to TwinView, and running one monitor with Twinview. I'm still getting the same error.

The debugger did output more lines than that, but they were just the line I quoted repeated.

Edited by Jitterro

Jitterro Thursday 30 May 2013 at 1:31
JitterroAnonymous

So according to EA, running the game in "windowed mode" may help. The problem I'm now having is that I can't locate this "Options.ini" file that they're talking about. There is an "Electronic Arts" file in my home folder, but Options.ini is nowhere to be found. I can't find it anywhere in the disc files either.

Sorry to keep bringing this up, but I've been reading a lot about The Sims lately and am now obsessed with getting this to work.

EDIT: All I'm seeing in The Sims 3 folder is "DeviceConfig.log." It's blank upon opening.

Edited by Jitterro

You are here: Index > PlayOnLinux > The Sims 3