The forum

Warcraft 3 LAN problem

From Mac to Mac

Author Replies
YeaTii Friday 31 May 2013 at 19:27
YeaTiiAnonymous

Hello,

my GF and me installed warcraft 3 on our Macs without any problem, we can play the campaign but it's impossible to host a LAN game from any of our Mac !

we could play with 2 Macs connected to a windows hosting the game but impossible to host from the our Mac ! As we only have Mac at home, we can't play LAN together :(

The created game shows in the list, I can select it and click "join game" but then it takes time and finally says "Unable to join specified game. Please try ...".

Before you ask, I did disable all possible firewalls...

any ideas ?


Edited by YeaTii

Ronin DUSETTE Friday 31 May 2013 at 19:38
Ronin DUSETTE
Admin

Do you have SAMBA installed? That has a bunch of packages related to networking. That could possibly be an issue. OSX doesnt come with SAMBA anymore, so this might help.

You can get it here:

https://www.macupdate.com/app/mac/41541/smbup

Also, post up the debug output from trying to run it so we can see if it outputs any errors to the terminal.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
YeaTii Saturday 1 June 2013 at 16:42
YeaTiiAnonymous

thanks for the fast answer !

I have osx 10.8.3 on both machine and I activated a share on each with the samba provided by Apple.

So OSX does come with samba but maybe I should try this samba you told me ?

here is the logs from the machine trying to connect (the hosting machine doesn't have any error log neither, just the same line about running the game ...):  

[06/01/13 16:28:49] - Running wine-1.2.3 Frozen Throne.exe (Working directory : /Users/tii/Library/PlayOnMac/wineprefix/WarcraftIII/drive_c/Program Files/Warcraft III Reign of Chaos & The Frozen ThronXIO:  fatal IO error 35 (Resource temporarily unavailable) on X server "/tmp/launch-m1aZjJ/org.macosforge.xquartz:0"


      after 2638 requests (2638 known processed) with 0 events remaining.


X connection to /tmp/launch-m1aZjJ/org.macosforge.xquartz:0 broken (explicit kill or server shutdown).


[06/01/13 16:33:23] - Running wine-1.2.3 Frozen Throne.exe (Working directory : /Users/tii/Library/PlayOnMac/wineprefix/WarcraftIII/drive_c/Program Files/Warcraft III Reign of Chaos & The Frozen Thron

Ronin DUSETTE Saturday 1 June 2013 at 18:45
Ronin DUSETTE
Admin

OSX does not come stock with SAMBA anymore. Thats why MacUpdates has it on there. Your version either just happened to come with it or its been installed previously. New version of OSX omit SAMBA.

As for that, its having issues connecting to xquartz.

There has to be more to the debug output than that, as the full debug output shows your system specs. post all of it, please.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
YeaTii Sunday 2 June 2013 at 15:54
YeaTiiAnonymous

Sorry to tell you this again but OSX does comes with Samba built-in as you can see here : http://support.apple.com/kb/ht1627 
If you go in sharing, you can activate Samba shares built-in !

anyway, I desactivated these osx samba shares I previously made, I installed samba via smbUp as you asked on both machines, I set up shares on both machine too and I tried again with the same result !

As for the debug output, I followed your instruction from this post : 


and here is my log for this virtual drive :

[06/02/13 15:29:28] - Running wine-1.2.3 Frozen Throne.exe (Working directory : /Users/tii/Library/PlayOnMac/wineprefix/WarcraftIII/drive_c/Program Files/Warcraft III Reign of Chaos & The Frozen Thron

[06/02/13 15:34:24] - Running wine-1.2.3 BattleLANv0.5.exe (Working directory : /Users/tii/Library/PlayOnMac/wineprefix/WarcraftIII/drive_c/Program Files/Warcraft III Reign of Chaos & The Frozen ThronForwarding...


socket Error:10044


and here is the log from the install script : 


PlayOnLinux debbuging tool (v4.1.8)

-----------------------------------------------

Debugging: Warcraft III - Reign Of Chaos


Warning. This is a PlayOnLinux script logfile. It does not contains everything that happened in your program virtual drive (wineprefix)

Please do not use this logfile on winehq forum, this logfile is not interesting for wine debugging.


Date: 12/19/12 22:03:18


> uname -a

  Darwin Chewbacca.local 12.2.1 Darwin Kernel Version 12.2.1: Thu Oct 18 16:32:48 PDT 2012; root:xnu-2050.20.9~2/RELEASE_X86_64 x86_64

> lsb_release -a

  

> wine --version (Be careful, this version might not be the version used 

in the script. Read the content of this file for more information)

  wine-1.4

> glxinfo \\| grep rendering

  direct rendering: Yes

> glxinfo \\| grep renderer

  OpenGL renderer string: NVIDIA GeForce GT 650M OpenGL Engine

> OpenGL libs

  

  

> export

  declare -x AMD64_COMPATIBLE="False"

declare -x APPLICATION_TITLE="PlayOnMac"

declare -x ARGVZERO="./playonmac.real"

declare -x Apple_PubSub_Socket_Render="/tmp/launch-kbKakA/Render"

declare -x Apple_Ubiquity_Message="/tmp/launch-abXUFi/Apple_Ubiquity_Message"

declare -x COMMAND_MODE="unix2003"

declare -x DEBIAN_PACKAGE="FALSE"

declare -x DESKTOP="/Users/tii/Desktop"

declare -x DISPLAY="/tmp/launch-ZbIZyu/org.macosforge.xquartz:0"

declare -x DONT_MONITOR="1"

declare -x DYLDPATH_ORIGIN="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/tools/lib/dyld:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/lib:/Applideclare -x DYLD_LIBRARY_PATH="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/tools/lib/dyld:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/lib:/Appdeclare -x EXECUTABLEPATH="/Applications/PlayOnMac.app/Contents/MacOS/./playonmac.real"

declare -x GECKO_SITE="http://www.playonlinux.com/wine/gecko"

declare -x GNUPGHOME="/Users/tii/Library/PlayOnMac//gpg"

declare -x HOME="/Users/tii"

declare -x IGNORE_ICON_DIR="false"

declare -x LANG="en_BE.UTF-8"

declare -x LD_LIBRARY_PATH="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/wine/lib/:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/lib:/Applicatiodeclare -x LD_PATH_ORIGIN="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/wine/lib/:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/lib:/Applicationdeclare -x LOGNAME="tii"

declare -x MACHTYPE="x86_64-apple-darwin12"

declare -x MAGICK_HOME="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/"

declare -x MD5_COMMAND="md5"

declare -x OLDPWD="/Users/tii/Library/PlayOnMac/plugins"

declare -x OSX_SUB_VERSION="2"

declare -x OSX_VERSION="12"

declare -x OS_NAME="darwin"

declare -x OpenGL32="1"

declare -x OpenGL64="1"

declare -x PATH="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/wine/bin:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/bin:/Applications/PlayOnMacdeclare -x PATH_ORIGIN="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/wine/bin:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/bin:/Applications/Pldeclare -x PLAYONLINUX="/Applications/PlayOnMac.app/Contents/Resources/playonlinux"

declare -x PLAYONMAC="/Applications/PlayOnMac.app/Contents/Resources/playonlinux"

declare -x POL_ARCH="x86"

declare -x POL_COOKIE="rLC74bu2Y6hUN3vLobHu"

declare -x POL_DNS="playonmac.com"

declare -x POL_HOST="127.0.0.1"

declare -x POL_ID="94390155"

declare -x POL_LANG="en"

declare -x POL_OS="Mac"

declare -x POL_PORT="30000"

declare -x POL_SetupWindow_ID="37898"

declare -x POL_TERM="xterm"

declare -x POL_UPTODATE="TRUE"

declare -x POL_USER_ROOT="/Users/tii/Library/PlayOnMac/"

declare -x POL_WGET="wget --prefer-family=IPv4 -q"

declare -x PWD="/Users/tii/Library/PlayOnMac"

declare -x PYTHONHOME="/Applications/PlayOnMac.app/Contents/Resources"

declare -x PYTHONPATH="/Applications/PlayOnMac.app/Contents/Resources"

declare -x REPERTOIRE="/Users/tii/Library/PlayOnMac/"

declare -x RESOURCEPATH="/Applications/PlayOnMac.app/Contents/Resources"

declare -x RLANG="en_BE.UTF-8"

declare -x SCRIPTID="Warcraft III: Reign of Chaos"

declare -x SETUPWINDOW_INIT="true"

declare -x SHELL="/bin/bash"

declare -x SHLVL="4"

declare -x SITE="http://repository.playonlinux.com"

declare -x SSH_AUTH_SOCK="/tmp/launch-2Lmty6/Listeners"

declare -x TEXTDOMAIN="pol"

declare -x TEXTDOMAINDIR="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/lang/locale/"

declare -x TITLE="Warcraft III - Reign Of Chaos"

declare -x TITRE="PlayOnMac"

declare -x TMPDIR="/var/folders/qt/vwns8s3d4yq7ssrjfzpmdhp40000gn/T/"

declare -x USER="tii"

declare -x VERSION="4.1.8"

declare -x WGETRC="/Users/tii/Library/PlayOnMac//configurations/wgetrc"

declare -x WINEDLLOVERRIDES="winemenubuilder.exe=d"

declare -x WINEPREFIX="/Users/tii/Library/PlayOnMac//wineprefix/default"

declare -x WINE_SITE="http://www.playonlinux.com/wine/binaries"

declare -x __CF_USER_TEXT_ENCODING="0x1F5:0:0"



12/19/12 22:03:25 - [POL_Wine_SelectPrefix] Message: Selecting prefix: WarcraftIII

12/19/12 22:03:30 - [POL_SetupWindow_InstallMethod] Message: Install method: LOCAL

12/19/12 22:03:56 - [POL_Wine_PrefixCreate] Message: Setting POL_WINEVERSION to 1.2.3

12/19/12 22:03:56 - [POL_Wine_PrefixCreate] Message: Creating prefix (1.2.3)...

12/19/12 22:03:56 - [POL_Wine_PrefixCreate] Message: Using wine 1.2.3

12/19/12 22:03:56 - [POL_Wine_InstallVersion] Message: Installing wine version path: 1.2.3, x86

12/19/12 22:03:57 - [POL_Config_PrefixWrite] Message: Prefix config write: ARCH x86

12/19/12 22:03:57 - [POL_Config_PrefixWrite] Message: Prefix config write: VERSION 1.2.3

12/19/12 22:03:57 - [POL_Wine] Message: Running wine-1.2.3 --version (Working directory : /Users/tii/Library/PlayOnMac)

12/19/12 22:03:57 - [POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html

wine-1.2.3

12/19/12 22:03:57 - [POL_Wine] Message: Wine return: 0

12/19/12 22:04:01 - [POL_LoadVar_PROGRAMFILES] Message: Getting Program Files name

12/19/12 22:04:01 - [POL_Wine] Message: Running wine-1.2.3 cmd /c echo %ProgramFiles% (Working directory : /Users/tii/Library/PlayOnMac)

12/19/12 22:04:01 - [POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html

C:\\Program Files


12/19/12 22:04:01 - [POL_Wine] Message: Wine return: 0

12/19/12 22:04:04 - [POL_LoadVar_PROGRAMFILES] Message: Getting Program Files name

12/19/12 22:04:04 - [POL_Wine] Message: Running wine-1.2.3 cmd /c echo %ProgramFiles% (Working directory : /Users/tii/Library/PlayOnMac)

12/19/12 22:04:04 - [POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html

C:\\Program Files


12/19/12 22:04:04 - [POL_Wine] Message: Wine return: 0

12/19/12 22:04:04 - [Set_Managed] Message: Setting wine managed: Off

12/19/12 22:04:04 - [POL_Wine] Message: Running wine-1.2.3 regedit /Users/tii/Library/PlayOnMac//tmp/regkey.reg (Working directory : /Users/tii/Library/PlayOnMac)

12/19/12 22:04:04 - [POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html

12/19/12 22:04:04 - [POL_Wine] Message: Wine return: 0

12/19/12 22:04:05 - [POL_Wine] Message: Running wine-1.2.3 /Volumes/Share/SOFTWARE/GAMES/Warcraft III Reign of Chaos & The Frozen Thron/Warcraft III Reign of Chaos & The Frozen Throne.exe (Working dir12/19/12 22:12:20 - [POL_Wine] Message: Wine return: 0

12/19/12 22:12:24 - [POL_Wine_Direct3D] Message: Setting wine Direct3D /Users/tii/Library/PlayOnMac//wineprefix/WarcraftIII VideoMemorySize 4096

12/19/12 22:12:24 - [POL_Wine] Message: Running wine-1.2.3 regedit /Users/tii/Library/PlayOnMac//tmp/regkey.reg (Working directory : /Users/tii/Library/PlayOnMac)

12/19/12 22:12:24 - [POL_Wine] Message: Wine return: 0

12/19/12 22:12:24 - [POL_SetupWindow_AutoApp] Message: Making .app  ()

12/19/12 22:12:25 - [POL_Shortcut] Message: Shortcut created: Warcraft III.exe Warcraft III - Reign Of Chaos

12/19/12 22:12:25 - [POL_SetupWindow_Close] Message: Closing window for pid 37898

Ronin DUSETTE Sunday 2 June 2013 at 19:41
Ronin DUSETTE
Admin


Sorry to tell you this again but OSX does comes with Samba built-in as you can see here : http://support.apple.com/kb/ht1627
If you go in sharing, you can activate Samba shares built-in !

Quote


Sorry to tell you, but YOUR version of OSX happens to have samba. It was removed in later versions. I know this because I have to tell people how to install it multiple times per day.

Read:
http://community.spiceworks.com/how_to/show/27815-os-x-10-7-and-later-and-samba-server-and-client-clearing-some-confusion

Trust me. Yours has it because you installed it before or it installed with something else. Im not here to argue a method of troubleshooting that I used multiple times per day...


declare -x VERSION="4.1.8"

Quote


Your PlayOnMac versionis painfully out of date. Upgrade it, and this might fix some of the issues. Get from the download section of our website.

The debug log that you posted is from the install. The install went fine, but we need the running logs.

Edited by RoninDusette


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
YeaTii Monday 21 April 2014 at 14:41
YeaTiiAnonymous

First of all, thank you again for spending time on this,

my version of osx did not "happen to have samba", Apple has always included it's own implementation of it for networking with Windows since before I even bought my first Mac !

But the problem doesn't seem to be there as I tried with the "real" Samba and still did not work ...

now,almost one year later, I have now OSX 10.9 Maverick and Apple implemented SMB2 protocol now but it's still not working.

Still I can be a guest on Windows host but I can't host a game :(

I really have no clue why...