The forum

Impossibe d'installer PlayOnLinux

Author Replies
Wizard50 Friday 8 February 2008 at 20:11
Wizard50Anonymous

Bonjour à tous ,
Donc voila déja ne m'en veuiller pas si je ne suis pas assez clair dans mes propos mais je débute sous Linux

Bon alors voila j'ai récemment acheté un EEE PC ( pour les non g33k qui ne savent pas ce que c'est, voir ici : http://www.blogeee.net/2007/09/19/asus-eee-701-le-test-partie-i/ ) et je dois avouer que comme pas mal de nouveau utilisateurs, j'aimeraient pouvoir jouer à quelques vieux jeux style Age Of Mythologie, etc ...
Alors déja la première étape à été d'installer Wine ( nickel car quand je tape " winecfg " dans la console, l'utilitaire de configuration de wine se lance ).
Le problème vient dans l'installation du paquet PlayOnLinux : impossible de l'installer via le Gestionnaire de Paquet Synaptic dont voici le message d'erreur dans son integralité :

" playonlinux:

Le paquet playonlinux n'est pas disponible bien qu'il soit listé dans la base de données.
Les explications possibles sont que le paquet est listé dans les dépendances sans jamais avoir été publié, qu'il est devenu obsolète ou qu'il n'est pas disponible sur les dépôts vers lesquels pointe le fichier sources.list "

Je ne me souviens plus comment j'ai fait via la console mais j'ai le même type d'erreur. La distribution est Xandros, un os basé sur Debian et le bureau doit être KDE.
Donc voila si quelqu'un pouvait m'aider, ce serait cool je suis ouvert à tout réponse
Bonne soirée
Zoloom Friday 8 February 2008 at 20:31
ZoloomAnonymous

Pour ajouter ce dépôt, vous pouvez utiliser les commandes suivantes :
sudo wget http://playonlinux.botux.net/playonlinux.list -O /etc/apt/sources.list.d/playonlinux.list
sudo apt-get update


Ou tout simplement ajouter la ligne suivante dans /etc/apt/sources.list
deb http://playonlinux.botux.net/ gutsy main


Les paquets disponibles sont playonlinux et playonlinux-dosbox-support

Quote


Salut ,

Installe le dépôt de cette façon, et ça devrait trouver les paquets.

Wizard50 Friday 8 February 2008 at 20:49
Wizard50Anonymous

La première méthode à l'air de fonctionner ( quoique j'ai une erreur au niveau de Wine : " W: GPG error: http://wine.budgetdedicated.com etch Release: Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 58403026387EE263 " )
Merci bien de ta réponse !

Sinon je suis curieux, comment lance t'on PlayOnLinux maintenant ? xD
Parce que y'a rien d'installer dans le menu ( comme d'hab avec Linux quoi ^^ ) et je ne connait pas bien la hiérarchie des fichiers sinon j'aurais été jeter un coup d'oeil dans Program Files )
Zoloom Friday 8 February 2008 at 20:56
ZoloomAnonymous

Chez moi (Ubuntu) PlayOnLinux est dans le menu Jeux > PlayOnLinux

Au pire, tape :

playonlinux

Dans un terminal.

Bon jeu

Edited by Zoloom


Wizard50 Friday 8 February 2008 at 22:26
Wizard50Anonymous

Mmmmmmmmmmh ultime vérification du menu et toujours pas de PlayOnLinux, la commande PlayOnLinux ne donne rien via la Console ni via At+F2 ...
Aymeric P. Friday 8 February 2008 at 23:13
Aymeric P.
Admin

Pour l'histoire de la clef GPG wine faire ceci :
wget -q http://wine.budgetdedicated.com/apt/387EE263.gpg -O- | sudo apt-key add -

Pour playonlinux que donne le résultat de la commande
aptitude show playonlinux (peut être a lancer en temps que root - sudo -)

Former member.
Zoloom Friday 8 February 2008 at 23:21
ZoloomAnonymous

Réinstalle c'est pas normal, t'a bien fait sudo apt-get update && sudo apt-get install playonlinux ?

Quentin PÂRIS Friday 8 February 2008 at 23:21
Quentin PÂRIS
Admin

PlayOnLinux c'est pas la bonne commande.

playonlinux c'est la bonne commande
Wizard50 Saturday 9 February 2008 at 0:32
Wizard50Anonymous

Excusez moi comme un gros - BIP - de - BIP - que je suis j'ai oublié d taper " sudo apt-get install playonlinux ". J'ai donc tout retapé et a la fin " sudo apt-get install playonlinux " j'ai comme message :

" /home/user> sudo apt-get install playonlinux
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.

Puisque vous n'avez demandé qu'une seule opération, le paquet n'est
probablement pas installable et vous devriez envoyer un rapport de bogue.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
playonlinux: Dépend: lynx mais il n'est pas installable
Dépend: python-wxgtk2.8 mais il n'est pas installable
E: Paquets défectueux
/home/user> "

J'ai rechaerché ces paquets dans le gestionnaire de paquet synaptic et auun résultat
Aymeric P. Saturday 9 February 2008 at 1:07
Aymeric P.
Admin

Bon ça va la c'est nominal regarde là : http://www.playonlinux.com/fr/topic-1071-Probleme_disntallation_de_POL.html

Former member.
Wizard50 Saturday 9 February 2008 at 12:29
Wizard50Anonymous

Merci de vos réponses, c'est rare de rencontrer autant d'aide de la part du staff sur un forum, ici c'est vraiment super

" Il te suffit donc de trouver un dépôt pour debian, contenant les paquets lynx et python-wxgtk. "
Le problème c'est que je ne sait pas du tout comment on fait sa, pas plus que que sur le site sourcelist.org ou on me demande plein d'info sur ma version de Ubuntu alors que j'ai Xandros ...
J'ai aussi regarder hier soir dans le Gestionnaire de paquet Synaptic comme tu le dit dans l'autre topic MulX, et tout est coché bien que je ne voit pas ou on voit si les dépots " universe/multiverse " soient activer
goku Saturday 9 February 2008 at 12:38
goku

Bonjour Wizard50;

Pour voir si les dépots multiverse et universe sont activés dans synaptic, il te suffit de cliquer sur "Dépots" dans le menu configuration de synaptic.

La 2ème ligne (universe) et la 4eme ligne (multiverse) doivent être cochées.

C'est aussi simple que cela .

Windows de Microsoft.

Mac de Apple.

Linux du monde entier.
Wizard50 Saturday 9 February 2008 at 13:41
Wizard50Anonymous

Bien que ce ne soit pas marqué comme tel, j'ai effectivement la 1ere et la 2eme ligne de coché. Moi quand je vais dans Dépot, j'ai plutot une sorte de liste de tout les dépots que j'ai tenter d'installer.

Sinon sauriez vous comment installer es dépots ?

http://xnv4.xandros.com/xs2.0/upkg-srv2/pool/main/l/lynx/

deb http://xnv4.xandros.com/4.0/pkg/ xandros4.0-xn main contrib non-free
deb http://xnv4.xandros.com/4.0/upkg-i386/ unsupported4.0-xn main contrib non-free
deb http://dccamirror.xandros.com/dccri/ dccri-3.0 main
deb http://www.archlug.org/apt/ xandros4 archlug
deb http://www.archlug.org/apt/ xandros4 xorid/andrew
deb http://www.archlug.org/apt/ xandros4 xorid/matty
deb http://www.archlug.org/apt/ xandros4 xorid/uploads
deb http://www.xandros.or.id/archive/ xxxx matty andrew
deb http://http.us.debian.org/debian/ stable main contrib non-free
deb http://http.us.debian.org/debian/ testing main contrib non-free
deb http://http.us.debian.org/debian/ unstable main contrib non-free
deb http://www.debian-multimedia.org/ stable main
deb ftp://ftp.monash.edu.au/pub/linux/debian/ unstable main contrib
Wizard50 Sunday 10 February 2008 at 11:31
Wizard50Anonymous

Voila problème résolus et pour vous "récompenser" de votre aide, j'ai fis un beau tuto ici xD

http://www.blogeee.net/forum/viewtopic.php?f=28&t=2924