The forum

Arch 64bit - LoL

Author Replies
tyromancy Sunday 29 December 2013 at 21:32

Hey, so I just got POL installed and tried installing LoL. I couldn't get it to download and unarchive the tarball automatically, so I downloaded and selected setup.exe manually, which seemed to work fine. I guess something went wrong, becuse when I try to run LoL, this is all the output I get. I tried uninstalling and reinstalling both LoL and POL, and everything results in the same output:

$ playonlinux --run "League of Legends"
[main] Message: PlayOnLinux (4.2.1) is starting
[clean_tmp] Message: Cleaning temp directory
Script started /home/max/.PlayOnLinux/shortcuts/League of Legends
[POL_System_CheckFS] Message: Checking filesystem for lol.launcher.admin.exe
[POL_Wine] Message: Running wine-1.7-LeagueOfLegends lol.launcher.admin.exe (Working directory : /home/max/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot Games/League of Legends)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See
[POL_Wine] Message: Wine return: 0

I'm on a Macbook Pro 9.2, the mid-2012 version. Any ideas?

Edited by tyromancy

booman Thursday 2 January 2014 at 14:17

Here is a step-by-step guide on installing and running League of Legends in Linux:  [url=]League of Legends Guide[/url]
Not sure if this will help you, but it can give you some tips on the libraries needed and Wine settings.

LoL has been known to have bugs specially when logging in or clicking "store"

† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Friday 3 January 2014 at 21:53

Please follow the forum stickies in regards to posting your whole debug output, as well as your computer specs. It could be quite a few things.

This application needs certain dependencies, so it seems as though you are not running the install script, which is what does this for you. The best thing to do is either try to do it manually, as booman stated, or re-run the script. Unfortunately, the connection issue has been around for a while, and Im not sure what can be done to fix it. Normally, you would just keep attempting to download over and over, and eventually, it would get done. There is also a trick laying around somewhere on the forums that people have used. Something like deleting a temp. file somewhere in the virtual folder. I cannot remember off the top of my head.

Try searching the forums for it and see if you can find it. Its been discussed quite a bit.

Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts