The forum

PlayOnLinux can't start

Problem

Author Replies
bbb123bbb Tuesday 31 December 2013 at 0:42
bbb123bbbAnonymous

Hi everyone. I cant speak English very well so pls exuse me. I installed POL and everything was fine, untill i tried to start it. Then it begin to start but it cant. I use Mandriva 2011. Wine is working fine. I installed all other servises that POL wanted like icoutils etc. When trying to run in konsole nothing happened, it only displays version number 3.8.8 and I cant write another command. When installing everything I used rpm packages. Pls help I am beginer in Linux.

Edited by bbb123bbb

petch Tuesday 31 December 2013 at 1:05
petch
Developer

3.8.8 is utterly outdated, see on the download page how to get the latest release (4.2.1)
bbb123bbb Tuesday 31 December 2013 at 1:10
bbb123bbbAnonymous

I installed version 4.0.15 \last for mandriva 2011 in mib\and again same thing. In konsole when write playonlinux: Traceback {most recent call last}:
File "mainwindow.py", line 30, in \module\
import wx
Import error: No module named wx
/usr/share/playonlinux/playonlinux: line 96: python2.6 \the command is not found\

What this mean?

Edited by bbb123bbb

petch Tuesday 31 December 2013 at 1:12
petch
Developer

4.0.15 is not utterly outdated, it's just outdated (Feb 2012)
Yes, soon 2 years old

Edited by petch

bbb123bbb Tuesday 31 December 2013 at 2:20
bbb123bbbAnonymous

I installed version 4.2.1. The problem is the same. The only difference is: usr/share/playonlinux/playonlinux: line 144: python2.6
petch Tuesday 31 December 2013 at 3:14
petch
Developer

The real problem is

Import error: No module named wx

if you still have it (as I understand).
This is strange, because wxPython is among package dependencies:

$ rpm -qpR PlayOnLinux_4.2.1.rpm
warning: PlayOnLinux_4.2.1.rpm: Header V4 DSA/SHA1 Signature, key ID c4676186: NOKEY
/bin/bash
/usr/bin/env
/usr/bin/python
ImageMagick
bash
cabextract
gettext
icoutils
p7zip
p7zip-plugins
python > 2.4
redhat-lsb
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
unzip
wget
wine
wxPython
xterm


How did you install the package? Do you have some wxPython package installed?

Edited by petch

bbb123bbb Tuesday 31 December 2013 at 3:57
bbb123bbbAnonymous

I used rpm package and it installs automaticaly. I have libwxPythonGTK 2.6 and 2.8 and wxPythonGTK-py2.3 version 2.5.2.8 FC2.

The strange thing is when i try to install newer version on wxPythonGTK it end with:
 
Some requested packages cannot be installed wxPythonGTK-2.8.9.2-4 "undefined" (this is what i can translate from my language) wxPythonGTK-wxversion[==1:2.8.9.2-4]

Thank you for traing to help me and for quick answers.

Edited by bbb123bbb