The forum

Kingdoms of Amalur- Unhandled exception

Unhandled exception: page fault on read access to 0x00000018 in 32-bit code (0x009c54b0).

Author Replies
Jump to the page: 1 - 2 - 3
booman Friday 14 February 2014 at 18:06
booman

Exactly, my work "had" a separate cox connection for fallback and no one used it.
So I would download games because it was so stinking fast.
Sorry for the off topic...

I noticed in your original post, you are using integrated graphics.
Is that Intel, AMD or Nvidia?

This may be a driver issue.
Can you play any other games?

† Booman †
Mint 20.2 64-bit | Nvidia 470 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Deedasmi Friday 14 February 2014 at 18:45
DeedasmiAnonymous

Intel HD4600.

Both natively and through wine, yes. Dota, LoL, Torchlight, etc. Only other issues I have relating to games are games that just don't work / aren't configured correctly.
booman Friday 14 February 2014 at 19:03
booman

Ok, so it sounds like your video drivers and 32-bit libraries are installed properly. Otherwise those games wouldn't work.

It may be a limitation of the Intel HD4600 chip.
Have you searched online for anyone that has Kingdoms running on that chip?

† Booman †
Mint 20.2 64-bit | Nvidia 470 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
pipyui Saturday 15 February 2014 at 1:00
pipyuiAnonymous

I'm back, but still stuck in the same boat after installing from the new script. :,(

Log file.

Edit: Oh yeah, and I've already got the Steam overlay disabled.  Nada.

Edited by pipyui

booman Sunday 16 February 2014 at 16:17
booman

Wow, that is frustrating. There is no clear error in that debug log.
I didn't see anything notable where the game crashes.

† Booman †
Mint 20.2 64-bit | Nvidia 470 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
ganbare Tuesday 9 September 2014 at 17:35
ganbare

Hello. I've wanted to play this game for a while and have always got the same error in both 32 bit and 64 bit Linux systems (Ubuntu and Arch)

What I found via trial and error and some educated problems has allowed the the game to start up.

I've already posted my solution to the Wine Appdb forums but I want to spread the message out and get others who are experiencing this issue to see if it resolves it for them.


"By tinkering around for three days, making educated guesses,and through a stroke of luck I may have found a solution for those who have been unfortunately experiencing an immmediate crash when trying to launch the game.

If you go into the main game folder (where the "Reckoning.exe" executable is located) you should notice that there is a "bigs" and "content" folder".

Now in my case (since I installed the two DLC Packs) I noticed that the folders "001", "002", "003", "004", "006", "007", "008", "009" were all present.

Notice the missing folder? Yes, it's "005". So I created an empty folder called "005" in the "bigs" directory.

For those who love command line magic, fire up your shell and cd into the working directory. From there type:

   cd bigs
   mkdir 005

Then go into the "content" folder which is also off of the main folder. Same situation! All the folders from 001 to 009 are present with 005 missing. Create another empty "005" folder and then the game runs!! Crazy, eh?

If others could please confirm if this solution works for them please leave a comment!

Also if you didn't install any DLC you probably only have the folders "001" and "002". In that case I just created the folder "009" and it worked!"


This problem has been bugging me for a long time and I hope this solution works for those who are experiencing issues. It only has seemed to affect those who have the Steam version and not the Origin or original Retail version. But I want to stress that I think it is not related to the Steam overlay issue. This is something completely different. (I noticed that a bug report was actually filed but I believed it was erroneously closed)

booman Tuesday 9 September 2014 at 18:01
booman

That is an awesome discovery!

I'll definitely give it a try again.  I just recently finished the main storyline and would love to see Kingdoms run in PlayOnLinux.
Thank you!


† Booman †
Mint 20.2 64-bit | Nvidia 470 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
ganbare Wednesday 10 September 2014 at 12:33
ganbare

Hi booman! Thanks to you as well! I went over and checked out your website and you are interested in a lot of the games I want to play as well including Torchlight II and Deathspank! :-) So you have just finished the main storyline in Kingdoms of Amalur? How long did it take you?  (I assume it was on a console or Windows box) I am just about to embark on my journey and am learning about sagecrafting, blacksmithing since I want to power up to the max (though I understand the game is easy even on Hard mode)

So..ahem...getting back to the thread topic I noticed on your site that Kindoms of Amalur failed due to Origins DRM. This game is really confusing since there is also the steam version as well! Do you own the origin version? My theory was that only people who had the Steam version were experiencing this crash and the the Origin version was free from this but this could prove that theory wrong! Does Origin match the retail DVD or is it different as well? I'm really interested to see what your results I hope this fix isn't just a "fluke" that works with my version / computer! I really want linux users to be able to play this game! Best of luck and keep me updated on the results. smiley

ganbare Sunday 14 September 2014 at 10:23
ganbare

And the drama and test cases continue...

I currently own two laptops - namely a Sony Vaio with a Nvidia GT 425M graphics card and an Samsung Ultrabook with an integrated Intel HD 4000 graphics chip.

My previous solution of creating an empty folder named 009 in both the bigs and content directory (right off of the main game executable directory) was successful in Arch Linux 64 and Ubuntu Studio LTS 14.04 64 which is housed via a dual partition on my Sony Vaio.

I then decided to see if I could use the same technique and install Kingdoms of Amalur on my Samsung Ultrabook. I was disappointed when it crashed immediately. I wondered to myself "Could it be because I am trying to run it on the less powerful HD 4000 chip but people on other forums had made it clear that they were having success with this card and not just in Windows but also in Wine.  Plus the fact that it crashed so fast and had the same error stack made me suspicious. I then went a little crazy and added an extra bunch of empty folders starting with 010, 011 .... 017 in both the bigs and content folder and what do you know...to my amazement it worked! yes

I have to say this is one of the strangest behaviours I have ever encountered. For starters, my Samsung laptop has the same essential software...namely Ubuntu 14.04 64 running the same Wine (Ubuntu PPA, version 1.7.26) as my Sony Vaio. And of course the Kingdoms of Amalur program is the same. Despite all this sameness, the fix is not exactly the same. There seems to be a degree of randomness here. It is going to take someone smarter than me (i.e. someone who can debug and has an intimate knowledge of how WINE truly operates under the hood) to find out what the core issues are. But the finicky nature of this beast does explain why some people are affected by this bug and others are not.

In fact, I wanted to play this game two years ago in 2011 when I was running Ubuntu 11.04. I had everything configured (in those days you needed to patch for raw input) and had started to play...and then mysteriously one day it just crashed on startup. This completely baffled me since I hadn't updated my version of Ubuntu or even changed the version of WINE I was running. (After it was hand compiled by me with the raw input patches.) It just stopped ...working...without any apparent reason. I tried reinstalling the game but nothing would work. It always bothered me since I had fallen in love with the combat and game mechanics. Now two years later since I finally have some free time I decided to investigate this matter again.

Anyway sorry for this lengthy explanation. I should mention that after I created all those empty folders on my Ultrabook, I also deleted some of them and the game still worked. I tried to find patterns and turned it into a weird math exercise. Was it looking for folders in a certain number range? Maybe just a certain number of folders? A specific folder? Well, I learned the answers to those questions are "no", "no", and "no". cheeky I can't detect any patterns. The only conclusive thing I found is that it does have to be a three digit number folder in the form 0xy where xy can be anything between 005 and 025. And even that is really not just conclusive...it has just been consistent for me. In the end through sheer trail & error and experimentation I just added one 021 folder in both the bigs and content directories and it worked. I should also add that I've never crashed the program by adding folders...it seems to be harmless. So probably a good rule of thumb if you encounter this error is to create a bunch of empty folders in the beginning!

To conclude this essay (haha) I just hope that the days where everyone can enjoy this game in Linux has begun!

booman Sunday 14 September 2014 at 19:04
booman

Thanks for providing your results in testing Kingdoms of Amalur.

I am playing the Origin version downloaded from Amazon.  I got it for about $5.00 and couldn't resist.  I've heard so many great things about Kingdoms, I had to try it myself. 

I really enjoyed the game, but found that it wasn't quite as satisfying as Skyrim.  Of course I had to compare the two because I played Morrowind, Oblivion and Skyrim before it.

Several things seemed to be completely pointless as I progressed through the game:

  • alchemy
  • crafting
  • looting
  • special skills

As I got at least half-way through the game, I found that most of the vegetation I clicked on would respond in "no reagents found".  At least 4 out of 5 would say that.  So what is the point of even trying if I'm not going to get any reagents? I tried to do some crafting, but found that items filled up my inventory and the weapons I crafted still weren't as good as the weapon I already possessed.  So I basically didn't craft anything. Looting was great at the beginning, but again, as I progressed, I found some powerful armor and weapons... but anything I looted was not as good.  So I would just sell them. Some of the skills were pretty cool and I used them here and there, but always found that I never had enough magic.  I could use a skill once, but had to use a mana/energy to use it again.  Later on I found a ring that regenerated my magic, but was still not enough.  This was probably my fault because I focused on Finess instead of Magic.

Anyways, I'm going to test Kingdoms again with the above suggestions and see if I get some success.  I hope its not totally random because I would like to post a step-by-step guide on it as well.

Thanks for checking out our site at gamersonlinux.com

We have devoted a lot of time to show that games really can run in Linux with Wine and PlayOnLinux.


† Booman †
Mint 20.2 64-bit | Nvidia 470 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
ganbare Tuesday 16 September 2014 at 3:30
ganbare

Wow, for $5.00 how could you go wrong? Hard to believe people once had to pay $60.00 for it! Yes, Skyrim is the pinnacle and holy grail of RPG's! I really want to play it but given my current laptop hardware (1.7 GHz Intel 7 w/ NVIDIA 425M) it's really not in the cards. Well technically it is playable but I want perfect framerates on a masterpiece like this.

I haven't started playing Kindoms of Amalur yet but I've read a lot of ot people in the gamefaq forums complain about the broken Economy, small inventory, loot they didn't know what to do with, and variable results with blacksmithing. One camp, like yourself, noticed that the items they crafted were not worth the effort while others complained that it made them too powerful ... even on Hard. I'm not sure what to expect so I have to play the game myself to figure this out.

Most really liked the combat system and there were a couple of people who made the insightful claim that this was like a 3D Diablo II. :-)

So, did you complete game to the finish? I, to want to engage in a pure Finess build in the building but I am told that you can respec pretty easily to try out different builds. And in a game that many claim takes over 200+ hours to complete if you do both (2) DLC missions and every single Faction and Task sidequests (I am a completionist at heart) I will not be doing a second playthrough.

Yeah, I hope two things about this "fix":

  • First, I actually hope it works with the majority of people having this error. I take it as a good sign that this worked on two distinct laptops but a test bed of only two computers is way too premature to draw any firm conclusions.
  • Secondly, perhaps always creating the folders from 001, 002, .... 027 solves the problem. I'm basing this belief in that I never found that adding a folder caused a crash but taking one or more away did.

Anyway, tell me if this solution works for you, and I'll keep on looking for updates on gamersonlinux.com.

Booman, is there anyway I could personally PM or email you though. I feel guilty for hijacking this thread! devil

booman Tuesday 16 September 2014 at 17:32
booman

Yes PM me by clicking my profile, then click "send this member a private message"

Or sign up on our http://www.gamersonlinux.com forum and post whatever you like.

I only played through The Reckoning.  I have the expansions, but have already uninstalled it.  I'll play it again in a few years.  My list of games to play is way too long right now wink

I will be testing Kingdoms of Amalur this weekend with Origin.  Hopefully the long update won't take too long and I can get in game.  DJ says the script works as well, so I'll be trying that too.
IF I can get some success, then I'll post a guide, pictures and a video.

Edited by booman


† Booman †
Mint 20.2 64-bit | Nvidia 470 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
ganbare Thursday 18 September 2014 at 3:12
ganbare

Okay, booman I've signed up and even made my first comment on gamersonlinux. It's a great site everyone so I hope other people sign up! I think the main game is really the majority of the material...I''m not sure how much the expansions actually add on! I hope everything goes well this weekend and we have a new guide up and running for Amalur! Woot Woot!

booman Thursday 18 September 2014 at 18:07
booman

I tested yesterday and it turns out the EA Origin version of Kingdoms of Amalur will not work properly.

Thanks for Origin! sad

Apparently the Steam version works fine!  Do you know if the Steam version requires Origin?

This is really frustrating because I can install the whole game, but updating and/or verifying files causes errors.  Oh well, I'm not going to purchase it again in Steam, but I wonder if I could activate Kingdoms in Steam with the same key?


† Booman †
Mint 20.2 64-bit | Nvidia 470 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
ganbare Friday 19 September 2014 at 21:30
ganbare

Oh this is not good news.

I've never used Origins myself but I've read quite a few WINE users complain that it is a headache to get working properly. I also spent some time on researching whether you could transfer over your Origins Key over to Steam and as far as I can tell the answer is a resounding no. (This is essentially a business issue..EA Origins and Steam are rivals and they don't want to make it easy for you to lose you as a customer! )

Okay so let's ask ourselves a basic troubleshooting question here:

  • Is this an Origins Issue?
  • An Amalur Issue?
  • Or both?

I found out that some people in WINE had trouble dowloading from EA Origins client but this can't be the case since you downloaded like what....8 GB from them? (How long did that take?!) I am wondering do you have this same problem with every game in Origin? (I.e. it downloads fine but you can't update it and then run it.)

And what where the exact errors you encountered?

If it is an Origin issue I would love to test it out since I could sign up for origins and download a Demo of amalur or some other game, correct?

While reasearching this issue, I came across a post that is very relevant that involves the EA Origins of KOA and Wine as well. (Wineskins is just a wrapper for MAC OS X users) It's interesting to note that this person seemed to get pretty far but it wouldn't start up. I wonder once again, was it an Origins problem or a KOA problem (or of course it could be both...)?

As an aside I've finally started playing KOA and I absolutely love it. It just resonates with me. I play it really slow and take in the surrounding and read the lore...The combat is wicked hard. At first I played on Hard and then it kept on trying to reset my level back to Normal because I kept on dying. But then I played again and kicked some butt! The combat actually takes some quick reflexes and strategy! I'm loviing it.

booman Friday 19 September 2014 at 21:40
booman

Actually I cheated!  I never downloaded the game through Origins, instead I have it downloaded from Amazon.com and just installed it.  The installation installs Origin so I made sure it was already setup in PlayOnLInux.

Its really hard to tell if Origin, Kingdoms or Wine is the problem.

For some reason it refused to run the update,  but the game was installed and I could click "Play" but always got an update pop-up.

Initially when installing, the game never finished as reported with other games in Origin.  So maybe that is where my problem lies?  This would be a Wine problem, not Origin or Kingdoms.

Another item to worry about... in windows, when you launch Kingdoms from Origin, it requires an EA login/password to verify the registration, key or something.  Really stupid!

I eventually figured out that I could play it offline as I am with Battlefield 3, but what a joke!  Origins should handle all the DRM like Steam, but the game still requires another DRM level.

What is wrong with these people?  Imagine if I purchased Kingdoms for $40 and one of the DRM's wasn't working!  I would be soo mad!

Well, giving up for now.  Too bad the key doesn't work in Steam.  Some publishers/developers provide an activation in Steam with their retail games, but its only certain games.  Kingdoms isn't one of them.

Thanks for your help!


† Booman †
Mint 20.2 64-bit | Nvidia 470 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
ganbare Friday 19 September 2014 at 22:54
ganbare

Oh my! The good battle never ends! I'm glad to "help" though the problem in the end was not solved so I'm not sure how much I helped. Thanks for trying by the way!

Well Kingdoms was developed by the now defunct 38 Studios and published via EA. Since EA owns Origins it makes sense why they would not make their key available for Steam

I don't blame you for giving up. My problem is that I refuse to give up and it gets me obsessed and in trouble! haha The only avenue I could think of at this point is to simplify things and just try to download and install a complete Origins game in a clean Wine Prefix environment. Troubleshooting is a slow and tedious process!

Keep on gaming in Linux my friend! :)

Edited by ganbare

booman Monday 22 September 2014 at 22:11
booman

Oh I won't give up completely, but I'll come back to it one day and see if Wine has fixed some of the problems with Origin.  I really want to play Battlefield 3 in Linux, but Origin is the main element stopping me.

I have other games to test for now, but I always go back to the problematic games like Bioshock 2, Assassin's Creed II and many more...

  • Bulletstorm
  • WH4K Space Marine
  • Fable 3
  • Rollercoaster Tycoon 3
  • World In Conflict
  • Dark Messiah

† Booman †
Mint 20.2 64-bit | Nvidia 470 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
booman Tuesday 23 September 2014 at 17:12
booman

By the way, I just found a step-by-step guide for PlayOnLinux on how to install Origin and play games:

Origin in PlayOnLinux

Note:  I haven't had a chance to try it out, but will do very soon.  I really want Kingdoms of Amalur to run with Origin.


† Booman †
Mint 20.2 64-bit | Nvidia 470 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
ganbare Wednesday 24 September 2014 at 10:04
ganbare

Hey that is a sweet tutorial, Booman! Great find! And I just found out that origin is offering the first 48 hours of Kingdoms of Amalur free! So even I could try this out using the Origins tutorial described above and play the Origin version of Kingdoms of Amalur. I'm seriously tempted to give this a try and report back on the results :-)

You know I am pretty sure I played Bioshock II a long long time ago on Wine. But you are right...it is super unstable. I really want to play Bioshock Infinite but that is impossible since WINE doesn't support DirectX 11 as of yet. Butt I am one of those people who will never play a game on Windows. It's against my religion. cheeky

I suppose I could circumvent this by buying a PS3..haha (I don't own any game console systems if you can believe that)