The forum

POL 4.2.2 shows only part of game listing

18 wheels.. -HALO available missing games I-Z

Author Replies
baziel Wednesday 11 June 2014 at 0:00


I have a weird error in pol 4.2.2 / linux mint 17 (64bit).

when i click on pol/ install /games with Testing and Commercial checked I see games starting with 18 wheels os steel haulin' , Ares :extinction agenda, Aion ( in red) , age of empires 1 and a lot of different games up to Half life 2, half-life blue shift and Halo combat evolved. Halo is the last game in the list, i can't scroll further down.

If i remove the commercial check, i see games up to Xenon2, and as the last one osu for some unalfabetic reason.

if i remove all checks the last game is xenon 2.

if i include the commercial check the last game is halo again.

Obviously when i remove checks i see less total games but more starting letters if that's more clear.

Anybody an idea why this is so? i already reinstalled twice, including physically removing ~/.PlayOnLinux

if i start pol on the commandline i get this:

103 $ playonlinux   
Looking for python... 2.7.6 - selected
[main] Message: PlayOnLinux (4.2.2) is starting
[clean_tmp] Message: PlayOnLinux seems to be already running. Don't cleaning tmp
[Check_OpenGL] Message: 32bits direct rendering is enabled
[Check_OpenGL] Message: 64bits direct rendering is enabled
[POL_System_CheckFS] Message: Checking filesystem for /home/baziel/.PlayOnLinux/
[main] Message: Filesystem is compatible
[install_plugins] Message: Checking plugin: Capture...
[install_plugins] Message: Checking plugin: ScreenCap...
[install_plugins] Message: Checking plugin: PlayOnLinux Vault...
[maj_check] Message: List is up to date
Traceback (most recent call last):
  File "", line 1091, in About
    self.aboutBox.SetCopyright("�� 2007-2013 "+_("PlayOnLinux and PlayOnMac team\nUnder GPL licence version 3"))
  File "/usr/lib/python2.7/dist-packages/wx-2.8-gtk2-unicode/wx/", line 6416, in SetCopyright
    return _misc_.AboutDialogInfo_SetCopyright(*args, **kwargs)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 0: ordinal not in range(128)

(python:22441): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:22441): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:22441): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

Anybody an idea what package i'm missing or what i'm doing wrong?


thanks for your time..



Edited by Tinou

petch Wednesday 11 June 2014 at 1:17

In a terminal, what does the "locale" command output?

baziel Saturday 14 June 2014 at 0:13


thanks for responding !

I had some issues in mate showing dates in german for some reason, ( these mate guys are smart, maybe they know the germans are up to something ;-)), so i did change my locale settings, but i'm pretty sure i reinstalled pol afterwards..

196 $ locale
petch Saturday 14 June 2014 at 0:47

Ok, could have been a problem with a non-UTF8 locale, or some not-so-common locale that could have been missing some translations, but now I have no good explanation to offer.


baziel Saturday 14 June 2014 at 1:19

I just re-installed again (with removal of .playonlinux and with these locale settings) and still have the same issue, but i can now defintely confirm i changed the locale to these settings before installing pol...



baziel Saturday 14 June 2014 at 11:29

I reinstalled pol via reinstalling Mate (with a diskformat ). This worked, i can see everything properly now. I did notice that the first game after Halo, so the first one i couldn't see, was Hanahira! (はなひらっ!) so pol may have choked on the japanese. Anyway, solved the ultra hard way. Linux mate 17 so far: issues with the germans, the japanese and the X of evil devil