The forum

Fallout 3 - DVD or Steam

Cann't get it to work? Read on!

Author Replies
BobMontgomery Saturday 2 August 2014 at 20:39
BobMontgomeryAnonymous

I have installed this through POL several times including the patch.  With the DVD it won'g work (although I did get it to work a little in Mint 14.04).... Steam doesn't even start to run even though I have installed it exactly as POL tells me to.  On the same computer, Fallout 3 runs fine in Windows 7.  I have Zorin premium 64 bit, version 9.  I have Mint 32 bit (based on 14.04 Ubuntu) and Windows 7.  4 Gigs memory Intel Cor i5-2400 @ 3.10 GHz x4, the an Intel Sandybridge Video built in card. Tons of hd space as well.  In Zorin it tells me I must disable copy protection to run.  In Mint, it does NOT tell me to disable copy protection but crashes when the "radio" clip starts.  In Windows 7 it runs like it was made for it (It wasn't).... I would love to hear from others who have successfully installed it in Zorin, but with steam and with the dvd.  email is bobbyincody@gmail.com  .... Thanks for any input.

booman Wednesday 6 August 2014 at 20:38
booman

Try this step-by-step guide on Intalling Fallout 3 DVD:  Fallout 3 on GamersOnLinux


† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
BobMontgomery Sunday 10 August 2014 at 6:15
BobMontgomeryAnonymous

Doesn't work.  Think it is because I have 4 CPUs ?

booman Monday 11 August 2014 at 2:10
booman

How far did you get?
Also, did you install 32-bit libraries to play games?


† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
BobMontgomery Monday 11 August 2014 at 3:42
BobMontgomeryAnonymous

I installed the six (I think) things such as core fonts, quartz, etc.  I have almost given up.  Fallout 3 runs fine on Windows 7 (you have to add one dll file) and was made for XP and Vista.  Same computer, with Zorin 64 bit and I have tried everything I can think of.  When I try to install with Steam the installation fails. (They have done something recently with Steam or Play on Linux that causes the basic installation to fail..) When using the Play on Linux script, it says you must disable the anti piracy to run the program on Wine.  Makes you wonder why they have a script but don't tell you how to make it work.  When I follow your instructions, it works until the "Radio" introduction (I don't want to set the world on fire song) and immediately crashes. I appreciate all your efforts but wonder if something has happened since you last did an installation of this program.  Thank you so much, if you have any other ideas I would love to hear them. Although I love Zorin 9 based on Ubuntu 14.02 I am willing to try another version of Linux just to solve this problem.  Thank you so much for any suggestions.

 

booman Monday 11 August 2014 at 4:23
booman

I have heard of the radio crashing.   Try going to the Fallout 3 game folder, look for radio, or audio and rename the folder.

I need to do more research, because I don't remember exactly how to do it.  I had the same problem and turning off the radio audio helped


† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
booman Monday 11 August 2014 at 5:01
booman

WineHQ says this:


If VATS and Radio stations crash the game, and there is no ingame music, try this:
install quartz.dll with winetricks

Open winecfg, goto library settings, and configure:
quartz = builtin, then native
You can also try to install proprietary mp3 codecs: winetricks l3codecx
The corresponding wine bug: http://bugs.winehq.org/show_bug.cgi?id=31566

Quote

 

If you followed the guide libraries instructions, quartz should already be installed.  Just make sure its shows (native, built in) in Wine Configuration.

Not sure about the codecs.  PlayOnLinux doesn't support winetricks, so it will be difficult to apply the codecs to your PlayOnLinux virtual drive.

 


† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
petch Monday 11 August 2014 at 14:10
petch
Developer

 

When using the Play on Linux script, it says you must disable the anti piracy to run the program on Wine.  Makes you wonder why they have a script but don't tell you how to make it work.

Wonder no more, that's because it would be illegal in many countries, including yours (check the DMCA). 

BobMontgomery Saturday 16 August 2014 at 5:39
BobMontgomeryAnonymous

Well, I got it to work on my computer by doing the following:  1.  Changed my Video card to GeForce GT 6400 with 2 mb ram.  2.  Did an installation NOT using POL scripts.  This means "install a non-listed program."  3.  Used the following:  Wine 1.6-rc 4,  I have tried 1.7.15 and all it did was crash.  1.6-rc 4 works. Install Core Fonts, CC580, DXFullsetup, MSVC80, Quartz, and VCRUN 2005.  You must patch it with the 1.7 Fallout patch, then install the Winlivedll (not in POL library) .... maybe tweek the setting a little and so far it runs like it is running on my same computer with Windows 7.  No problems so far at all! Every other version of Wine I tried (and I tried a lot of them) crashed very early in the game.  Most would not get past the introduction even if they got that far.  I also installed STEAM from POL and got the program to run to a point and then it would always crash.  Maybe I will fool around with the Steam installation some more, but there is a problem installing Steam thru POL  You cannot read the fonts to complete it.  I don't know how to fix this (yet)... Stay tuned.

 

booman Monday 18 August 2014 at 4:53
booman

I'm hopeing Steam will get to patch-out the Games For Windows Live DRM in Fallout 3.
This will make a HUGE difference in our success!
I can't stand Games For Windows LIve.  Most of the game that don't run in PlayOnLinux is because of GFWL.

Thanks for posting your success. I had to do all the same things to get it running properly.  Wish it wasn't this difficult, but no thanks to Microsoft


† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
BobMontgomery Tuesday 19 August 2014 at 17:41
BobMontgomeryAnonymous

I have played the game to the point I leave the vault, but the mouse is giving me fits.  Usually it won't work on the bottom 1/4 of my screen.  It makes it impossible to enjoy the game.  This is not always the case, but it occures enough for me to not want to play.  This was with the CD installation.  With the Steam version, it works fine until you go to enter your name then crashes.  Go figure.  This is a difficult game to get working correctly, even on Windows 7 the steam version crashes.  Any suggestions are appreciated.

booman Tuesday 19 August 2014 at 23:24
booman

Are you using the virtual desktop?

  • Launch PlayOnLinux
  • Click Configure
  • Click Wine Tab
  • Click Wine Configuration
  • Click Graphics Tab

Graphics Tab
Check "Automatically capture the mouse in full-screen windows"
Check "Emulate a virtual desktop"
Desktop size: 1024x768
Click OK
wcommand13.png 


† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
BobMontgomery Friday 22 August 2014 at 6:22
BobMontgomeryAnonymous

Got it working - both with the CD installation and on Steam.  You have to disable the overlay in Steam and it seems to work fine.  Truth is, Steam seems so much easier I think if you don't already own the game, buying it on Steam works the best as far as I am concerned.  Of course, if it is a Windows game like Fallout 3 you need to be sure you can make it work with POL (wine).... As time goes by more and more games do work.  Soon I hope to cut the cord and not have the dual boot with Windows anymore.  Now if I can just get my Logitech Harmony to work with Linux....

booman Friday 22 August 2014 at 16:55
booman

Ah yes, found that out a few months back.  There was a steam update that broke the overlay in Wine.  Crashes almost every single game.

Feel free to post any more problems with new games.  I've had a lot of success, check out my list of linux games in my signature.


† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained