The forum

Error in POL_Wine_InstallVersion Unable to find version: <.t.it

Trying to install COD4

Author Replies
glyix Monday 3 November 2014 at 1:51
glyixAnonymous

Hey what's up everybody? I'm here to see if you guys can help me.

 

My version of Linux: Linux mint 17 Cinnamon 64 bit

My version of POL: 4.2.2

4Gbs of RAM

500 Gb hard drive

Nvidia Geforce 9800 GT video card

 

I installed Play on Linux today hoping I could install Call of Duty 4. Once I clicked install, put the CD in, and it starts checking it, I get this error message: "Error in POL_Wine_InstallVersion
Unable to find version: <.t.it"

 

Any suggestions?

Ronin DUSETTE Monday 3 November 2014 at 15:48
Ronin DUSETTE
Admin

Debug output, please.....


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
petch Monday 3 November 2014 at 17:11
petch
Developer

The script tries to discover the latest available Wine version using deprecated mechanisms, it doesn't work anymore.

It could be quickfixed by using a given Wine version, but the whole script is in bad need for a rewrite.

Edited by petch

glyix Tuesday 4 November 2014 at 5:04
glyixAnonymous

 

 

Debug output, please.....

 

Total noob question here, but how do I get a debug output? 

 

Thanks

Ronin DUSETTE Wednesday 5 November 2014 at 1:35
Ronin DUSETTE
Admin

Lol. No problem. You can get it from Tools -> PlayOnLinux Debugger. Or you can start playonlinux from the terminal, and you can copy and paste that here. :)


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
glyix Thursday 6 November 2014 at 1:33
glyixAnonymous

Alrighty, tried to find a debug output from Tools-> Play on linux debugger, and there aren't any log files to be found.

 

What happens is I click on install, it brings up the Playonlinux install menu, I search for Call of Duty4, and click to install it. From there it brings up a few prompt screens and tells me to insert the CD, once I do that it tries downloading something for wine and gives me this error:

Error in POL_Wine_InstallVersion
Unable to find version: <.t.it

Again after trying this a few times, there is nothing in the log files for the debugger.

To be honest, I don't know how to run or install programs with Playonlinux from the terminal yet, so any help is awesome!

 

Thanks again

Ronin DUSETTE Saturday 8 November 2014 at 18:09
Ronin DUSETTE
Admin

According to Petch (I have verified this), the script for CoD4 is broken and needs to be updated. 

Well, if you just type 'playonlinux' in a terminal, and press enter, it will run playonlinux, but it will spit out it's debug output on the terminal. Other than that, it runs exactly the same from the terminal. 

Basically, someone needs to re-write the CoD4 script, and it should work. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
glyix Sunday 9 November 2014 at 16:58
glyixAnonymous

Right on, thanks for the help man. Here is the debug output from the terminal:

 

tim@tim-GA-MA770T-UD3P ~ $ playonlinux
Looking for python... 2.7.6 - selected
[main] Message: PlayOnLinux (4.2.2) is starting
[clean_tmp] Message: Cleaning temp directory
[POL_System_CheckFS] Message: Checking filesystem for /home/tim/.PlayOnLinux/
[main] Message: Filesystem is compatible
[install_plugins] Message: Checking plugin: ScreenCap...
[install_plugins] Message: Checking plugin: PlayOnLinux Vault...
[maj_check] Message: Web version : 1415478472
[maj_check] Message: Current local version : 1415220159
[maj_check] Message: Updating list
[POL_Config_Write] Message: Config write: LAST_TIMESTAMP 1415478472

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
[POL_GPG_auth_script] Message: Checking signature of /home/tim/.PlayOnLinux//install
[POL_GPG_install_key] Message: Importing PlayOnLinux public key
[POL_Bash] Message: POL GPG : Good signature - Call of Duty 4 Modern Warfare
[POL_SetupWindow_Init] Message: Creating new window for pid 4828

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
[select_prefixe] Warning: Deprecated function ! Use POL_Wine_SelectPrefix

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
[POL_SetupWindow_menu] Message: menu answer: COD4MW
[POL_SetupWindow_cdrom] Message: CD-ROM selected: COD4MW
[POL_SetupWindow_cdrom] Message: cdrom answer: /media/tim/COD4MW

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
[POL_SetupWindow_check_cdrom] Message: /media/tim/COD4MW/setup.exe FOUND!

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
[POL_SetupWindow_install_wine] Warning: Function deprecated
[POL_Wine_InstallVersion] Message: Installing wine version path: <.t.it, x86
[POL_Wine_InstallVersion] Error: Unable to find version: <.t.it

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python:4270): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
[POL_SetupWindow_Close] Message: Closing window for pid 4828

 

Ronin DUSETTE Monday 10 November 2014 at 5:13
Ronin DUSETTE
Admin

Ok, so first, you should for sure upgrade POL to 4.2.5. 4.2.2 is old. As stated before, someone will need to update the script, as it is extremely out of date, and incompatible with with PlayOnLinux as it stands. I don't own the game, so I cannot test it. If you want to attempt to update it, our scripts documentation is here:

http://www.playonlinux.com/en/documentation.html


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts