The forum

The Sims 1 cannot run

Author Replies
Damien948 Friday 2 January 2015 at 12:43
Damien948Anonymous

Hello,

I have to write, POL is a great tool and with it I can run many apps for Windows that I sometimes use. Thank You for that.

Unfortunately, I have a problem with The Sims 1. It is installed correctly without any error. However I cannot run this game - screen is black for some seconds and later it returns to desktop. POL tells me:

Error in main
The Sims crashed. (I'm not sure if there is "crashed", my POL is not english and I translate it to "crashed")

When I click "debug", I get:

[01/02/15 12:31:34] - Running wine- Sims.exe (Working directory : /home/damian/.PlayOnLinux/wineprefix/default/drive_c/Program Files/Maxis/The Sims)

I use PC from 2003, but a bit modernized. It has GFX nVidia GeForce FX 5700 and I use open drivers nouveau, because the proprietary drivers (173xx) are not compatible with new versions of X.org.

My Linux is Debian testing. My desktop environment is MATE.

I saw that some people can run this game with texture errors, but at least it ran. 

Did I forget about anything? As I wrote, other applications (not games) work correctly. 

Edited by Damien948

Damien948 Saturday 3 January 2015 at 0:55
Damien948Anonymous

Ok, I downgraded a bit kernel and xorg to make proprietary drivers work. Now they work great. I reinstalled POL, whole game, but unfortunately errors are still there, but now they are different. Firstly I have to write, game "Warblade" works under POL smoothly and without errors - just like under Windows. But The Sims is still crashing. :(

This is what I'm getting now:

[01/03/15 00:50:00] - Running wine- Sims.exe (Working directory : /home/damian/.PlayOnLinux/wineprefix/default/drive_c/Program Files/Maxis/Les Sims)
wine: Unhandled page fault on read access to 0x000000f0 at address 0x7f09abd8 (thread 0009), starting debugger...
[01/03/15 00:50:31] - Running wine- Sims.exe (Working directory : /home/damian/.PlayOnLinux/wineprefix/default/drive_c/Program Files/Maxis/Les Sims)
fixme:win:EnumDisplayDevicesW ((null),0,0x32f018,0x00000000), stub!
fixme:d3d:wined3d_device_decref Device released with resources still bound, acceptable but unexpected.
fixme:d3d:wined3d_device_decref Leftover resource 0x1561a0 with type WINED3D_RTYPE_SURFACE (0x1).
fixme:d3d:wined3d_device_decref Leftover resource 0x156030 with type WINED3D_RTYPE_TEXTURE (0x3).
err:ole:COMPOBJ_DllList_Add couldn't load in-process dll L"C:\\windows\\system32\\dmusic.dll"
err:ole:CoGetClassObject no class object {636b9f10-0c7d-11d1-95b2-0020afdc7421} could be created for context 0x1
fixme:win:EnumDisplayDevicesW ((null),0,0x32f298,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f5f8,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f5f8,0x00000000), stub!
fixme:d3d_surface:wined3d_surface_blt Can't handle WINEDDBLT_ASYNC flag.
wine: Unhandled page fault on read access to 0x000000f0 at address 0x7f097bd8 (thread 0009), starting debugger...
Unhandled exception: page fault on read access to 0x000000f0 in 32-bit code (0x7f097bd8).
Register dump:
 CS:0073 SS:007b DS:007b ES:007b FS:003b GS:0033
 EIP:7f097bd8 ESP:0032f950 EBP:0032f988 EFLAGS:00010202(  R- --  I   - - - )
 EAX:00002840 EBX:7f0c6570 ECX:00000000 EDX:7f0c5a00
 ESI:001a5994 EDI:00000000
Stack dump:
0x0032f950:  00000000 00000000 00000000 00000020
0x0032f960:  00000000 00000000 00000000 00000000
0x0032f970:  00000000 7f097ba6 0032f99c 008bc1a8
0x0032f980:  008bc270 00000000 0032fa34 00582a9e
0x0032f990:  00000000 0032fa34 00582a9e 001a5994
...skipped 111 line(s)...
ELF    7fcb1000-7fe0d000    Deferred        user32<elf>
  \-PE    7fcc0000-7fe0d000    \               user32
ELF    7ff96000-7ffa3000    Deferred        libnss_files.so.2
ELF    7ffa3000-7ffaf000    Deferred        libnss_nis.so.2
ELF    7ffaf000-7ffc8000    Deferred        libnsl.so.1
ELF    b73a0000-b73a9000    Deferred        libnss_compat.so.2
ELF    b73aa000-b73f0000    Deferred        libm.so.6
ELF    b73f0000-b73f5000    Deferred        libdl.so.2
ELF    b73f5000-b75a0000    Deferred        libc.so.6
ELF    b75a1000-b75bd000    Deferred        libpthread.so.0
ELF    b75d5000-b778a000    Dwarf           libwine.so.1
ELF    b778c000-b778d000    Deferred        [vdso].so
ELF    b778d000-b77ae000    Deferred        ld-linux.so.2
Threads:
process  tid      prio (all id:s are in hex)
00000008 (D) C:\Program Files\Maxis\Les Sims\Sims.exe
    00000025   15
    00000024    0
    00000023    0
    00000009    0 <==
0000000e services.exe
    0000001d    0
    0000001c    0
    00000016    0
    00000014    0
    00000010    0
    0000000f    0
00000012 winedevice.exe
    0000001b    0
    00000018    0
    00000017    0
    00000013    0
00000019 plugplay.exe
    0000001f    0
    0000001e    0
    0000001a    0
00000020 explorer.exe
    00000022    0
    00000021    0

 

Damien948 Saturday 3 January 2015 at 11:45
Damien948Anonymous

So... I was fighting with it and after installing whole DirectX, dmusic, dxdiag, dsound and other stuff connected with that and also disabling GLSL, game ran, but it crashed during loading screen. I run this game in normal desktop, not virtual, because it doesn't run at all in virtual desktop. 

What debugger tells me:

[01/03/15 11:35:12] - Running wine- Sims.exe (Working directory : /home/damian/.PlayOnLinux/wineprefix/default/drive_c/Program Files/Maxis/Les Sims)
err:winediag:wined3d_dll_init The GLSL shader backend has been disabled. You get to keep all the pieces if it breaks.
fixme:win:EnumDisplayDevicesW ((null),0,0x32f048,0x00000000), stub!
fixme:d3d:wined3d_device_decref Device released with resources still bound, acceptable but unexpected.
fixme:d3d:wined3d_device_decref Leftover resource 0x1561b0 with type WINED3D_RTYPE_SURFACE (0x1).
fixme:d3d:wined3d_device_decref Leftover resource 0x156058 with type WINED3D_RTYPE_TEXTURE (0x3).
fixme:win:EnumDisplayDevicesW ((null),0,0x32f048,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f2a8,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f5f8,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f5f8,0x00000000), stub!
fixme:amstream:IAMMultiMediaStreamImpl_AddMediaStream Specifying a stream object in params is not yet supported
fixme:ddraw:ddraw_surface7_Flip Ignoring flags 0x1.

Now I completely don't know what to do. Please, help me, I'm so close to make it work... 

petch Saturday 3 January 2015 at 16:51
petch
Developer

Damien948 Sunday 4 January 2015 at 10:39
Damien948Anonymous

Yes, but there are two bronzes: https://appdb.winehq.org/objectManager.php?sClass=version&iId=8696 In the screens game works, but with white sims.

 

But finally I made game work - I have just changed Wine version to 1.4.1 and game works, but sims are invisible... The game works also with 1.4, 1.3.37, but with 1.5.0 not. 

I think, I cannot do more for making sims visible, probably I should wait for fix from Wine developers. 

 

Greetings!

Edited by Damien948

Ronin DUSETTE Sunday 4 January 2015 at 17:43
Ronin DUSETTE
Admin

Yeah. It will likely need a patch. I wouldn't just wait, though. I would submit a bug report to them, that way they are aware off the issue.


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts