The forum

League Of Legends - login server did not respond

Author Replies
Kochon Sunday 1 February 2015 at 22:40

Okay, here we go... I've been digging for two days all over these forums and google to find a solution to my issue, and I can't...


The game installed just fine through PoL, managed to do all the updates, then the game launched without issues! But when I try to log in it goes Did not receive a response from the login servers...1,2,3 then gives me this magnificent error: The login server did not respond, see screenshot:


What I tried:

  • disabling tcp timestamps
  • deleting wininet dll override in registry and from system32
  • just about every wine version known to mankind (the script installed 1.7.33-LeagueofLegends2 by default)
  • installing ie8 (that one hurt)
  • screaming/cursing/birdflipping at my monitor (felt great, didn't help at all though)

More info (I'm not really sure as to which logs to provide, please enlighten me and i'll be more then glad to provide them):


arch linux x64 up-to-date


nvidia proprietary drivers(340xx)

Edited by Kochon

st4ll1 Friday 6 February 2015 at 0:00

Hi Kochon,

try to remove the wininet.dll from your windows/system32 directory

worked for me on my arch




Kochon Friday 6 February 2015 at 2:36

Unfortunately that didn't work

Edited by Kochon

gl3nnleblanc Thursday 2 July 2015 at 0:37

Don't know if you still need a fix on this, but have you tried

sudo pacman -S lib32-alsa-lib lib32-libldap lib32-lcms2 lib32-gnutls winetricks` ?

I was having the same exact issue, and the debug screen mentioned that I was missing those packages. Make sure you've enabled the multilib repo in your mirrors file, too. Looks like I have pretty much the same system as you (except for xfce), so if that doesn't work I'm stumped.

Edited by gl3nnleblanc