The forum

GTA San Andreas problem

Can't play properly

Author Replies
Jump to the page: 1 - 2
gamsufa Monday 30 March 2015 at 18:42
gamsufaAnonymous

Hello, I face this problem...

Installed GTA San Andreas through POL, and when I run it... Screen becomes black, then white, then black, then white and when menu appears, there's no text, just cyan random boxes. Sound works perfectly as I navigate through menu.

Here's log:

 

ot yet filled.
fixme:shell:IShellLinkA_fnGetPath (0xfdc9c8): WIN32_FIND_DATA is not yet filled.
fixme:shell:IShellLinkA_fnGetPath (0xfdc870): WIN32_FIND_DATA is not yet filled.
fixme:shell:IShellLinkA_fnGetPath (0xfdc870): WIN32_FIND_DATA is not yet filled.
err:ole:dispatch_rpc no apartment found for ipid {ffffffff-ffff-ffff-2400-000021000000}
err:rpc:I_RpcReceive we got fault packet with status 0x80010108
err:ole:dispatch_rpc no apartment found for ipid {ffffffff-ffff-ffff-2400-000021000000}
err:rpc:I_RpcReceive we got fault packet with status 0x80010108
err:ole:dispatch_rpc no apartment found for ipid {ffffffff-ffff-ffff-2400-000021000000}
err:rpc:I_RpcReceive we got fault packet with status 0x80010108
[03/30/15 19:30:18] - Running wine-1.3.26 regedit /home/addo/.PlayOnLinux//tmp/regkey.reg (Working directory : /media/addo)
[03/30/15 19:30:18] - Content of /home/addo/.PlayOnLinux//tmp/regkey.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\Direct3D]
"VideoMemorySize"="1792"
-----------
[03/30/15 19:30:24] - Running wine-1.3.26 regedit /home/addo/.PlayOnLinux//tmp/regkey.reg (Working directory : /media/addo)
[03/30/15 19:30:24] - Content of /home/addo/.PlayOnLinux//tmp/regkey.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\Drivers]
"Audio"="alsa"
-----------
[03/30/15 19:30:24] - Running wine-1.3.26 regedit /home/addo/.PlayOnLinux//tmp/regkey.reg (Working directory : /media/addo)
[03/30/15 19:30:24] - Content of /home/addo/.PlayOnLinux//tmp/regkey.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\DirectSound]
"EmulDriver"="Y"
-----------
[03/30/15 19:31:06] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
Initialised SoundManager
[03/30/15 19:31:53] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
fixme:win:EnumDisplayDevicesW ((null),0,0x177f64c,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x177f63c,0x00000000), stub!
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 32 channels, pretending there's only 2 channels
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 8 channels, pretending there's only 2 channels
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 8 channels, pretending there's only 2 channels
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 8 channels, pretending there's only 2 channels
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 32 channels, pretending there's only 2 channels
fixme:mixer:ALSA_MixerInit No master control found on HDA Intel HDMI, disabling mixer
fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x145a20,0x13e250): stub
fixme:dinput:IDirectInputDevice2WImpl_GetProperty DIPROP_VIDPID not implemented
fixme:win:EnumDisplayDevicesW ((null),0,0x177f304,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x177f79c,0x00000000), stub!
fixme:d3d:resource_check_usage Unhandled usage flags 0x28.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:system:SystemParametersInfoW Unimplemented action: 59 (SPI_SETSTICKYKEYS)
fixme:d3d:wined3d_buffer_preload Too many declaration changes or converting dynamic buffer, stopping converting
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x28.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:wined3d_buffer_preload Too many declaration changes or converting dynamic buffer, stopping converting
fixme:d3d:wined3d_buffer_preload Too many declaration changes or converting dynamic buffer, stopping converting
fixme:d3d:wined3d_buffer_preload Too many declaration changes or converting dynamic buffer, stopping converting
fixme:d3d:wined3d_buffer_preload Too many declaration changes or converting dynamic buffer, stopping converting
fixme:quartz:MPEGSplitter_query_accept MPEG-1 system streams not yet supported.
fixme:quartz:MPEGSplitter_query_accept MPEG-1 system streams not yet supported.
fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x30637a8,0x3063270): stub
fixme:d3d:wined3d_swapchain_set_gamma_ramp Ignoring flags 0x1.
fixme:dsound:IDirectSoundBufferImpl_SetFX (0x30640b8,0,(nil),(nil)): stub
fixme:d3d:wined3d_swapchain_set_gamma_ramp Ignoring flags 0x1.
Initialised SoundManager
[03/30/15 19:33:54] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
[03/30/15 19:34:05] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
[03/30/15 19:34:05] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
[03/30/15 19:34:05] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
[03/30/15 19:34:05] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
[03/30/15 19:34:05] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
[03/30/15 19:34:06] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
[03/30/15 19:34:07] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
[03/30/15 19:34:08] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
[03/30/15 19:34:08] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
[03/30/15 19:34:08] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
[03/30/15 19:34:08] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
Initialised SoundManager
[03/30/15 19:36:38] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
fixme:win:EnumDisplayDevicesW ((null),0,0x177f64c,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x177f63c,0x00000000), stub!
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 32 channels, pretending there's only 2 channels
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 8 channels, pretending there's only 2 channels
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 8 channels, pretending there's only 2 channels
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 8 channels, pretending there's only 2 channels
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 32 channels, pretending there's only 2 channels
fixme:mixer:ALSA_MixerInit No master control found on HDA Intel HDMI, disabling mixer
fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x145a20,0x13e250): stub
fixme:dinput:IDirectInputDevice2WImpl_GetProperty DIPROP_VIDPID not implemented
fixme:win:EnumDisplayDevicesW ((null),0,0x177f304,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x177f79c,0x00000000), stub!
fixme:d3d:resource_check_usage Unhandled usage flags 0x28.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:system:SystemParametersInfoW Unimplemented action: 59 (SPI_SETSTICKYKEYS)
fixme:d3d:wined3d_buffer_preload Too many declaration changes or converting dynamic buffer, stopping converting
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x28.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:wined3d_buffer_preload Too many declaration changes or converting dynamic buffer, stopping converting
fixme:d3d:wined3d_buffer_preload Too many declaration changes or converting dynamic buffer, stopping converting
fixme:d3d:wined3d_buffer_preload Too many declaration changes or converting dynamic buffer, stopping converting
fixme:d3d:wined3d_buffer_preload Too many declaration changes or converting dynamic buffer, stopping converting
fixme:quartz:MPEGSplitter_query_accept MPEG-1 system streams not yet supported.
fixme:quartz:MPEGSplitter_query_accept MPEG-1 system streams not yet supported.
fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x30637a8,0x3063270): stub
fixme:d3d:wined3d_swapchain_set_gamma_ramp Ignoring flags 0x1.
fixme:dsound:IDirectSoundBufferImpl_SetFX (0x30640b8,0,(nil),(nil)): stub
fixme:d3d:wined3d_swapchain_set_gamma_ramp Ignoring flags 0x1.
Initialised SoundManager

Ronin DUSETTE Monday 30 March 2015 at 18:44
Ronin DUSETTE
Admin

What are your full computer specs? Graphics card and driver, Linux distro, CPU, etc.? I see a lot of wined3d errors and sound errors, but it looks like it may be a graphics driver problem. Do you have the 32-bit drivers installed for your graphics card?


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
gamsufa Monday 30 March 2015 at 18:53
gamsufaAnonymous

Linux Mint

Intel® Core™ i5 4200U Processor

4GB RAM

GPU: Intel integrated / NVIDIA® GeForce® GT 840M (nouveu)

 

I'm not sure about 32-bit drivers, I couldn't choose.

Ronin DUSETTE Monday 30 March 2015 at 19:06
Ronin DUSETTE
Admin

You need to run the proprietary Nvidia drivers and bumblebee to get this working, along with installing the 32-bit graphics libraries from Nvidia (not the open source Nouveau drivers. They don't work well for gaming). Please note that Mint is based off of Ubuntu, so you can use the Ubuntu instructions, for the most part, to get it working. 

Start here:

http://wiki.playonlinux.com/index.php/Graphics_Card_Drivers#Optimus

You are going to have to do some reading and installing of stuff to get your system working well for ANY game, but it is not hard. Just read that link, and follow it to get bumblebee set up on your laptop. If you are still having trouble getting it installed, check Mint's documentation to get your drivers set up correctly with the proprietary Nvidia drivers (along with the 32-bit libraries), and get Bumblebee set up (so that you can tell your latop to use the Nvidia card for games.).

Edited by RoninDusette


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
gamsufa Monday 30 March 2015 at 19:10
gamsufaAnonymous

Thanks, but here other problem comes in. I had nvidia installed, but because of it, whole system randomly froze (you couldn't do anything but to restart) and just deleting nvidia and using nouveu driver helped. Maybe you encountered this problem?

Ronin DUSETTE Monday 30 March 2015 at 19:13
Ronin DUSETTE
Admin

Then you didn't have something installed correctly. You NEED the Nvidia driver installed to play games with that card. I have never had my Nvidia driver lock up my system like you are describing, so you must not have installed the driver correctly. Check the link that I gave you, and go from there. Remember; you are going to need Bumblebee to control your laptop's graphics cards (it has 2; 1 intel GPU, and your nvidia card). This "Optimus" setup requires some special settings and configuration to get working correctly for gaming. If you go through the steps to set Bumblebee up with the proprietary Nvidia drivers, you shouldn't have a problem. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
gamsufa Monday 30 March 2015 at 19:16
gamsufaAnonymous

Understood. Installing at the moment.

Ronin DUSETTE Monday 30 March 2015 at 19:17
Ronin DUSETTE
Admin

No problem. I am certain this will make a difference once you unleash the full power of that Nvidia card. ;)


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
gamsufa Monday 30 March 2015 at 20:07
gamsufaAnonymous

I installed nvidia and bumblebee.

First of all, this is sick!

With glxgears, before I had ~60fps, now 2000+. Cool :D

 

But, now GTA San Andreas does not even start from POL. I just press run run run, and nothing happens.

 

Log:

 

03/30/15 21:04:14] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
[03/30/15 21:04:35] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
[03/30/15 21:05:06] - Running wine-1.3.26 regedit /home/addo/.PlayOnLinux//tmp/regkey.reg (Working directory : /usr/share/playonlinux/python)
[03/30/15 21:05:06] - Content of /home/addo/.PlayOnLinux//tmp/regkey.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\Direct3D]
"VideoMemorySize"="2048"
-----------
[03/30/15 21:05:10] - Running wine-1.3.26 regedit /home/addo/.PlayOnLinux//tmp/regkey.reg (Working directory : /usr/share/playonlinux/python)
[03/30/15 21:05:10] - Content of /home/addo/.PlayOnLinux//tmp/regkey.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\Direct3D]
"VideoMemorySize"=-
-----------
[03/30/15 21:05:27] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
[03/30/15 21:07:10] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
fixme:win:EnumDisplayDevicesW ((null),0,0x177f64c,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x177f63c,0x00000000), stub!
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 32 channels, pretending there's only 2 channels
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 8 channels, pretending there's only 2 channels
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 8 channels, pretending there's only 2 channels
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 8 channels, pretending there's only 2 channels
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 32 channels, pretending there's only 2 channels
fixme:mixer:ALSA_MixerInit No master control found on HDA Intel HDMI, disabling mixer
fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x1453b0,0x13dbe0): stub
fixme:dinput:IDirectInputDevice2WImpl_GetProperty DIPROP_VIDPID not implemented
fixme:win:EnumDisplayDevicesW ((null),0,0x177f304,0x00000000), stub!

Edited by gamsufa

Ronin DUSETTE Monday 30 March 2015 at 20:18
Ronin DUSETTE
Admin

Can you highlight the shortcut to start the game in POL's main window and click "debug" in the left panel, and post the whole log here, please? There is nothing in here that I can see that is causing a crash. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
gamsufa Monday 30 March 2015 at 20:20
gamsufaAnonymous

I think the problem isn't the crash, because in order to crash, it has to start. It does not even start.

 

That's debug:

 

 

Initialised SoundManager
[03/30/15 20:42:03] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
Initialised SoundManager
[03/30/15 21:04:14] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
[03/30/15 21:04:35] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
[03/30/15 21:05:06] - Running wine-1.3.26 regedit /home/addo/.PlayOnLinux//tmp/regkey.reg (Working directory : /usr/share/playonlinux/python)
[03/30/15 21:05:06] - Content of /home/addo/.PlayOnLinux//tmp/regkey.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\Direct3D]
"VideoMemorySize"="2048"
-----------
[03/30/15 21:05:10] - Running wine-1.3.26 regedit /home/addo/.PlayOnLinux//tmp/regkey.reg (Working directory : /usr/share/playonlinux/python)
[03/30/15 21:05:10] - Content of /home/addo/.PlayOnLinux//tmp/regkey.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\Direct3D]
"VideoMemorySize"=-
-----------
[03/30/15 21:05:27] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
[03/30/15 21:07:10] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
fixme:win:EnumDisplayDevicesW ((null),0,0x177f64c,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x177f63c,0x00000000), stub!
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 32 channels, pretending there's only 2 channels
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 8 channels, pretending there's only 2 channels
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 8 channels, pretending there's only 2 channels
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 8 channels, pretending there's only 2 channels
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 32 channels, pretending there's only 2 channels
fixme:mixer:ALSA_MixerInit No master control found on HDA Intel HDMI, disabling mixer
fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x1453b0,0x13dbe0): stub
fixme:dinput:IDirectInputDevice2WImpl_GetProperty DIPROP_VIDPID not implemented
fixme:win:EnumDisplayDevicesW ((null),0,0x177f304,0x00000000), stub!
[03/30/15 21:19:01] - Running wine-1.3.26 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
fixme:win:EnumDisplayDevicesW ((null),0,0x177f64c,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x177f63c,0x00000000), stub!
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 32 channels, pretending there's only 2 channels
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 8 channels, pretending there's only 2 channels
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 8 channels, pretending there's only 2 channels
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 8 channels, pretending there's only 2 channels
fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 32 channels, pretending there's only 2 channels
fixme:mixer:ALSA_MixerInit No master control found on HDA Intel HDMI, disabling mixer
fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x1453b0,0x13dbe0): stub
fixme:dinput:IDirectInputDevice2WImpl_GetProperty DIPROP_VIDPID not implemented
fixme:win:EnumDisplayDevicesW ((null),0,0x177f304,0x00000000), stub!

gamsufa Monday 30 March 2015 at 20:23
gamsufaAnonymous

It opened, when using just wine. First problem is fixed! It displays everything properly!!

But it opens in very small resolution, that messes up whole display even after exit.

Ronin DUSETTE Monday 30 March 2015 at 20:24
Ronin DUSETTE
Admin

Can you try to install the newest version of Wine (Tools -> Manage Wine Versions), and install the x86 version of 1.7.39, then in the General Tab of the Configuration Window, with your GTA virtual drive selected, change the Wine version to the new one that you just installed, and try to run it like normal again. I am not sure what would be causing that. Also, quit POL, open a terminal, and use optirun playonlinux, and see if that helps. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Deleted Doing it myself. lol.
Ronin DUSETTE Monday 30 March 2015 at 20:33
Ronin DUSETTE
Admin

Let's do this real quick. Delete the virtual drive for GTA, go to the Install Window and try to install GTA again. Remember to restart POL before attempting to reinstall GTA. I just updated the script, and I would like to see if it works better now. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
gamsufa Monday 30 March 2015 at 20:46
gamsufaAnonymous

Ok. Just a moment.

Ronin DUSETTE Monday 30 March 2015 at 20:48
Ronin DUSETTE
Admin

I am actually doing it right now, as well. I just hopped on Steam and bought it, and I am just waiting for it to download. :)


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Monday 30 March 2015 at 21:25
Ronin DUSETTE
Admin

Changing the Wine version worked great, although I am thinking that this may require the use of Wine's Virtual Desktop feature to correct the glitches in the game's graphics. I am still looking at it. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
gamsufa Monday 30 March 2015 at 21:30
gamsufaAnonymous

Ok, I'm still downloading some files on POL.. :D

gamsufa Monday 30 March 2015 at 21:48
gamsufaAnonymous

Didn't fixed problem.. I still get small screen, and when I try to change resolution, it crashes.

 

Log:

 

[03/30/15 22:31:16] - Running wine-1.7.35 --version (Working directory : /home/addo/.PlayOnLinux/wine/mono)
wine-1.7.35

PlayOnLinux logfile
-------------------
Date: 03/30/15 22:31:16

> PlayOnLinux Version
  4.2.2
> uname -a
  Linux addo-X550LN 3.13.0-46-generic #79-Ubuntu SMP Tue Mar 10 20:06:50 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
> lsb_release -a
  
> wine --version
  wine-1.7.35
> POL_WINEVERSION
  1.7.35
> WINEPREFIX
  /home/addo/.PlayOnLinux//wineprefix/GTASA
> Distribution
  Linux Mint 17.1 Rebecca
> glxinfo \| grep rendering
  direct rendering: Yes
    GL_NV_path_rendering, GL_NV_pixel_data_range, GL_NV_point_sprite, 
    GL_NV_path_rendering, GL_NV_pixel_data_range, GL_NV_point_sprite, 
> glxinfo \| grep renderer
  OpenGL renderer string: GeForce 840M/PCIe/SSE2
> OpenGL libs (Direct rendering testing)
  
  

[03/30/15 22:31:33] - Running wine-1.7.35 cmd /c echo %ProgramFiles% (Working directory : /home/addo/.PlayOnLinux/wine/mono)
C:\Program Files (x86)
[03/30/15 22:31:40] - ----- Starting function POL_Install_steam_flags -----
[03/30/15 22:31:40] - ----- Ending function POL_Install_steam_flags -----
[03/30/15 22:31:45] - Running wine-1.7.35 start /unix /media/addo/GTA_SAN_ANDREAS/setup.exe (Working directory : /media/addo)
err:ole:TLB_ReadTypeLib Loading of typelib L"C:\\Program Files (x86)\\Common Files\\InstallShield\\Professional\\RunTime\\IsProBE.tlb" failed with error 2
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: cannot open shared object file: No such file or directory
fixme:ole:RemUnknown_QueryInterface No interface for iid {00000019-0000-0000-c000-000000000046}
fixme:ole:RemUnknown_QueryInterface No interface for iid {00000019-0000-0000-c000-000000000046}
fixme:apphelp:ApphelpCheckInstallShieldPackage stub: 0x33dcd4 L"E:\\data1.hdr"
fixme:shell:IShellLinkA_fnGetPath (0xbd24e0): WIN32_FIND_DATA is not yet filled.
fixme:shell:IShellLinkA_fnGetPath (0xbd24e0): WIN32_FIND_DATA is not yet filled.
fixme:shell:IShellLinkA_fnGetPath (0x361f310): WIN32_FIND_DATA is not yet filled.
fixme:shell:IShellLinkA_fnGetPath (0x361f310): WIN32_FIND_DATA is not yet filled.
fixme:shell:IShellLinkA_fnGetPath (0x361f310): WIN32_FIND_DATA is not yet filled.
fixme:shell:IShellLinkA_fnGetPath (0x361f310): WIN32_FIND_DATA is not yet filled.
err:ole:dispatch_rpc no apartment found for ipid {ffffffff-ffff-ffff-2700-000024000000}
err:rpc:I_RpcReceive we got fault packet with status 0x80010108
err:ole:dispatch_rpc no apartment found for ipid {ffffffff-ffff-ffff-2700-000024000000}
err:rpc:I_RpcReceive we got fault packet with status 0x80010108
err:ole:dispatch_rpc no apartment found for ipid {ffffffff-ffff-ffff-2700-000024000000}
err:rpc:I_RpcReceive we got fault packet with status 0x80010108
[03/30/15 22:37:47] - Running wine-1.7.35 regedit /home/addo/.PlayOnLinux//tmp/regkey.reg (Working directory : /media/addo)
[03/30/15 22:37:47] - Content of /home/addo/.PlayOnLinux//tmp/regkey.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\Direct3D]
"VideoMemorySize"="1792"
-----------
[03/30/15 22:37:56] - Running wine-1.7.35 regedit /home/addo/.PlayOnLinux//tmp/regkey.reg (Working directory : /media/addo)
[03/30/15 22:37:56] - Content of /home/addo/.PlayOnLinux//tmp/regkey.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\Drivers]
"Audio"="alsa"
-----------
[03/30/15 22:37:56] - Running wine-1.7.35 regedit /home/addo/.PlayOnLinux//tmp/regkey.reg (Working directory : /media/addo)
[03/30/15 22:37:56] - Content of /home/addo/.PlayOnLinux//tmp/regkey.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\DirectSound]
"EmulDriver"="Y"
-----------
[03/30/15 22:47:02] - Running wine-1.7.35 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  21 (RRSetCrtcConfig)
  Value in failed request:  0x0
  Serial number of failed request:  566
  Current serial number in output stream:  566
[03/30/15 22:47:32] - Running wine-1.7.35 gta_sa.exe (Working directory : /home/addo/.PlayOnLinux/wineprefix/GTASA/drive_c/Program Files (x86)/Rockstar Games/GTA San Andreas)
fixme:win:EnumDisplayDevicesW ((null),0,0x177f558,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x177f548,0x00000000), stub!
fixme:dinput:IDirectInputDevice2WImpl_GetProperty DIPROP_VIDPID not implemented
fixme:win:EnumDisplayDevicesW ((null),0,0x177f328,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x177f7b8,0x00000000), stub!
fixme:d3d:resource_check_usage Unhandled usage flags 0x20.
fixme:system:SystemParametersInfoW Unimplemented action: 59 (SPI_SETSTICKYKEYS)
fixme:d3d:resource_check_usage Unhandled usage flags 0x20.
fixme:d3d:swapchain_gl_present WINED3D_SWAP_EFFECT_FLIP not implemented.
err:quartz:GetClassMediaFile Media class not found
fixme:quartz:Parser_QueryInterface No interface for {37d84f60-42cb-11ce-8135-00aa004bb851}!
fixme:quartz:MPEGSplitter_query_accept MPEG-1 system streams not yet supported.
err:quartz:GetClassMediaFile Media class not found
fixme:quartz:Parser_QueryInterface No interface for {37d84f60-42cb-11ce-8135-00aa004bb851}!
fixme:quartz:MPEGSplitter_query_accept MPEG-1 system streams not yet supported.
fixme:wmvcore:WMCreateSyncReader ((nil), 0, 0x177fc68): stub
fixme:d3d:wined3d_swapchain_set_gamma_ramp Ignoring flags 0x1.
err:xvidmode:ComputeGammaFromRamp low-biased gamma ramp (588), rejected
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  21 (RRSetCrtcConfig)
  Value in failed request:  0x0
  Serial number of failed request:  571
  Current serial number in output stream:  571