The forum

Path of exile issue on launching / Quesiton

Question about Path of exile launching

Author Replies
agentzulu Sunday 18 October 2015 at 20:15
agentzuluAnonymous

Hello,

My name is Phil. I'm new to playonlinux and in general, ubuntu. Recently I downloaded the game called path of exile (POE) via this installer, Playonlinux. I downloaded it with no errors until when I run the program, the window opens but gives me a pop-up "Direct3D failed resetting objects." I looked up forum post as stated below but none came to work. At least they didn't fix the whole problem.

 

https://www.playonlinux.com/en/topic-11041-32bits_OpenGL_Libraries_Missing.html
https://www.playonlinux.com/en/topic-13360-Path_of_Exile__cannot_launch.html

Before I added the 32bit opengl libraries I had this upon starting POL

For a reminder I run a 64bit

Distributor ID:    Ubuntu
Description:    Ubuntu 14.04.3 LTS
Release:    14.04
Codename:    trusty

 

Looking for python... 2.7.6 - selected
[main] Message: PlayOnLinux (4.2.2) is starting
[clean_tmp] Message: Cleaning temp directory
[POL_System_CheckFS] Message: Checking filesystem for /home/phil/.PlayOnLinux/
[main] Message: Filesystem is compatible
[install_plugins] Message: Checking plugin: ScreenCap...
[install_plugins] Message: Checking plugin: PlayOnLinux Vault...
[maj_check] Message: List is up to date
[POL_System_CheckFS] Message: Checking filesystem for PathOfExile.exe
[POL_Wine] Message: Running wine-1.5.28-PathOfExile PathOfExile.exe (Working directory : /home/phil/.PlayOnLinux/wineprefix/pathofexile/drive_c/Program Files/Grinding Gear Games/Path of Exile)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
[POL_Wine] Message: Wine return: 0
[POL_System_CheckFS] Message: Checking filesystem for PathOfExile.exe
[POL_Wine] Message: Running wine-1.5.28-PathOfExile PathOfExile.exe (Working directory : /home/phil/.PlayOnLinux/wineprefix/pathofexile/drive_c/Program Files/Grinding Gear Games/Path of Exile)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
[POL_Wine] Message: Wine return: 0

 

##Upon manually shutting down
Registered PID: 8911 (Missing)
Registered PID: 8945 (Missing)
Registered PID: 9131 (Missing)
Registered PID: 9178 (Missing)
Registered PID: 9376 (Present)
Registered PID: 9423 (Missing)

Five pids were missing and one was present

After adding the 32 bit opengl libraries I found this upon manually closing

:~$ playonlinux
Looking for python... 2.7.6 - selected
[main] Message: PlayOnLinux (4.2.2) is starting
[clean_tmp] Message: Cleaning temp directory
[POL_System_CheckFS] Message: Checking filesystem for /home/phil/.PlayOnLinux/
[main] Message: Filesystem is compatible
[maj_check] Message: List is up to date
[install_plugins] Message: Checking plugin: ScreenCap...
[install_plugins] Message: Checking plugin: PlayOnLinux Vault...
[POL_System_CheckFS] Message: Checking filesystem for PathOfExile.exe
[POL_Wine] Message: Running wine-1.5.28-PathOfExile PathOfExile.exe (Working directory : /home/phil/.PlayOnLinux/wineprefix/pathofexile/drive_c/Program Files/Grinding Gear Games/Path of Exile)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
[POL_Wine] Message: Wine return: 0


## Upon manually closing
Registered PID: 11039 (Missing)
Registered PID: 11225 (Present)
Registered PID: 11272 (Missing)
:-$

Only two were missing this second run and the one was still present. Again, as new as I am by deductive reasoning I believe that I solved one of the problems with the 32bit opengl libraries

To test I ran it one more time.


:~$ playonlinux
Looking for python... 2.7.6 - selected
[main] Message: PlayOnLinux (4.2.2) is starting
[clean_tmp] Message: Cleaning temp directory
[POL_System_CheckFS] Message: Checking filesystem for /home/phil/.PlayOnLinux/
[main] Message: Filesystem is compatible
[maj_check] Message: List is up to date
[install_plugins] Message: Checking plugin: ScreenCap...
[install_plugins] Message: Checking plugin: PlayOnLinux Vault...
[POL_System_CheckFS] Message: Checking filesystem for PathOfExile.exe
[POL_Wine] Message: Running wine-1.5.28-PathOfExile PathOfExile.exe (Working directory : /home/phil/.PlayOnLinux/wineprefix/pathofexile/drive_c/Program Files/Grinding Gear Games/Path of Exile)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
[POL_Wine] Message: Wine return: 0

 

Registered PID: 22387 (Missing)
Registered PID: 22413 (Missing)
Registered PID: 22619 (Present)
Registered PID: 22673 (Missing)


surprisingly I got this now. I'm not even sure if this(above) indicates a problem.

Thanks for all your help and thoughts.
I'll make sure to check this topic daily for responses and respond with feedback quickly.

If you need anymore information please let me know.

Thanks again,
Phil

Basically, my thoughts on this seems to me that I need a version of directx maybe and maybe something else.


however I'm not entirely sure how to get that version of directx that I need attached to the POE vitrual machine if that is the case.


Screenshot of problem

Note: Seeing double of the error was gyazo having trouble taking a photo.

https://gyazo.com/56cb535d04f0d83e2fdf7656c4c22853

petch Sunday 18 October 2015 at 21:46
petch
Developer

Try starting the game in debug mode:

Select the game shortcut, then click on "Debug" in the side panel

That may give some insights about what's going on.

agentzulu Monday 19 October 2015 at 0:29
agentzuluAnonymous

The log file as it stands (my thoughts at the bottom)

 


[10/17/15 19:41:02] - Running wine-1.5.28-PathOfExile --version (Working directory : /usr/share/playonlinux/python)
wine-1.5.28

PlayOnLinux logfile
-------------------
Date: 10/17/15 19:41:02
Warning! PlayOnLinux is using a modified wine version (1.5.28-PathOfExile).
    Do not file bugs, AppDB test reports, or ask for help on the WineHQ website for any applications or games that are run using this version.
    
> PlayOnLinux Version
  4.2.2
> uname -a
  Linux emerald 3.13.0-65-generic #106-Ubuntu SMP Fri Oct 2 22:08:27 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
> lsb_release -a
 
> wine --version
  wine-1.5.28
> POL_WINEVERSION
  1.5.28-PathOfExile
> WINEPREFIX
  /home/phil/.PlayOnLinux//wineprefix/pathofexile
> Distribution
  Ubuntu 14.04.3 LTS
> glxinfo \| grep rendering
  direct rendering: Yes
> glxinfo \| grep renderer
      GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile
> OpenGL libs (Direct rendering testing)
 
 

[10/17/15 19:41:15] - Running wine-1.5.28-PathOfExile cmd /c echo %ProgramFiles% (Working directory : /usr/share/playonlinux/python)
C:\Program Files
[10/17/15 19:41:21] - Running wine-1.5.28-PathOfExile msiexec /i /home/phil/.PlayOnLinux//tmp/pathofexile/PathOfExileInstaller.msi (Working directory : /home/phil/.PlayOnLinux/tmp/pathofexile)
fixme:storage:create_storagefile Storage share mode not implemented.
fixme:msi:ControlEvent_SpawnWaitDialog Doing Nothing
err:setupapi:do_file_copyW Unsupported style(s) 0x144
err:setupapi:do_file_copyW Unsupported style(s) 0x144
[10/17/15 19:41:34] - Running wine-1.5.28-PathOfExile regedit /home/phil/.PlayOnLinux//tmp/override-dll.reg (Working directory : /home/phil/.PlayOnLinux/wine/linux-x86)
[10/17/15 19:41:34] - Content of /home/phil/.PlayOnLinux//tmp/override-dll.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\DllOverrides]
"*openal32"="native,builtin"
-----------
[10/17/15 19:41:38] - Running wine-1.5.28-PathOfExile PathOfExile.exe (Working directory : /home/phil/.PlayOnLinux/wineprefix/pathofexile/drive_c/Program Files/Grinding Gear Games/Path of Exile)
[10/17/15 20:40:15] - Running wine-1.5.28-PathOfExile PathOfExile.exe (Working directory : /home/phil/.PlayOnLinux/wineprefix/pathofexile/drive_c/Program Files/Grinding Gear Games/Path of Exile)
[10/17/15 20:41:52] - Running wine-1.5.28-PathOfExile PathOfExile.exe (Working directory : /home/phil/.PlayOnLinux/wineprefix/pathofexile/drive_c/Program Files/Grinding Gear Games/Path of Exile)
[10/17/15 20:56:40] - Running wine-1.5.28-PathOfExile PathOfExile.exe (Working directory : /home/phil/.PlayOnLinux/wineprefix/pathofexile/drive_c/Program Files/Grinding Gear Games/Path of Exile)
[10/17/15 20:58:08] - Running wine-1.5.28-PathOfExile PathOfExile.exe (Working directory : /home/phil/.PlayOnLinux/wineprefix/pathofexile/drive_c/Program Files/Grinding Gear Games/Path of Exile)
[10/17/15 21:08:44] - Running wine-1.5.28-PathOfExile PathOfExile.exe (Working directory : /home/phil/.PlayOnLinux/wineprefix/pathofexile/drive_c/Program Files/Grinding Gear Games/Path of Exile)
[10/17/15 21:11:12] - Running wine-1.5.28-PathOfExile PathOfExile.exe (Working directory : /home/phil/.PlayOnLinux/wineprefix/pathofexile/drive_c/Program Files/Grinding Gear Games/Path of Exile)
[10/18/15 14:02:33] - Running wine-1.5.28-PathOfExile PathOfExile.exe (Working directory : /home/phil/.PlayOnLinux/wineprefix/pathofexile/drive_c/Program Files/Grinding Gear Games/Path of Exile)
[10/18/15 14:10:46] - Running wine-1.5.28-PathOfExile PathOfExile.exe (Working directory : /home/phil/.PlayOnLinux/wineprefix/pathofexile/drive_c/Program Files/Grinding Gear Games/Path of Exile)
[10/18/15 14:11:08] - Running wine-1.5.28-PathOfExile PathOfExile.exe (Working directory : /home/phil/.PlayOnLinux/wineprefix/pathofexile/drive_c/Program Files/Grinding Gear Games/Path of Exile)
[10/18/15 18:12:55] - Running wine-1.5.28-PathOfExile PathOfExile.exe (Working directory : /home/phil/.PlayOnLinux/wineprefix/pathofexile/drive_c/Program Files/Grinding Gear Games/Path of Exile)
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:heap:HeapSetInformation 0x110000 0 0x32fdb8 4
fixme:win:EnumDisplayDevicesW ((null),0,0x32e624,0x00000000), stub!
fixme:d3d:swapchain_init The application requested more than one back buffer, this is not properly supported.
Please configure the application to use double buffering (1 back buffer) if possible.
fixme:d3d9:Direct3DShaderValidatorCreate9 stub
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:system:SystemParametersInfoW Unimplemented action: 59 (SPI_SETSTICKYKEYS)
fixme:system:SystemParametersInfoW Unimplemented action: 53 (SPI_SETTOGGLEKEYS)
fixme:system:SystemParametersInfoW Unimplemented action: 51 (SPI_SETFILTERKEYS)
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d_texture:texture_init Failed to create surface 0x5b136c8, hr 0x8876086c


"fixme:d3d:swapchain_init The application requested more than one back buffer, this is not properly supported.
Please configure the application to use double buffering (1 back buffer) if possible."

looks like I need another back buffer?

not sure what that is but looks like it is the problem. Let me know how I might go about this.

 

Thanks A lot petch

-Phil

petch Monday 19 October 2015 at 1:11
petch
Developer

Mmmmh not much to see, the issue reported may be fixed if the game supports "double buffering" instead of "tripe buffering", but I'm not sure it's the root cause of your problem.

I'd suggest trying the latest version of PlayOnLinux (4.2.9) from this site.

Also it checks whether video drivers allow for direct rendering for both 32 and 64bit programs, something removed from Debian and Ubuntu packages. Just to be sure everything is working ok in that direction.

agentzulu Monday 19 October 2015 at 3:50
agentzuluAnonymous

Hello. again,

I updated my pol and still no luck. how would I check if the video drivers allow for direct rendering? 

Sorry for my experience level of linux,

-Phil

petch Monday 19 October 2015 at 7:34
petch
Developer

If you installed PlayOnLinux 4.2.9 from the site and got no warnings about OpenGL when it starts, direct rendering should be ok.

Edited by petch

agentzulu Monday 19 October 2015 at 14:07
agentzuluAnonymous

Ok yes I see know, Everything is fine in that direction.

fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:heap:HeapSetInformation 0x110000 0 0x32fdb8 4
fixme:win:EnumDisplayDevicesW ((null),0,0x32e624,0x00000000), stub!
fixme:d3d:swapchain_init The application requested more than one back buffer, this is not properly supported.
Please configure the application to use double buffering (1 back buffer) if possible.
fixme:d3d9:Direct3DShaderValidatorCreate9 stub
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:system:SystemParametersInfoW Unimplemented action: 59 (SPI_SETSTICKYKEYS)
fixme:system:SystemParametersInfoW Unimplemented action: 53 (SPI_SETTOGGLEKEYS)
fixme:system:SystemParametersInfoW Unimplemented action: 51 (SPI_SETFILTERKEYS)
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d_texture:texture_init Failed to create surface 0x5b2e380, hr 0x8876086c

 

Is what I'll get now upon errors in debug mode.

It's still asking me for a double buffer.

EDIT : by the way upon the crash in the terminal it asks me get

http://www.playonlinux.com/api/s.php?data=ODA4Nn4wMDQ2fjB%2bUGF0aCBvZiBFeGlsZX4xfjF%2bMX5%2bMH5VYnVudHUgMTQuMDQuMyBMVFN%2bMjU2
fjEzODg2MTc2OTQxODMzMDJ%2bMX5QYXRoIG9mIEV4aWxlfjQuMi45fjY=


which is a link with OK printed on it, the whole thing is here

[POL_Wine] Message: Wine return: 0
[POL_DetectVideoCards] Message: Gettings GPU informations
[POL_LoadVar_Device] Message: VendorID : 8086
[POL_LoadVar_Device] Message: DeviceID : 0046
[POL_Website_GET]Message: GET http://www.playonlinux.com/api/s.php?data=ODA4Nn4wMDQ2fjB%2bUGF0aCBvZiBFeGlsZX4xfjF%2bMX5%2bMH5VYnVudHUgMTQuMDQuMyBMVFN%2bMjU2
fjEzODg2MTc2OTQxODMzMDJ%2bMX5QYXRoIG9mIEV4aWxlfjQuMi45fjY=

 

 

Edited by agentzulu

agentzulu Monday 19 October 2015 at 16:24
agentzuluAnonymous

Hey petch, I have an update.

If I try and run path of exile with wine 1.7.51, I'll get a black screen with the pathofexile cursor. I think it's a start.

here is the logfile.

 

Edit: Maximizing screen will now after about 5-10 min start up the homepage.

petch Monday 19 October 2015 at 16:46
petch
Developer

which is a link with OK printed on it, the whole thing is here

[POL_Wine] Message: Wine return: 0
[POL_DetectVideoCards] Message: Gettings GPU informations
[POL_LoadVar_Device] Message: VendorID : 8086
[POL_LoadVar_Device] Message: DeviceID : 0046
[POL_Website_GET]Message: GET http://www.playonlinux.com/api/s.php?data=ODA4Nn4wMDQ2fjB%2bUGF0aCBvZiBFeGlsZX4xfjF%2bMX5%2bMH5VYnVudHUgMTQuMDQuMyBMVFN%2bMjU2
fjEzODg2MTc2OTQxODMzMDJ%2bMX5QYXRoIG9mIEV4aWxlfjQuMi45fjY=

That's because upon first run you answered "yes" to the question "Do you want PlayOnLinux to make a compatibility database?"

So what you're seeing is the report of the success or failure of the execution.

agentzulu Monday 19 October 2015 at 18:37
agentzuluAnonymous

Thanks for all your help guiding me petch, appreciate it.