The forum

Darkest Dungeon (Steam) - Sound stuttering

Author Replies
Brainmind Friday 22 January 2016 at 21:47


I finally decided to give POL a try after resorting to dual booting for the past. Setting up Steam worked absolutely flawlessly, as did installing Darkest Dungeon. It didn't run at first, but I could fi that by simply installing the vcrun2013 extension.

In principle, the game works well, but I have issues with sound crackling and stuttering intermittently. I found quite a few threads mentioning similar problems, but I couldn't get it to work just yet.

I am using an onboard soundchip, and I'm running PulseAudio for Plasma 5. When running pavucontrol while POL Steam is opened, I have an additional playback device there, named "ALSA plug-in [wine-preloader]: ALSA Playback on". As soon as I start Darkest Dungeon, I get two more of these - one of them disappears as soon as the intro cinematic finishes playing, so I assume that is some kind of adapter for pre-rendered videos.

The intro cinematic runs fine. When I go ingame, however, the stuttering starts. Whenever a stutter occurs, The "ALSA plug-in" in pavucontrol flickers off and on briefly, and the debug log outputs "ALSA lib pcm.c:7963:(snd_pcm_recover) underrun occurred".

Now, I understand POL doesn't officially support PulseAudio, and I tried the the BEFORE_WINE flag with pasuspender and papsd, both didn't change anything. I then removed pulseaudio-alsa and killed pulseaudio manually to ensure pure ALSA playback, but still, the problem persists.

Even more confusingly, Legend of Grimrock (started through the same POL Steam instance, not using the native Linux client) works perfectly fine. I'm at a loss and would greatly appreciate any input, because I no longer know what else to try!

petch Friday 22 January 2016 at 22:49

Now, I understand POL doesn't officially support PulseAudio, [...]

Correction, we didn't support it more than official Wine did.

Those days you get PulseAudio support from official Wine since 1.7.55, and before that using wine-staging patched versions.

Edited by petch

Brainmind Saturday 23 January 2016 at 2:54

Interesting, thank you. Based on this new information, I manually changed the Wine version used for Steam to the current 1.9.2 from the default 1.7.53-steam-crossoverhack. To enable the pulseaudio driver, I exported the winepulse.drv keys from a Photoshop virtual drive that I set up in an unrelated fashion and imported that to the registry of the Steam drive. I also created the "audio" string in the "Drivers" key and set it to "pulse". Somewhat surprisingly, this entirely hackish solution worked, and I can now use native pulseaudio with steam. However, this did not fix the underlying problem of stuttering sound, it's still the same as before.

I also tried the widely-published solution of editing /etc/pulse/daemon.conf and editing the default-fragments and default-fragments-size to different values, none of which proved successful, so i'm still open to suggestions.

Edited by Brainmind

DrSarez Wednesday 27 January 2016 at 20:57

Following solved the problem for me on Gnome Ubuntu 15.04 with default PlayOnLinux from Repos:


Configure you Steam Installation in POL -> goto Wine -> 'Configure Wine' -> goto the 'Audio' tab -> change the default audio output from 'system default' to another one (for me it was 'Out: HDA Intel - ALC889A Digital').

However I have a german Linux and translated the steps into english. Some menu items may be labeled different. One more note: Testing the sound device leads to no output. However since the new setting, the game sound works as expected.

Brainmind Thursday 28 January 2016 at 16:31

This didn't work for me, unfortunately. Which Wine version and sound driver did you use?