The forum

[GW2] performance and freeze on start

I can play the game, but....

Author Replies
xen111 Wednesday 30 March 2016 at 2:49

Okay so for some reason I want to talk in Dutch here, so I will, a bit.

Het spel start nu maar ik heb een ontzettend slechte performance. Ik zal verder gaan in het Engels.

My system:

OS: Kubuntu 16.04
POL: 4.2.10
Wine version: 1.7.35   - I am using __GLVND_DISALLOW_PATCHING=1  in the startup shortcut to get around the nVidia 361.28 bug (without having really encountered it yet myself)
CPU: Athlon X2 5050e
GPU: nVidia GeForce GT 640
driver: 361.28 (updates)

My system FREEZES as per the threads by other people. However, it appears as though the system doesn't freeze and it just stops redrawing the screen when the launcher is active -- but I can still type my username, password, I can press the login button, and I can press the play button, after that it starts and my desktop returns to normal.

During that LAUNCHER freeze my Xorg CPU usage is 100%.

But I can get past it, so it is not much of a problem at this point.

(Currently running with Wine set to virtual desktop. Not sure if it matters yet.)


The first time the program crashed pretty soon with a weird memory access bug/fault.

Second time (I did change virtual desktop) it runs without fault now.
Performance is ABYSMAL. "Psensor" program records total CPU usage at about 2x 60%, and maximum GPU has been registered at 51%. That's like really weird, which means there should be another bottleneck right.

I haven't attempted anything else yet. I have not manually installed any components. I have not manually changed any options (except virtual desktop). The resolution is at 1440x900 which is monitor native. I can alt-tab in and out of the game without problems. Guild Wars runs at 12 fps at the moment.

And the weird thing is that CPU and GPU are not maxed out even at this FPS.

I have installed the game out of the POL application.

The game being used is the 64-bit version: gw2-64.exe

Options are currently just -dx9single and -autologin.

I wanted to make this thread here to collect information and to have a place where to place it. I get really confused with POL vs Wine proper, and there is also wine-staging, and I don't know how to do everything (yet).

(One more thing: I have issues with the mouse. I cannot rotate the camera view more than the distance of the cursor to the edge of the screen, from the moment I press the right mouse button to rotate.)

Edited by xen111

xen111 Wednesday 30 March 2016 at 4:37

So I have been looking at overall performance on Windows for my graphics card, and even with high settings people should get about 20 fps, although it depends on the CPU as well.

Currently I have not been able to increase or decrease the general FPS, although my latest start did decrease it (setting were at medium and -dx9single was removed). I have not attempted the 32-bit version yet. I have tested 3 different 64-bit Wine environments: the default, the 1.7.4-guildwars2 build, and the 1.9.5-staging build.

I have used every trick I have seen on the official guildwars2 wiki. I have disabled GLSL, enabled CSLT, and installed d3dx9. I am also running with or without "virtual desktop' -- it makes no difference.

What I haven't done is:

  • overclock my cpu
  • try a 32-bit version

But the game is not even USING full CPU.

My mouse problem apparently disappeared by selecting "Mouse Warp Override".

This is the only output in the debug window when/after running the game, mostly:

[03/30/16 04:43:41] - Running wine-1.9.5-staging Gw2-64.exe -dx9single -autologin (Working directory : /home/xen/.PlayOnLinux/wineprefix/GuildWars2/drive_c/Program Files (x86)/ArenaNet/Guild Wars 2)
wine: DLL not found.


The Freeze problem

I have been able to solve the launcher freeze problem for me by using both 32-bit wine prefix and 32-bit application.

  • I went into the shortcuts directory of ~/.PlayOnLinux and copied the "Guild Wars 2" script to "Guild Wars 2 - 32 bit".
  • I went into the icones subdirectory and created a copy of all GW icons with the same name
  • I created an empty "GuildWars2-32" directory in the wineprefix directory
  • I copied playonlinux.cfg from the old to the new, and modified amd64 to x86
  • I ran WINEARCH=win32 WINEPREFIX=~/.PlayOnLinux/wineprefix/GuildWars2-32/ ../wine/linux-x86/1.9.5-staging/bin/winecfg from that directory
  • I went into the new -32 prefix and symlinked 
    ~/.PlayOnLinux/wineprefix/GuildWars2/drive_c/Program Files (x86)/ArenaNet to ~/.PlayOnLinux/wineprefix/GuildWars2-32/drive_c/Program Files, creating a symlink there.
  • I downloaded Gw2.exe and put it in that directory
  • I modified the shortcut to "Guild Wars 2 - 32 bit" to include the new directories and then I launched this shortcut from PlayOnLinux. POL will cause Wine to regen the config once more.
  • The game then downloads some 32-bit libraries and then simply starts, without downloading the data files again.

Now to my surprise the freezing launcher thing is no longer there. It now responds normally, if a bit slow. Xorg still takes some 80% CPU and now CoherentUI_host is also there at 80%. But at least the system responds.

Alt-tab didn't work when by my error, Wine was set to "system". It works when it is set to 1.9.5-staging. My FPS is still about 15 max but it's the best I have had. It still doesn't use full CPU even though it uses 2 cores. It also doesn't use full GPU.

Edited by xen111