The forum

[Issue] UnderRail, LMDE2, no suitable graphics card found,

Help me play the Mole People game!

Author Replies
CroMagnon Saturday 2 July 2016 at 13:45

Edit:  I think I posted in the wrong forum. I've never used POL or WINE before and I don't even know if I have them working correctly. Therefore, how do I know I am even suitably testing a manual installation? I don't. So, I've reposted this to the PlayOnLinux subforum.

You may as well skip everything below and ignore this post. Unless you're a moderator. I apologize, I'll need a mod to delete this thread.


Greetings, and with great humility and lowly need of aide do I beseech ye who are wise in my struggle against my netbook. I am ashamed before humanity!

I have tried around 5 or 6 times to install the latest GOG version of UnderRail. The game seems to install okay, but attempts to run it fail with this error:

"No suitable graphics card found. Could not find a Direct3D device that supports XNA Framework Reach profile."

I tried the exact instructions and components from this post:

Before I go into more detail, here are my specs:

Linux version: 

LMDE2 (Linux Mint Debian Edition 2, based on Debian Jessie)

Kernel: 4.5.0-0.bpo.2-amd64

MultiArch appears to be set up fine.

POL Version: 

4.2.10. For the first install, I used POL 4.2.5 (stable) from the Jessie repository. Then, I installed 4.2.10. With both versions, the problem behaved the same.

For my first 2 or 3 attempts, I had Wine 1.8.2 32bit and 64bit installed from Debian Backports. 

Computer Specs:

Lenovo S21E netbook

CPU: Intel Celeron N2840 Dual Core 2.16GHz

RAM: 2 Gb

GPU: Intel Atom Processor Z36xxx/Z37xxx Series - using i915 driver provided by Jessie package xserver-xorg-video-intel version 2:2.21.15-2+b2.

Error messages:

I've uninstalled and reinstalled POL several times, and do not have debug logs at the moment. Upon request, I can do it all again to get debug logs.

For every install (in POL and using WINE/wineprefix alone), I get the "Runtime Error 69:445" message before the install finishes. I've read that this is not always a problem.

But, I have never once had the UnderRail game icon show up in the POL main window. The only way I can try to play it is to go to Configure, choose the virtual drive, and then run an .exe.

So, again, I get this:

"No suitable graphics card found. Could not find a Direct3D device that supports XNA Framework Reach profile."


In addition to the components listed in the POL forum link above, I have also tried installing:

XNA3.1 plus the suggested components.

XNA4.0 plus suggested components.

Both XNA versions plus the components.

D3DFull plus the components.

WindowsVideoDriver plus the components, and possibly one or both XNA's at the same time (I don't remember clearly. "No suitable brain cells found.")

And, I forget whatever other combination I tried.

To start over clean, I deleted the virtual drive after each attempt.

In addition to WINE 1.8, I also used the POL WINE Manager and tried WINE versions 1.8.2, 1.9.1, and I think 1.9.3.

The last thing I tried was the WINEPREFIX method from this post on the GOG forums:

That results in the same error, and I tried various combinations of components with that, as well.

I'm curious whether LMDE2/Debian Jessie require things I don't know about to make WINE and POL work nice. I'm aware Ubuntu and regular Mint are more friendly for this.

I'm hoping I just need to do something with POL. If this is an issue with LMDE2 stuff, just point me vaguely in the right direction if no one wants to get into helping with that.

Whoever can help with this, I know that much of this information may or may not be immediately useful, so I'll try whatever anyone suggests as long as it doesn't result in fire and as long as the conclusion isn't like the end of the movie "Pi".

I'd just like to add that this is why robots should be distrusted and regarded as evil.

Thank you for your time.

Edited by CroMagnon

CroMagnon Sunday 3 July 2016 at 6:18

Looks like I posted in the wrong subforum and gave the impression I've done this before.

In the post I linked to, booman said installing UnderRail was a manual installation, so I posted here. But, this is the first game I've ever tried to install with WINE or POL. I've never used either one before. Being that I am not someone who is knowledgeably testing this, but someone new to the software who is merely throwing things together until it works, I don't even know if I've got POL and WINE set up correctly. I think posting here gives the impression that I know what I'm doing.

I think I do, but I'm going to repost this in the PlayOnLinux subforum, so if a moderator can remove this post, I would appreciate it.