You are here    Forums    PlayOnLinux    Audio Error GTA SA nl sv ru pl es de fr

The forum

Audio Error GTA SA

Author Replies
binny Sunday 10 September 2017 at 20:20
binny Anonymous

I can play SAMP/GTA-SA-OFF fine on my Positivo Union PCTV C1260 computer...

But sometimes while i'm playing the sounds get bugged, and on playonlinux debugger flood this:

ALSA lib pcm.c:8306:(snd_pcm_recover) underrun occurred

And while this error is printing i can not play, it's be unplayable, so many lag...

My Wine version: 2.0.2

Edited by binny

booman Wednesday 13 September 2017 at 1:42
booman

Wow, those are errors I haven't seen in a few years.  I used to get those with older versions of wine.  This is because older versions did not support Pulseaudio.  Now current versions of Wine support Pulseaudio and you should be seeing those errors.

Maybe your Pulseaudio needs to be updated/upgraded?

Yeah, that bug definitely can kill frame rates in-game and cause audio stutter.


† Booman †
Mint 18.1 64-bit | Nvidia 378 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
binny Wednesday 13 September 2017 at 2:37
binny Anonymous

I'm using 2.0.2, is the last stable version...

What are u mean about update/upgrade pulseaudio?

apt-get install pulseaudio
Reading package lists... Done
Building dependency tree       
Reading state information... Done
pulseaudio is already the newest version (10.0-1+deb9u1).
The following packages were automatically installed and are no longer required:
  blueman cinnamon-common cinnamon-l10n cjs gconf2 gir1.2-appindicator3-0.1
  gir1.2-cmenu-3.0 gir1.2-javascriptcoregtk-3.0 gir1.2-keybinder-3.0
  gir1.2-meta-muffin-0.0 gksu libappindicator3-1 libcjs0 libdbusmenu-gtk3-4
  libgksu2-0 libglewmx1.13 libindicator3-7 libjavascriptcoregtk-3.0-0
  libkeybinder-3.0-0 libnemo-extension1 metacity-common nemo nemo-data
  nemo-fileroller python-dbus python-imaging python-pam python-pexpect
  python-pil python-ptyprocess python-pyinotify
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

 

booman Wednesday 13 September 2017 at 18:26
booman

That is so strange. Since you are on the newest version of Pulseaudio and Wine maybe its your PlayOnLinux version?

I haven't seen or experienced those Alsa underrun symptoms in a few years.

Here was the solution we used to apply:

 

ALSA lib pcm.c:7905:(snd_pcm_recover) underrun occurred

The problem can be remedied by editing /etc/pulse/default.pa 

and changing default parameters to
default-fragments = 5
default-fragment-size-msec = 2 

then restarting pulseaudio by
pulseaudio -k

solution found at
https://bbs.archlinux.de/viewtopic.php?id=27711

I'm not sure who should change their settings, Wine, Fedora or others, but hope this helps others make it work.

 


† Booman †
Mint 18.1 64-bit | Nvidia 378 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained