You are here    Forums    Manual installations    How to run mono instead of dotnet nl sv ru pl es de fr

The forum

How to run mono instead of dotnet

Author Replies
pleiades Monday 7 May 2018 at 23:13
pleiades Anonymous

Hi,

 

I'm trying to run a download manager called Mipony (http://www.mipony.net/downloads/Mipony-Installer.exe) but it crashes, I tried running it on mono and it seems to be much stable except it does not show some part of the gui so you cannot use it.

 

This is running playonlinux + dotnet 2

https://imgur.com/0610xI0

 

the error I got is about corrupt memory

https://imgur.com/Ea4uzjZ

 

after the error, the application crash. before the crash, the application is usable, you can click on buttons and change options and it updates itself fine. the problem is that it will take a just a few second before it will crash so you cannot do anything about it.

 

 

I tried running it on mono since its a dotnet application

https://imgur.com/l4fUc1G

 

The error i got is

https://imgur.com/2RL7Ul3

 

The good thing about this is the application does not crash, you can click the button all day but the lower part of the gui is not usable

https://imgur.com/IVblkUr

 

The application should be like this, the bottom part you can see the download links

http://i1-win.softpedia-static.com/screenshots/Mipony_2.png

 

Maybe the problem is that it sees the os as Linux or it uses other windows os part, so I tried to install wine-mono in playonlinux but I cant seem to make it work. 

 

Can anyone help me with this? thank you!

Edited by pleiades