The forum

Mipony: How to run Mono instead of Dotnet ?

Author Replies
pleiades Monday 7 May 2018 at 23:13



I'm trying to run a download manager called Mipony ( but it crashes, I tried running it on mono and it seems to be much stable except it does not show some part of the gui so you cannot use it.


This is running playonlinux + dotnet 2


the error I got is about corrupt memory

after the error, the application crash. before the crash, the application is usable, you can click on buttons and change options and it updates itself fine. the problem is that it will take a just a few second before it will crash so you cannot do anything about it.



I tried running it on mono since its a dotnet application


The error i got is


The good thing about this is the application does not crash, you can click the button all day but the lower part of the gui is not usable


The application should be like this, the bottom part you can see the download links


Maybe the problem is that it sees the os as Linux or it uses other windows os part, so I tried to install wine-mono in playonlinux but I cant seem to make it work. 


Can anyone help me with this? thank you!

Edited by Dadu042

Dadu042 Monday 25 March 2019 at 11:19

What versions did you test ? (on a screenshot I see Mipony v2.5.4)
Do you know what is the Dotnet version that this app need ?


Note: I tried Mipony v3.0.4 + Wine 4.0: installation work, but I get a crash before the app start.

Unhandled Exception:
System.TypeInitializationException: The type initializer for '<Module>' threw an exception. ---> System.InvalidProgramException: Invalid IL code in gfDJNHneTgY7EmUSFKC.V18wMOnf7xvHKV71E4P:JaETA3CNGLI 

Edited by Dadu042

pleiades Saturday 26 October 2019 at 9:31

Hello Dadu042, thanks for helping me out!


The version that I would like to run is Mipony v2.5.4, I think they updated their app to v3 now.

I'm not sure which Dotnet version it needs, based on the changelog 2.5.6


Mipony will run under .NET Framework 4.x if it is installed. It is recommended to install .NET Framework 4.6 or newer.


v2.5.4  should be using v4 or lower.


Do you want to test the v2.5.4? i can upload it somewhere since you cannot download this in the mipony website.


Dadu042 Tuesday 21 January 2020 at 10:11

Note: POL and POM does now have functions to install Dotnet > 4.5 (you can try also latest Mono functions).

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to