The forum

Fonts Looking like garbage

Author Replies
Jump to the page: 1 - 2
sinemora Tuesday 8 January 2019 at 4:35
sinemoraAnonymous

Hi Everyone,

Fonts in any applications on PlayonMac or just Wine look like garbage: no antialiasing or hinting whatsoever. I downgraded Xquartz to 2.9.7 as suggested on reddit, but to no avail. The problem affects anything on any versions of Wine I can currently download through PoM, including the winecfg. I tried and researched about everything, anyone has any tricks up their sleeve to fix this?

 

Thank you very much  

Quentin PÂRIS Tuesday 8 January 2019 at 17:19
Quentin PÂRIS
Admin

Hi,

Can you provide a screenshot please?

Thanks

smaira Monday 14 January 2019 at 18:49
smairaAnonymous

I'm running into the same issue. I was able to downgrade to XQuartz 2.7.9 and that fixed the issue on my previous macbook pro which was running the older OSX version but it's not working with macOS Mojave 10.14.2.

This is a link to the software  - Jagannath Hora .

Here is a screenshot of what it looks like on my Mac.

Here is a Screenshot of what it should look like. It's not the best image because it's pixelated but you get the idea.

Maybe this is an issue with the newer version of the Mac OS?

-Sameer
 

 

Edited by smaira

Quentin PÂRIS Monday 14 January 2019 at 21:12
Quentin PÂRIS
Admin

We are no longer using XQuartz, this is why it does not work.

If you change the HDPI in wine config, does all the font scale?

smaira Monday 14 January 2019 at 22:32
smairaAnonymous

Oh so if I uninstall XQuartz, it should still work?

Where do I find the HDPI setting in Wine Config ?

smaira Monday 14 January 2019 at 22:43
smairaAnonymous

Never mind, I found it. So when I increase the DPI in the Wine Config, it only affects the Menu Components. Here is a screenshot with the parts that changed highlighted. I set it to a ridiculous 168 DPI and this is what it looks like.  The fonts are still not anti-aliased.

 

 

Quentin PÂRIS Monday 14 January 2019 at 23:36
Quentin PÂRIS
Admin

Too bad. My idea was to set up retina mode, but it won't work because all the fonts do not scale.

What if you install gdiplus?

smaira Tuesday 15 January 2019 at 0:03
smairaAnonymous

I don't know what gdiplus is. How do I install it?

Quentin PÂRIS Wednesday 16 January 2019 at 9:33
Quentin PÂRIS
Admin

(On the right virtual drive)

Résultat de recherche d'images pour "gdiplus playonmac"

smaira Wednesday 16 January 2019 at 21:29
smairaAnonymous

Thanks, I tried installing it but it did not have any effect. I also set the Direct Draw renderer to GDI.

sinemora Thursday 17 January 2019 at 3:38
sinemoraAnonymous

Thank you everyone for the answers, I had my mac sent in for repairs and could not take a look at the thread but now. I was also unaware PoM isn't using XQuartz! Installing gdplus and changing the DPI unfortunately isn't working either. 

smaira Friday 18 January 2019 at 19:50
smairaAnonymous

Anything else we can try Quentin?

sinemora Saturday 2 February 2019 at 8:03
sinemoraAnonymous

I just saw a new version of Wine released (4.0) I will try it in a new bottle and see if the problem persists.

smaira Sunday 10 February 2019 at 19:12
smairaAnonymous

Did that work for you sinemora? 

How did you upgrade with PlayOnMac?

sinemora Sunday 24 February 2019 at 8:55
sinemoraAnonymous

Hi Smaira, no unfortunately I haven't found a solution and updating wine to 4.0 within PoM didn't solve the problem either. But if I install office using Wine outside PoM I see the fonts look better. Hope Quentin has an ace up his sleeve.

Quentin PÂRIS Sunday 24 February 2019 at 12:28
Quentin PÂRIS
Admin

What is the version of wine that is used outside PoM?

sinemora Sunday 24 February 2019 at 16:38
sinemoraAnonymous

HI Quentin,

I am using the latest stable version (4.0) with the latest abvailable XQuartz (2.7.11). I am also using the latest truetype version (40). I would attach a screenshot of both my W2007 and W2010 but for the life of me I cannot seem to understand how to upload them

sinemora Sunday 24 February 2019 at 16:40
sinemoraAnonymous

HI Quentin,

I am using the latest stable version (4.0) with the latest abvailable XQuartz (2.7.11). I am also using the latest truetype version (40). I would attach a screenshot of both my W2007 and W2010 but for the life of me I cannot seem to understand how to upload them

Quentin PÂRIS Tuesday 26 February 2019 at 21:17
Quentin PÂRIS
Admin

So you are using XQuartz, is that correct? If so, we should be able to create a winebuild that supports XQuartz inside POM for your particular case.

smaira Tuesday 26 February 2019 at 21:19
smairaAnonymous

That would be great!