The forum

The Sims 3: OpenGL support is disabled

Author Replies
oz1sej Friday 2 August 2019 at 13:01
oz1sejAnonymous

I've succesfully installed The Sims 3 from DVD. Now, I get this error when running:

 

[08/02/19 12:56:54] - Running wine-1.4.1 TS3.exe (Working directory : /home/steen/.PlayOnLinux/wineprefix/TheSims3/drive_c/Program Files/Electronic Arts/The Sims 3/Game/Bin)
err:winedevice:ServiceMain driver L"WineBus" failed to load
err:module:load_builtin_dll failed to load .so lib for builtin L"glu32.dll": libGL.so.1: kan ikke åbne delt objektfil: Ingen sådan fil eller filkatalog
err:wgl:has_opengl Failed to load libGL: libGL.so.1: kan ikke åbne delt objektfil: Ingen sådan fil eller filkatalog
err:wgl:has_opengl OpenGL support is disabled.
err:d3d_caps:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat.
err:d3d:InitAdapters Failed to get a gl context for default adapter
Direct3D9 is not available without OpenGL.
err:d3d_caps:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat.
err:d3d:InitAdapters Failed to get a gl context for default adapter
Direct3D9 is not available without OpenGL.
fixme:dbghelp:elf_search_auxv can't find symbol in module

 

I'm pretty sure I have OpenGL installed correctly:

 

$ glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 750 Ti/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 418.74
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 418.74
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 418.74
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

 

libglu1-mesa AND libglu1-mesa:i386 are installed. What to do now?

Edited by oz1sej

oz1sej Friday 2 August 2019 at 13:36
oz1sejAnonymous

It works! This is what did it for me:

 

$ sudo apt-get install libgl1-nvidia-glx:i386
Dadu042 Friday 2 August 2019 at 16:17
Dadu042
Moderator

Thanks for the report. Upgrading wine version (I see wine-1.4.1) may help too.

Dadu042 Sunday 4 August 2019 at 7:13
Dadu042
Moderator