The forum

The Elder Scrolls IV: Oblivion - having problems to install it

Author Replies
Jump to the page: 1 - 2
drakojan Monday 7 December 2009 at 17:02

Hi, i'm new here and like the title says i have some problems to install it. Basically (on kubuntu) i select to make install from media-cdrom or media-cdrom0. Then, while is creating the prefix it spawn a message saying :

Following server is no longer available:

How i can resolve it?Please helpme.

O.T.= My apologises if my english isn't perfect. Anyway i can write in spanish or italian. :D

Edited by drakojan

Dr Phil Monday 7 December 2009 at 19:49
Dr Phil


It was just a small bug, I've made a small update with the bug corrected. Now the download works correctly.
(I also updated some deprecated code.)

To run the script, copy the code below and save it as "" in any folder you want.
Open PlayOnLinux and press "Tools" and "Run an unofficial script", choose the file you copied the code to and follow the instructions. Thank you very much for telling us it was broken, and please tell us if you notice more problems with this or any other script. =)

[code language="PlayOnLinux"]#!/bin/bash
[ "$PLAYONLINUX" = "" ] && exit
source "$PLAYONLINUX/lib/sources"

if [ "$POL_LANG" == "fr" ]; then
     LNG_DX9_DL="Téléchargement de la mise a jour DirectX9.0c pour Wine..."
     LNG_DX9_INSTALL="L'installation de la mise a jour DirectX9.0c pour Wine va débuter."
     LNG_WAIT_END="Appuyez sur \\"Suivant\\" UNIQUEMENT quand l'installation du jeu sera\\nterminée sous peine de devoir recommencer l'installation."
     LNG_WARNING_UPDATE="Si vous n'avez pas l'add-on \\"Shivering Isle\\" il est recommander\\nde patcher le jeu avant de l'utiliser."
     LNG_DX9_DL="Downloading Wine DirectX9.0c Update..."
     LNG_DX9_INSTALL="DirectX9.0c Update installation will begin."
     LNG_WAIT_END="Click on \\"Next\\" ONLY when the game installation\\nis finished or you will have to redo the installation."
     LNG_WARNING_UPDATE="If you do not have \\"Shivering Isle\\" addon\\nit's recommanded to update this game before use it."

rm *.jpg
wget $SITE/setups/oblivion/left.jpg
POL_SetupWindow_Init "" "$REPERTOIRE/tmp/left.jpg"
POL_SetupWindow_presentation "The Elder Scrolls 4 - Oblivion" "2K Games" "" "GNU_Raziel" "TheElderScrolls4_Oblivion"

POL_SetupWindow_check_cdrom "setup.exe"

select_prefix "$REPERTOIRE/wineprefix/TheElderScrolls4_Oblivion/"

#cd $WINEPREFIX/dosdevices
#ln -s $CDROM d:

if [ ! -e "$REPERTOIRE/ressources/" ]; then
     mkdir -p "$REPERTOIRE/ressources/"

cd "$REPERTOIRE/ressources/"

if [ ! -e "$REPERTOIRE/ressources/D3DX9_XX_dll_\\(32Bit_All\\).zip" ]; then
     POL_SetupWindow_download "$LNG_DX9_DL" "The Elder Scrolls 4 - Oblivion" ""

cd $WINEPREFIX/drive_c/windows/temp/
unzip $REPERTOIRE/ressources/D3DX9_XX_dll_\\(32Bit_All\\).zip
POL_SetupWindow_message "$LNG_DX9_INSTALL" "The Elder Scrolls 4 - Oblivion"
Set_OS "winxp"
wine c:\\\\windows\\\\temp\\\\D3DX9_XX_dll_\\(32Bit_All\\)\\\\Install\\\\DXSETUP.exe

#wine d:\\\\setup.exe
wine "$CDROM/setup.exe"

POL_SetupWindow_message "$LNG_WAIT_END" "The Elder Scrolls 4 - Oblivion"

Set_Managed "On"
Set_DXGrab "On"
echo "[HKEY_CURRENT_USER\\Software\\Wine\\DirectSound]" > $REPERTOIRE/tmp/directsound.reg
echo "\\"DefaultBitsPerSample\\"=\\"16\\"" >> $REPERTOIRE/tmp/directsound.reg
echo "\\"DefaultSampleRate\\"=\\"44100\\"" >> $REPERTOIRE/tmp/directsound.reg
echo "\\"EmulDriver\\"=\\"Y\\"" >> $REPERTOIRE/tmp/directsound.reg
echo "\\"HardwareAcceleration\\"=\\"Emulation\\"" >> $REPERTOIRE/tmp/directsound.reg
regedit $REPERTOIRE/tmp/directsound.reg
echo "[HKEY_CURRENT_USER\\Software\\Wine\\Drivers]" > $REPERTOIRE/tmp/drivers.reg
echo "\\"Audio\\"=\\"oss\\"" >> $REPERTOIRE/tmp/drivers.reg
regedit $REPERTOIRE/tmp/drivers.reg
echo "[HKEY_CURRENT_USER\\Software\\Wine\\Direct3D]" > $REPERTOIRE/tmp/d3d.reg
echo "\\"OffscreenRenderingMode\\"=\\"fbo\\"" >> $REPERTOIRE/tmp/d3d.reg
regedit $REPERTOIRE/tmp/d3d.reg

cd "$WINEPREFIX/drive_c/Program Files/Bethesda Softworks/Oblivion/"
mv Oblivion_default.ini
cat | sed s/bForce1XShaders=1/bForce1XShaders=0/g | sed s/bSaveOnInteriorExteriorSwitch=1/bSaveOnInteriorExteriorSwitch=0/g | sed s/bUseWaterShader=1/bUseWaterShader=0/g > Oblivion_default.ini
#mv Data/Video Data/Video2
#mkdir -p Data/Video


POL_SetupWindow_make_shortcut "TheElderScrolls4_Oblivion" "Program Files/Bethesda Softworks/Oblivion/" "OblivionLauncher.exe" "ElderScroll4_Oblivion.xpm" "The Elder Scrolls 4 - Oblivion"
POL_SetupWindow_message_image "$LNG_WARNING_UPDATE" "The Elder Scrolls 4 - Oblivion" "$PLAYONLINUX/themes/tango/warning.png"
PS: I am not very good on English neither, unfortunately I can't even write more than "¡Hola!" in Spanish. ;)
NSLW Monday 7 December 2009 at 20:24

I see that you switched to POL_SetupWindow_prefixcreate. Is there anything else you did?
Anyway thanks for your help. The script is updated now.
Dr Phil Monday 7 December 2009 at 20:38
Dr Phil

I added one row in here:

if [ ! -e "$REPERTOIRE/ressources/" ]; then 
mkdir -p "$REPERTOIRE/ressources/" 
cd "$REPERTOIRE/ressources/" 
#This line was added.. ..somewhere around line 37.

if [ ! -e "$REPERTOIRE/ressources/D3DX9_XX_dll_\\(32Bit_All\\).zip" ]; then 
POL_SetupWindow_download "$LNG_DX9_DL" "The Elder Scrolls 4 - Oblivion" "" 

And I think that was all. =)
I did also remove cfg_check at the beginning of the script, since it is deprecated.

I got the game installed and could play it without any big problems.
It was slow in the menus and the game did not catch any keypresses before the mainmenu had popped up.

BTW: In this script the creator changes some wine-settings with regedit instead of using the built-in POL-functions. Is that recommended?
Dr Phil Monday 7 December 2009 at 21:00
Dr Phil

The 1.2 patch did work good for me, still no real bugs.
There were some minor spelling mistakes in the installation script though, but I may have added some new mistakes since I'm not a fluent speaker.

Corrected texts (The Elder Scrolls IV - Oblivion Patch 1.2.0416):
LNG_OBLI_UPDATE_WELCOME="Welcome to the patch 1.2.0416 installation for The Elder Scrolls 4 - Oblivion.\\nNote that you DO NOT NEED to install this update if you have the \\"Shivering Isle\\"-addon!"
LNG_OBLI_UPDATE_INFO1="I will download the patch from the official website.\\nThis operation may take a long time to complete.\\nClick \\"Forward\\" to begin."
LNG_OBLI_UPDATE_DL="Please wait while the patch is downloading...\\nThis operation can take a while, depending on your internet connection."
LNG_OBLI_UPDATE_INSTALL="Download finished. Patch installation will begin."
LNG_OBLI_UPDATE_FINISHED="The patch was installed successfully."

Edited by Dr Phil

NSLW Monday 7 December 2009 at 22:23

BTW: In this script the creator changes some wine-settings with regedit instead of using the built-in POL-functions. Is that recommended?

Quote from Dr Phil

No. It isn't recommended, but this script might be created before these POL functions were created.

Your text for patch seems to look better that the present one so I included it in script database, adding note about you.
Unfortunately I don't know how to fix this script because I don't know where it fails. What language of Oblivion you've got and what patch is used? The best would be to give official link for that patch.

Edited by NSLW

Dr Phil Monday 7 December 2009 at 22:40
Dr Phil

Fix what script?
The one for the patcher or the one for the game itself?

The patcher did work great for me, and the installer just couldn't download D3DX9_XX_dll_(32Bit_All).zip from this site, which was fixed (at least for me) with my small update to the script. (Which was posted in my first reply)
NSLW Tuesday 8 December 2009 at 11:18

Sorry, I didn't read carefully. Nothing needs to be fixed.
Ataronchronon Wednesday 9 December 2009 at 4:04

Wow, three days of searching and I think I found where I need to be!
I got Oblivion installed with PlayOnLinux (and wine in case you were wondering) and it starts with the pre-main menu (with uninstall, play, exit, tech support, etc.) and it works there, but i get a message regarding a dxdllreg.exe failure (does nothing, tried to find it in regedit but couldn't) and I get to the Oblivion main menu.
This is where it gets bad.
I click load, new, continue, anything really, and it gets halfway through loading then crashes saying Oblivion.exe failed every time.
I also tried to install patch 1.2 and it says the Oblivion servers are no longer available.
Any help at all you guys could offer would be fantastic!
Thanks in advance from an ubuntu newbie ^_^

Edit: forgot to mention, running all this on 9.10 karmic

Edited by Ataronchronon

NSLW Wednesday 9 December 2009 at 9:44

Try earlier Wine versions. As i remember there was an regression which was causing the same for Gothic 3.
Ataronchronon Wednesday 9 December 2009 at 17:04

Tried a couple .9 versions so far and it hasn't worked, but I'll keep trying some others.
Any suggestions about the patch server problem?

Edit: got Oblivion working itself, still no patch.
I'll be trying the add-ons and expansions later.

Edited by Ataronchronon

NSLW Wednesday 9 December 2009 at 17:46

There is many informations in your post but sadly i cannot help you.
Dr Phil Wednesday 9 December 2009 at 18:43
Dr Phil

I now know my the patch doesn't work. My translations! :D

When I posted in the forum, the linebreak characters "\\ n" got converted to real linebreaks, which broke the functional code. pinch:

Someone just has to fix the linebreaks and the patch will be up working again, I am so sorry for your problems! :sad:

EDIT: The patcher-script with corrected translations:

Edited by Dr Phil

drakojan Wednesday 9 December 2009 at 20:55

Thank you very much to all. Now i fixed that problem but after installed it i try to play and strongly my character gone forward and slight left by itself. I tryed to change the keyboard configuration but nothing is happened. Then, when i want to download the official patch listed on the playonlinux menu it says it is no longer available (like ataronchronon i'm using karmic 9.10, same problem) but i'm gone at and download it (-.-) and tryed to install via wine or playonlinux manually... no way, a little bit of errors like "Missing/Invalid Registry" bla bla bla. Any ideas?

Edited by drakojan

Dr Phil Wednesday 9 December 2009 at 22:22
Dr Phil

I would do this:
1. Uninstall oblivion (take backups of any savegames you want to save.)
2. Install Oblivion with POL.
3. Try to play the game, any errors or bugs? If so, tell us here at the forum.
4. Maybe patch to 1.2 with POL, but you might run into more bugs with this. (1.2 is rated silver and 1.0 is rated platinum)
5. Tell us if you run into any bugs with 1.2.

The autorunning problem might be solved by telling Wine to use a virtual desktop.
The next time you ask for help, please also tell us if you use any joysticks or such. =)
Ataronchronon Wednesday 9 December 2009 at 22:37

I have done 1 through 3, and that's as far as I get.
Everything works fine straight from the DVD, but I can't install the patch.
I tried your script, and it gets as far as "I will download from the official website" blah blah blah then click forward and it doesn't do anything after that.
Although the original works flawlessly.
Dr Phil Wednesday 9 December 2009 at 23:29
Dr Phil

Which version do you use? (UK/French/Italian/North American/german7Spanish)?
If you just want to have the patch installed, go to pick the right patch and install in the same prefix as Oblivion ("TheElderScrolls4_Oblivion"). It should be pretty straightforward.
Ataronchronon Thursday 10 December 2009 at 0:09

North American.
I tried installing the patch from the website before and it didn't work.
BUT, I just uninstalled and reinstalled Oblivion with an .iso I burned (so I don't have to carry the disk around everywhere) and then tried your script and it worked just fine!
Although now it says it can't find the CD drive when I try to run it.
I know it's made for the CD drive, but I would rather not have to carry the CD around with me.
Last problem!
drakojan Thursday 10 December 2009 at 17:13

I'm not an expert of these "POL", how i can install the patch or the game with this method?

P.s.= I'm just using keyborad and mouse to play oblivion (italian version)
Ataronchronon Thursday 10 December 2009 at 18:04

Open up PlayOnLinux and click Tools > Run non-official script and it'll bring up a new window.
Click browse and find the script you have saved (from Dr. Phil) and it should bring up a POL window that'll take you through it simply in a few minutes!