The forum

I can't install anything

Error "This script does not more exists"

Author Replies
kenny.niutanen Saturday 9 January 2010 at 19:16
kenny.niutanenAnonymous

Hi!

I installed PlayOnLinux and tried to install any program - all installation attempts resulted in the error: "This script does not more exists".

My system info:
Distro: Jolicloud robby
Desktop Gnome
Error: This script does not more exists
Computer Acer Aspire One with 8G SSD - no hard disk

Any advice how to go forward?

BR, Kenny N - not really a linux specialist, but a fan still
-----
I ran POL from the console and got the same result. The console messages were as follows, maybe this helps:

kenny@KennyAAO:/usr/bin$ ./playonlinux
PlayOnLinux v3.7.2

Checking python :                     [ Ok ]
Murrine 0.91.x Development Snapshot, Copyright Andrea Cimitan
Running install menu
Exception in thread Thread-1 (most likely raised during interpreter shutdown):
Traceback (most recent call last):
File "/usr/lib/python2.6/threading.py", line 525, in __bootstrap_inner
File "/usr/share/playonlinux/python/install.py", line 46, in run
<type 'exceptions.AttributeError'>: 'NoneType' object has no attribute 'sleep'
Unhandled exception in thread started by <bound method getDescription.__bootstrap of <getDescription(Thread-1, started -1249383536)>>
Error in sys.excepthook:
TypeError: 'NoneType' object is not callable

Original exception was:
Traceback (most recent call last):
File "/usr/lib/python2.6/threading.py", line 497, in __bootstrap
self.__bootstrap_inner()
File "/usr/lib/python2.6/threading.py", line 572, in __bootstrap_inner
with _active_limbo_lock:

Edited by kenny.niutanen

cdvl Tuesday 8 June 2010 at 0:45
cdvlAnonymous

I get the same error message when I try to install something. I get no "real" error messages though. Running POL from a terminal window gives me no errors.

Please help. It sucks to be stuck.

Kind regards
Quentin PÂRIS Tuesday 8 June 2010 at 12:39
Quentin PÂRIS
Admin

Please update POL first
autoayuda Wednesday 9 June 2010 at 20:01
autoayudaAnonymous

I get the same error in Ubuntu x64. I don't know what else to do, this is annoying.
franko Monday 26 July 2010 at 13:56
frankoAnonymous

I can confirm this is happening on my system, too. Whenever I try to install something it gives me a "This script does not more exists" error window, but no errors in terminal, though. And I can't install anything.

I have Ubuntu Lucid 64 bit and PlayOnLinux 3.7.6.

I am not sure if this started after upgrading POL or Ubuntu... But it used to work fine.
Could it be because of the old config files in my home directory, those in ~/.PlayOnLinux? I did a fresh install of Lucid some months ago, but I have my /home on a different partition, so I left it intact. Then I installed POL back, using the same configs in ~/.PlayOnLinux. Could it be some conflict with the old configurations? If so, what should I do to fix it without losing all my prefixes and installed apps?

I noticed this just today because I didn't need to install any Windows app till now. Now I am forced to do it the classic Wine way.

I like this project, it makes my life with Wine easier. But in this state, POL is just worthless. So I hope this will be fixed soon.

Thank you for your effort in doing all this.

Edited by franko

franko Thursday 29 July 2010 at 14:59
frankoAnonymous

bump
franko Saturday 31 July 2010 at 19:55
frankoAnonymous

bump
franko Sunday 1 August 2010 at 14:57
frankoAnonymous

bump
franko Sunday 1 August 2010 at 15:05
frankoAnonymous

Do I have to learn french to get some support here?
franko Sunday 1 August 2010 at 15:39
frankoAnonymous

I have just tried to remove my .PlayOnLinux directory, and the problem persists...

I see that in the news you say that you solved a compatibility problem with Lucid. But it seems like there still is a compatibility problem with Lucid. Maybe it is architecture related. Have you tested on Lucid 64? But the first poster here doesn't even use Ubuntu, which leaves me with a doubt...
Quentin PÂRIS Monday 2 August 2010 at 1:18
Quentin PÂRIS
Admin

Hi !

Can you send a ticket to the Bug tracker ? It will be easier for us to find and correct the problem.

Thank's
franko Wednesday 11 August 2010 at 22:14
frankoAnonymous

I just did. But I have already said everything here....

http://bugs.playonlinux.com/en/issue-14.html