The forum

Ubuntu 11.04 x86_64 + steam portal = black screen (after splash screen)

Author Replies
vrash Wednesday 15 June 2011 at 4:38

Hello all,

It's my first attempt in using playonlinux, so I would really appreciate any help.

I'm using Ubuntu 11.04 x86_64 and my gpu is an nvidia gts250. I'm trying to run Steam's Portal on playonlinux and the installation went fine... but when I start the game, after the splash screen, all I get is a black screen (that never goes away; I waited a lot).

return, esc, q, ctrl-q, alt-f4, nothing works... I've been closing it with a kill command from the console. Steam's control panel works fine after that. I checked the Gnome System Monitor and it shows:
hl2.exe : Status "Sleeping" : Waiting Channel "futex_wait_queue_me"

I really wanted to play it on linux, so...
... thanks in advance,

vrash Thursday 16 June 2011 at 16:29

Ok, I don't know if it was me or just installing it again, but what I did may be of help to others, so...

I was using PlayOnLinux from the repositories, without unstable enabled, so even though there was this message about 3.8.12 being available, apt-get upgrade didn't bring it to the latest version. So I followed the instructions on this page:

I'll just post here the important commands to install PlayOnLinux 3.8.12:

sudo wget -O /etc/apt/sources.list.d/playonlinux.list
sudo apt-get update
sudo apt-get install playonlinux

Even after that, portal didn't work. So I purged PlayOnLinux and installed it and Steam from scratch. After that I just installed Portal from Steam (never used the PlayOnLinux installer for Portal) and it worked!!!

I'm not sure what I did wrong and what I did right, but it worked for me.... so I thought I might as well share. :D

Edited by vrash

GNU_Raziel Thursday 16 June 2011 at 16:48

All Source Engine based games need a serious cleanup and fixes in PoL, this will be done in this summer's roadmap.

You have to be a little patient because we're very busy with real-life things right now :)