The forum

Trackmania Nations Forever

Author Replies
Jump to the page: 1 - 2 - 3 - 4
zeph Thursday 28 October 2010 at 10:36
zephAnonymous

J ai fait ce que tu dit Tinou mais ensuite je fait quoi? car au lancement aucun changement
Je teste sur le macbook derniere gen a mme pour voir si ok avec 9400m
zeph Thursday 28 October 2010 at 11:04
zephAnonymous

s installe et fonctionne de suite sur macbook
Quentin PÂRIS Thursday 28 October 2010 at 11:38
Quentin PÂRIS
Admin

Ok, donc je prépare une nouvelle version de PlayOnMac. Je vais changer quelques trucs. Je ne sais pas si ça fonctionnera mieux sur la puce GMA, mais je mettrai une option pour pouvoir utiliser le serveur X11 d'Apple qui devrait te permettre au moins de jouer en mode fenêtre
Quentin PÂRIS Thursday 28 October 2010 at 11:44
Quentin PÂRIS
Admin

Est ce que tu peux taper

/usr/X11/bin/glxinfo | grep "renderer"

Dans la console de PlayOnMac et me donner le résultat ?
zeph Thursday 28 October 2010 at 12:55
zephAnonymous

Resultat


PlayOnLinux: ~/Library/PlayOnMac > /usr/X11/bin/glxinfo | grep "renderer"
OpenGL renderer string: Intel GMA 950 OpenGL Engine
PlayOnLinux: ~/Library/PlayOnMac >
zeph Thursday 28 October 2010 at 15:23
zephAnonymous

oups erreur de validation dsolé

Edited by zeph

zeph Thursday 28 October 2010 at 20:33
zephAnonymous

Je telecharge reinstall et test
zeph Thursday 28 October 2010 at 20:53
zephAnonymous

Version 2.2 avec la version beta de xquart marche pas non plus
zeph Thursday 28 October 2010 at 20:59
zephAnonymous

Quand je lance
PlayOnMac Error
An unexpected error has occurred during execution of the main script

PyAssertionError: C++ assertion "(bitmap.GetWidth() >= m_width && bitmap.GetHeight() == m_height) || (m_width == 0 && m_height == 0)" failed at ../src/mac/carbon/imaglist.cpp(80) in Add(): invalid bitmap size in wxImageList: this might work on this platform but definitely won't under Windows.
zeph Thursday 28 October 2010 at 21:26
zephAnonymous

Ok sur macbook
Quentin PÂRIS Thursday 28 October 2010 at 21:31
Quentin PÂRIS
Admin

Pour le problème PyAssertionError, tu peux essayer de renommer le dossier PlayOnMac dans Bibliothèque ?
zeph Friday 29 October 2010 at 8:53
zephAnonymous

Hello
1: je renomme
2: il se reinstalle
3: je reinstalle TMNF, a la fin il fige je quitte donc X11, et la message no bitmap handler for type 50, can't load image frm /USers/XXX/Library/PlayONMAC//ICONES/32/PLAYONLINUX.PNG FILE DOES NOT EXIST
4: je force a quitter playonmac
5: je relance et j ai le message ci dessus.

Voila dispo pour autre test
zeph Friday 29 October 2010 at 8:55
zephAnonymous

J oubliai 10,6,4 et Xquart 2,35 (xorgserver 1.4.2-APPLE53)


Le message disparait si dans le dossier PlayOnMac/Configuration/Installed je supprime le fichier TMNF, et en cliquant sur le raccourci creer sur le bureau TMNF se lance quand meme (mais ne fonctionne pas, mode fenetre blanc puis se ferme)

Edited by zeph

Quentin PÂRIS Friday 29 October 2010 at 11:35
Quentin PÂRIS
Admin

Tu as forcé l'utilisation du Server X Apple ?
Quentin PÂRIS Friday 29 October 2010 at 11:58
Quentin PÂRIS
Admin

2.2.1 en cours d'upload pour corriger le problème de l'icône

Et c'est normal que tu aies un écran blanc en passant par l'icone du bureau. Je viens de réaliser ça ! Pour que ça marche il faut absolument passer par PlayOnMac

Edited by Tinou

zeph Friday 29 October 2010 at 12:17
zephAnonymous

Avec le server X apple ou le Xquartz 2.5.3 ou la Beta 2.6 meme resultat.

Des que possible je telecharge la 2.2.1 de play on mac et je fait une install propre complete pour voir ce qui se passe

En tout cas merci bcp pour ton aide et ta reactivité

Edited by zeph

zeph Friday 29 October 2010 at 15:43
zephAnonymous

Toujours pareil, par contre j ai remarqué la chose suivante, j installe wine 1.3.5 mais play on mac continue a prendre wine 1.2 est ce normal?
Quentin PÂRIS Friday 29 October 2010 at 16:56
Quentin PÂRIS
Admin

Oui il faut que tu ailles dans l'onglet Application pour choisir quelle application va avec quelle version de wine.

Tu as bien lancé le programme à partir du menu de PlayOnMac ?
zeph Friday 29 October 2010 at 21:36
zephAnonymous

c est bien ce que j ai fait
zeph Friday 29 October 2010 at 21:45
zephAnonymous

TESTER sur virtual box pareil rien ne se lance sa doit venir du gma 950 est il possible d'installer un driver gma dans playonmac, je vais tester