The forum

Problem with installing wine

Author Replies
youtomi00 Sunday 27 May 2012 at 8:59
youtomi00Anonymous

I want to run cs4 on my redhat Enterprise 5.5.
Version of wine: i want install wine by playonlinux
Distribution: redhat Enterprise 5.5
Version of playonlinux: 4.1.1
Graphics card: Nvidia, geforce 8400M
Version of Python:My system comes with python2.4, so I upgraded to  python2.6 by source.


First click install -> the Graphics-> Adobe Photoshop CS4 will download wine1.2.3. when the wine  download is complete. the installation of wine was stopped.Loop printing error in the shell as follows:
========================================
 File "/home/vi/Desktop/playonlinux/python/guiv3.py", line 479, in AutoReload
    self.gauge.SetValue(self.downloader.nb_blocs)
  File "/usr/local/lib/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/_controls.py", line 900, in SetValue
    return _controls_.Gauge_SetValue(*args, **kwargs)
wx._core.PyAssertionError: C++ assertion "pos <= m_rangeMax" failed at ../src/gtk/gauge.cpp(94) in SetValue(): invalid value in wxGauge::SetValue()
Traceback (most recent call last):
  File "/home/vi/Desktop/playonlinux/python/guiv3.py", line 479, in AutoReload
    self.gauge.SetValue(self.downloader.nb_blocs)
  File "/usr/local/lib/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/_controls.py", line 900, in SetValue
    return _controls_.Gauge_SetValue(*args, **kwargs)
wx._core.PyAssertionError: C++ assertion "pos <= m_rangeMax" failed at ../src/gtk/gauge.cpp(94) in SetValue(): invalid value in wxGauge::SetValue()
Traceback (most recent call last):
  File "/home/vi/Desktop/playonlinux/python/guiv3.py", line 479, in AutoReload
    self.gauge.SetValue(self.downloader.nb_blocs)

=======================================
Want to get advice, Thank you very much.



Edited by youtomi00

Quentin PÂRIS Sunday 27 May 2012 at 10:20
Quentin PÂRIS
Admin

Install wxpython 2.8 for python 2.6
youtomi00 Sunday 27 May 2012 at 12:08
youtomi00Anonymous

I think i have alredy install the wxPython2.8.

Input the "python" at terminal :

[Termi@localhost ~]$ python
Python 2.6.8 (unknown, May 24 2012, 11:11:34)
[GCC 4.1.2 20080704 (Red Hat 4.1.2-52)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import wx
>>> import sys
>>> print sys.path
['', '/opt/wx/2.8', '/opt/wx/2.8/lib', '/home/Termi', '/usr/local/lib/python26.zip', '/usr/local/lib/python2.6', '/usr/local/lib/python2.6/plat-linux2', '/usr/local/lib/python2.6/lib-tk', '/usr/local/lib/python2.6/lib-old', '/usr/local/lib/python2.6/lib-dynload', '/usr/local/lib/python2.6/site-packages', '/usr/local/lib/python2.6/site-packages/wx-2.8-gtk2-unicode']
>>>


This top error will still occur