The forum

Unable to Launch Diablo 3 (Fedora 17 x86_64)

Author Replies
jyundt Thursday 12 July 2012 at 13:51
jyundtAnonymous

OS: Fedora 17 x86_64
Kernel: 3.4.4-5.fc17.x86_64
POL: playonlinux-4.1.3-fedora0.noarch
Nvidia Driver: 295.59 (kmod-nvidia-295.59-1.fc17.4.x86_64)

I'm able to install (using the POL installer + BNet downloader) and patch Diablo 3 without issue.  However, when I click "Play" I get the dreaded "The application encountered an unexpected error" dialog and I'm unable to launch the game.  


The only errors that caught my eye: 

err:wininet:open_http_connection create_netconn failed: 10036
err:module:import_dll Library QtSvg4.dll (which is needed by L"C:\\\\users\\\\Public\\\\Application Data\\\\Battle.net\\\\Client\\\\Blizzard Launcher.1682\\\\imageformats\\\\qsvg4.dll") not found

However, I should have both 32bit and 64bit qtsvg DLLs installed with these packages: 

[jyundt@phoenix ~]$ rpm -qa | grep -i qt
qt-settings-4.8-16.fc17.noarch
mingw32-qt-qmake-4.8.2-1.fc17.x86_64
mingw32-qt-4.8.2-1.fc17.noarch
mingw64-qt-4.8.2-1.fc17.noarch
mingw64-qt-qmake-4.8.2-1.fc17.x86_64
qt-4.8.2-2.fc17.x86_64
qt3-3.3.8b-41.fc17.x86_64
qt-x11-4.8.2-2.fc17.x86_64
[jyundt@phoenix ~]$ 

Regarding the "open_http_connection" error, I found this POL forum post:: http://www.playonlinux.com/en/topic-8917-Diablo_3_freezing_after_login.html


Unfortunately, neither seem to have a solution or workaround (the wine bugzilla indicates that this could be fixed in wine 1.5.7)

Additionally, I've confirmed that I have both 32bit and 64bit nvidia opengl libraries installed: 

[jyundt@phoenix ~]$ rpm -qa | grep -i nvidia
nvidia-xconfig-1.0-16.fc17.x86_64
xorg-x11-drv-nvidia-devel-295.59-1.fc17.x86_64
nvidia-settings-1.0-18.fc17.x86_64
xorg-x11-drv-nvidia-libs-295.59-1.fc17.x86_64
kmod-nvidia-295.59-1.fc17.4.x86_64
xorg-x11-drv-nvidia-libs-295.59-1.fc17.i686
xorg-x11-drv-nvidia-295.59-1.fc17.x86_64
kmod-nvidia-3.4.4-3.fc17.x86_64-295.59-1.fc17.3.x86_64
xorg-x11-drv-nvidia-devel-295.59-1.fc17.i686
kmod-nvidia-3.4.4-5.fc17.x86_64-295.59-1.fc17.4.x86_64
[jyundt@phoenix ~]$ 

I've been scouring the forums and I haven't found anyone else with this stack that is having the exact same problem.  And, based on this youtube video, running D3 on Fedora 17 x86_64 should be possible: http://www.youtube.com/watch?v=ljbF5rPvuWA  (As per the description in this video, I've also tried launching with the "-opengl" flag.  Unfortunately it also doesn't work.)

What am I missing?  What am I doing wrong?

Thanks,
Jacob
Quentin PÂRIS Thursday 12 July 2012 at 18:12
Quentin PÂRIS
Admin

What about trying to download QtSvg4.dll and installing it in the virtual's drive system32 folder?
jyundt Friday 13 July 2012 at 1:28
jyundtAnonymous

I copied that file (/usr/i686-w64-mingw32/sys-root/mingw/bin/QtSvg4.dl) to ~/.PlayOnLinux/wineprefix/DiabloIII/drive_c/windows/system32

Unfortunately, when I launch D3, I get the same "...application encountered an unexpected..." error message but these new errors in my POL log:

err:module:import_dll Library libgcc_s_sjlj-1.dll (which is needed by L"C:\\\\windows\\\\system32\\\\QtSvg4.dll") not found
err:module:import_dll Library libstdc++-6.dll (which is needed by L"C:\\\\windows\\\\system32\\\\QtSvg4.dll") not found
err:module:import_dll Library zlib1.dll (which is needed by L"C:\\\\windows\\\\system32\\\\QtSvg4.dll") not found
err:module:import_dll Library QtSvg4.dll (which is needed by L"C:\\\\users\\\\Public\\\\Application Data\\\\Battle.net\\\\Client\\\\Blizzard Launcher.1682\\\\imageformats\\\\qsvg4.dll") not found


Based on this site, wine tricks was able to workaround this QtSV4.dll issue: http://notes.benv.junerules.com/diablo-3-beta-and-wine/

(I found that link via this e-mail thread: http://www.winehq.org/pipermail/wine-users/2012-May/106269.html)



jyundt Friday 13 July 2012 at 16:04
jyundtAnonymous

Quick update: I was able to get D3 to play using Fedora's wine (wine-1.5.8-1.fc17.x86_64) + winetricks vcrun2008.  I still get the QtSv4.dll error, however, D3 launches (and runs) fine.

With the exception of the wine version discrepancy (POL = wine 1.5.5-DiabloIII_v3 vs. wine-1.5.8-1), I can't seem to figure out why D3 won't launch with POL.