The forum

PlayOnMac Mountain Lion

Author Replies
medoctron Thursday 26 July 2012 at 19:58


i just installed Mac OS X 10.8 Mountain Lion and downloaded PlayOnMac v4.1.3. My Mac says (when i try to start it) that the app is broken...

Is 10.8 already supported?
Does anyone else have this problem?

Best regards
Quentin PÂRIS Thursday 26 July 2012 at 20:28
Quentin PÂRISAnonymous

PlayOnMac works perfectly on my mountain lion.

Maybe you could try to redownload it
medoctron Thursday 26 July 2012 at 22:17

Just downloaded and tried for the third time... nothing changed.... :( ... Uninstaller works (Gatekeeper just asks me if i trust it and if i say yes it runs as expected)

Edited by medoctron

medoctron Thursday 26 July 2012 at 22:22

Just changed my Gatekeeper settings to allow everything, then i started PlayOnMac - et voila - it starts. I'm now changing back my Gatekeeper settings. Thanks for your help!
mbongio Monday 30 July 2012 at 21:40

I have installed Mountain Lion, updated Xquartz and installed the latest version of PlayonMac.
I want to install Scottrade Elite, and going through the "install non listed program" process.
As soon as the virtual drive creation step starts, a window pops up asking me to install X11. X11 is no longer part of Mountain Lion which is now fully integrated with XQuartz.
So basically i am stuck at this point... nothing gets installed.
Any help would be greatly appreciated.

Thank you.
Quentin PÂRIS Monday 30 July 2012 at 22:42
Quentin PÂRISAnonymous

Try to restart your computer
mbongio Tuesday 31 July 2012 at 1:00

Thank you for your reply.
I followed your suggestion and restarted the computer but i had the same issues.
I then proceeded to fully shutdown, wait 5 minutes, then turn it back on but with the same results.
I am at a loss.
Just for your info, i am trying this on the new MacbookPro with Retina display.
I took a screenshot for you, is there a place where i can post it so you can see it?

Quentin PÂRIS Tuesday 31 July 2012 at 22:10
Quentin PÂRISAnonymous

Type xterm in ?     
mbongio Tuesday 31 July 2012 at 23:48

If i type xterm in i get the following:

Last login: Mon Jul 30 18:54:27 on console
MBPR2012:~ Adm$ xterm
-bash: xterm: command not found
MBPR2012:~ Adm$
mbongio Tuesday 31 July 2012 at 23:52

When i try to install the software through PlayOnMac a window pops up saying:

To open "wineboot" you need to install X11.
Would you like to install X11 now?

If i say CONTINUE, it takes me to this page:

Which tells me that X11 is not included in Mountain Lion and that XQuartz is now the standard (note: I have XQuarz 2.7.2 properly installed on my system).

Hope this helps you in figuring out why this is happening.

Thank you for the support!
Quentin PÂRIS Wednesday 1 August 2012 at 10:22
Quentin PÂRISAnonymous

XQuartz does not seem to be well installed.

Try to run it manually
Blaisorblade Thursday 17 October 2013 at 17:14

I was in a similar situation, but found only this topic without a solution. What solved the problem for me was running this on a prompt:
$ sudo /usr/X11/libexec/

but I don't recommend it, unless you look at that file, understand what it's doing and that it'll solve things for you.

In general, I'd recommend reinstalling XQuartz, I believe that should work as well.

Before that, both the stub X11 and XQuartz were installed.

I assume the situation arose (for me) because I made a fresh install of Mountain Lion, followed by a Time Machine restore of my old system (including XQuartz). Probably the restore avoided overwriting system files.