The forum

Problem with POL_Install_dotnet35

Author Replies
kweepeer Thursday 29 November 2012 at 22:52
kweepeerAnonymous

Can you try this simple script please?

For me it gives this error:




#!/bin/bash

[ "$PLAYONLINUX" = "" ] && exit 0
source "$PLAYONLINUX/lib/sources"

PREFIX="DotNet35Test"

POL_SetupWindow_Init
POL_Wine_SelectPrefix "$PREFIX"
POL_System_SetArch "x86"
POL_Wine_PrefixCreate "1.5.18"

POL_Call POL_Install_dotnet35

POL_SetupWindow_Close

exit

petch Friday 30 November 2012 at 7:47
petch
Developer

Hi,

I need to check, but I suppose it's the same issue:
http://www.playonlinux.com/en/issue-1439.html


Edited by petch

kweepeer Friday 30 November 2012 at 10:30
kweepeerAnonymous

Hi petch, thanks for your reply.

I had a look at the code of POL_Install_dotnet35. It does seem to call the 30sp1 function, early in the script:

# Install dotnet30sp1 if needed
if [ ! -e "$WINEPREFIX/drive_c/windows/system32/XpsFilt.dll" ]; then
POL_Call POL_Install_dotnet30sp1
fi

So it could be the same issue. I will attach a log to confirm this.

I wonder why it complains about 2.0SP1 though. From looking at the code of both POL_Install_dotnet30sp1 and POL_Install_dotnet35, I don't see any mention of installation of dotnet20sp1 (or sp2).