El Foro

Starcraft 2 Crashes On Startup

Autor Respuestas
ExpDel Sunday 17 March 2013 at 3:32

I installed Wings of Liberty via playonlinux from a setup file downloaded from the website. It worked fine up until I tried to connect to battlenet, then it crashed. I'm running Mint 13 Maya with the Cinnamon LDE on a Toshiba P745. I'm pretty certain my specs are alright, but, to be sure, I changed all the settings for SC2 to low to no avail. Based on my previous experiences with proprietary software, I restarted my computer, hoping that this would somehow magically fix the problem. Instead, the game now crashes whenever the start screen finishes loading. The error message gives no information on the cause of the problem.

I've tried googling, but the people who had this error were running Windows and when I searched for Linux specifically, I found fixes for runtime errors. I contacted Blizzard Technical Support and I got this message:

"We appreciate you contacting us.  My name is XXXXXXX, and I'll be doing my best to help you out in the most epic way today.

        We apologize for the inconvenience experienced with our legacy games.  The programs that allows players to play the games on Linux OSs is not something that we can monitor properly.  Because of this we are unable to determine the possibility of using exploitive software or macros.  With out this ability accounts may be flagged for using said programs.  While we have looked into a possible workaround for this we have been unable to find a way to easily differentiate between non-exploitive and exploitive programs.  With all that said, if a player chooses to us Linux it is at their own risk as the account may be flagged.

        We offer no technical support for Linux as the games were not created to run on Linux.  We again apologize for the inconvenience."


I'm not very tech savvy, so I'm pretty much at the end of my rope. I know that lots of people play SC2 on Linux, so I was hoping someone encountered this problem before or could help me resolve it.

Editado por: ExpDel

ExpDel Sunday 17 March 2013 at 3:56

After some more searching on google, I found that running this command fixes the bug

sudo sysctl kernel.yama.ptrace_scope=0


However, now that I've actually started playing the game, I noticed another error. During actual gameplay, the graphics aren't showing up nicely. Everything is black except the buildings and units, which are red. I can't even see the mineral fields.

Some pictures illustrating the issue:

Editado por: ExpDel

petch Sunday 17 March 2013 at 4:33

Mmmhh those nice Intel video drivers probably...
ExpDel Tuesday 19 March 2013 at 7:32

I installed it and it's still not working.

Editado por: ExpDel

petch Tuesday 19 March 2013 at 8:46

ExpDel Tuesday 19 March 2013 at 8:58

I installed this as suggested and it didn't work.

I tried playing with just the black terrain and monocolored units and it seems to crash a lot. Maybe my computer isn't up to spec. It has an i3 with integrated graphics and 4GB RAM.
petch Tuesday 19 March 2013 at 9:05

You need the 32bit version of this package, since it's a 32bit program.
I'm not sure where it can be found, though

Editado por: petch

Ronin DUSETTE Tuesday 19 March 2013 at 17:19

I know in ubuntu, you can run:

sudo apt-get install multiarch-support ia32-libs ia32-libs-multiarch


That should look at all of your libraries that you have, and install the 32 bit versions of every library on your system. Im not sure how this would work for Mint, though.

The integrated gfx will obviously not perform up to par such as a PCI-E card, but this is not really lack of power that is causing the issue. It almost for sure looks like bad driver/missing library.

Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts