El Foro

PlayOnLinux 4.2 Configure Arguments Don't Save

Autor Respuestas
unimatrixoverload Tuesday 26 March 2013 at 1:52
unimatrixoverloadAnonymous

Wanted to run it buy others but,
Just wanted to report what appears to be bug: 

- Name of the distribution (and its version) 
Ubuntu 13.04 (beta)

- Name of the software and its version (ex: Wine 0.9.37) 
PlayOnLinux 4.2
PlayOnLinux using the wizard "testing" install of Guild Wars 2

- Your desktop (KDE, Gnome, Xfce, Fluxbox...) 
Unity

- Errors from the software. And if possible, tell when and/or where it happens. 
When I click Configure.
Then select "Guild Wars 2" program icon on the left
When entering anything into ARGUMENTS it doesn't save.

- Your computer configuration. 
Dell Studio XPS 1645
Advanced Micro Devices [AMD] nee ATI RV730 XT [Mobility Radeon HD 4670]


Ronin DUSETTE Tuesday 26 March 2013 at 3:16
Ronin DUSETTE
Admin

Well, first, you are using a beta version of Ubuntu, and a testing install of guild wars, so that may have something to do with it. Hence the beta status. lol. It may not be that, but its something to consider. 

If you run playonlinux from the terminal, does it output any errors when you are saving/typing in the arguments in the configure screen?

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
unimatrixoverload Saturday 6 April 2013 at 16:30
unimatrixoverloadAnonymous

Sorry for the delay...

- Name of the distribution (and its version)
Ubuntu 12.10
Linux workstation 3.5.0-26-lowlatency #28-Ubuntu SMP PREEMPT Tue Mar 19 10:32:21 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

- Name of the software and its version (ex: Wine 0.9.37)
PlayOnLinux 4.2.1
PlayOnLinux using the wizard "testing" install of Guild Wars 2

- Your desktop (KDE, Gnome, Xfce, Fluxbox...)
Unity

- Your computer configuration.
ASUS motherboard, Intel Core 2 Quad 2.5Ghz, 8GB RAM, AMD Radeon HD 4870


He he, after trying on a more stable version like you said I had the same results. I have "rm -R -f" my /home/user/.Playonlinx folder and started up PlayOnLinux from scratch. It recreated the folder with no problems.

Installed using testing GuildWars2. So everything is fresh.

Disabled all plugins.

Went to Configure->64GuildWars2->Guild Wars 2. Then General->Arguments. Then delete everything from the box, it is ok, and saves that nothing is in the box.

When I try to add "fruit cake", clicking the Wine tab in the same window it still saves. I can close the window and it still saves. So I am wrong in my post before about "anything". It likes "fruit cake". :)

But, when I enter the following, "-email user@domain.com -password ‘password’ -autologin -nopatchui" without quotes and close the window etc. everything I had entered in the Arguments box is removed.

Odd that "fruit cake" works but "-email user@domain.com -password ‘password’ -autologin -nopatchui" does not.

I can provide more information if needed.

As requested below is all I get even when changing text in Arguments box:

$ playonlinux
[main] Message: PlayOnLinux (4.2.1) is starting
[clean_tmp] Message: Cleaning temp directory
[Check_OpenGL] Message: 32bits direct rendering is enabled
[Check_OpenGL] Message: 64bits direct rendering is enabled
[POL_System_CheckFS] Message: Checking filesystem for /home/jonathan/.PlayOnLinux/
[main] Message: Filesystem is compatible
[install_plugins] Message: Checking plugin: Capture...
[install_plugins] Message: Checking plugin: ScreenCap...
[install_plugins] Message: Checking plugin: PlayOnLinux Vault...
[maj_check] Message: List is up to date
petch Saturday 6 April 2013 at 17:03
petch
Developer


-email user@domain.com -password ‘password’ -autologin -nopatchui

Do you really mean those unicode quotes around password, and not the ASCII single quotes

-email user@domain.com -password 'password' -autologin -nopatchui

I can indeed reproduce the problem with unicode characters.
Beside, unless your password contains shell separators (spaces, tabs,...), those quotes are unnecessary.

Editado por: petch

Ronin DUSETTE Saturday 6 April 2013 at 17:07
Ronin DUSETTE
Admin

When I try to add "fruit cake", clicking the Wine tab in the same window it still saves. I can close the window and it still saves. So I am wrong in my post before about "anything". It likes "fruit cake".

Citar


hahaha

You can always add those arguments in the symlink, but that kind of kills flow and ease of use, doesnt it? :)

So, pretty much take all of that information, and create a bug report. It should be saving those arguments, if I am not mistaken, and it may be a bug that has been introduced recently.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
unimatrixoverload Sunday 7 April 2013 at 7:22
unimatrixoverloadAnonymous

First off, thank you for such an amazing software package. Good call patch! Yes DJYostaBYD.

For everyone's reference Guild Wars 2 command line parameters can be found here:

http://wiki.guildwars2.com/wiki/Command_line_arguments

Being a programmer myself I instinctively put the quotes in. lol