El Foro

4.2 broke Hard Reset

ran perfectly now its really buggy

Autor Respuestas
booman Wednesday 27 March 2013 at 14:55
booman

I installed Hard Reset last week so I could test it in PlayOnLinux.
I selected Wine 1.5.25 and installed the game.
Not only did the install go perfectly, I didn't have to install any extra packages.
Launched Hard Reset and everything worked perfectly and looked beautiful.
I can even show you screenshots of every step because I am making step-by-step guides.

This week I noticed there was an updated version of PlayOnLinux:  4.2
So I let Mint update PlayOnLinux for me.
Of course I wanted to make sure my games would still run... Hard Reset errors each time I launch it.  When I try Wine 1.4.1 the game launches but with major graphical artifacts... as if directx was totally corrupted...

So of course, I try installing directx from Hard Reset program file location
dxwebsetup.exe

I get an error from that.
Then I try installing the directx packages through PlayOnLinux and still no success.

So then I figured the upgrade must have conflicted with the PlayOnLinux 4.1.9 version.
So I remove PlayOnLinux and try re-installing.
No luck
I try removing it with "Software Installer" & "apt-get" and even delete the /usr/share/playonlinux folder.

Then re-install with "Software Installer"
I restore my game and shortcuts but no luck.

Next I am going to revert back to 4.1.9 and install Hard Reset from scratch.
If it works, then something is going on with PlayOnLinux 4.2

Very strange because my other installed games work fine.  Just not Hard Reset!??
This sucks because it was the cleanest, easiest install ever!

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
booman Thursday 28 March 2013 at 5:24
booman

I figured it out. Sometimes Linux doesn't make any sense, specially with Windows programs.
Anyways, when I originally installed Hard Reset I tested it in a Virtual Desktop.
After it runs successfully I will then try it fullscreen. For some reason, after updating PlayOnLinux, the fullscreen would error each time. Even after all the steps mentioned above.

So I tried installing and running it in Virtual Desktop again.... it worked!
Then I ran it in fullscreen and it runs GREAT!
Such a strange bug....

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Thursday 28 March 2013 at 16:50
Ronin DUSETTE
Admin

Wow. That is odd. This one for sure could be filed as a bug report. Go ahead and do that, so that if there is something that one of the devs can fix, they will (if its not already being fixed for the all new POL5)

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
booman Thursday 28 March 2013 at 17:10
booman

Well, I tried running it in Winetricks too and received the same problem.
I bet if I had just tried Hard Reset in fullscreen mode with PlayOnLinux 4.1.9 initially, I would have had this problem too.
So I don't think its PlayOnLinux at all.
When I looked it up on WineHQ's several people claimed that it ran perfectly like in my experience.
I guess worse case is you play it in Windowed mode in a virtual desktop and match your monitor resolution to appear like fullscreen.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Thursday 28 March 2013 at 17:22
Ronin DUSETTE
Admin

Yeah. Some of the AppDB posts are very ambiguous.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
booman Thursday 28 March 2013 at 17:40
booman

True, but I always go there first before installing a game. It usually helps me to know what to expect and what packages do and do not work.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Thursday 28 March 2013 at 17:50
Ronin DUSETTE
Admin

Same here. Its a very good reference to see what others have done and what may or may not be required.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
booman Friday 5 April 2013 at 14:57
booman

I had a strange problem last night when playing Hard Reset...
Its running great and I'm killing lots of robots when I started to noticed textures being completely black. A I continue they get worse... to the point where one of the robots is totally black... no textures at all.
I'll show you...
How do I post a screenshot?

The fix? I just quit the game and re-launched.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Friday 5 April 2013 at 19:50
Ronin DUSETTE
Admin

To post a screenshot, you will have to host it somewhere like google drive or something, then post the link with the reply box's image feature.

or use url and /url in brackets. POLs forums and most of the site accepts BB code.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
booman Friday 5 April 2013 at 20:26
booman

Ok, thats what I thought... I'll try it later
Thanks

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
booman Monday 8 April 2013 at 3:54
booman


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
booman Monday 8 April 2013 at 3:54
booman


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
booman Monday 8 April 2013 at 3:55
booman

That small robot has no textures at all.
In the first screenshot, all of the black surfaces are supposed to have textures

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
booman Thursday 11 April 2013 at 22:49
booman

I finished off a HUGE boss and the next level was running a little bit slow. Or should I say choppy.
So I logged into Openbox, launched PlayOnLinux, launched Hard Reset and it ran perfectly!
gained a few frames per second with Openbox

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained