El Foro

MS Office 2010 - how to install SP1?

Errors on running the SP installation file

Autor Respuestas
Jump to the page: 1 - 2
nmeyne Tuesday 2 April 2013 at 16:41
nmeyneAnonymous

Hi there,

First:  Playonlinux / Wine:  Great software...   amazed that it's working so well so far, and with such a smooth install.  Thanks!

Maybe I'm asking too much to install SP1 on top of this, but I attempted it and encountered problems.  Got a 'wine has crashed' message.

I chose the upgrade existing applications option.  Perhaps this was incorrect?  I chose to upgrade Word (32bit) using the 32 bit Office 2010 SP1 download exe from Microsoft.  The update ran OK at first, but then got the error above, and after this the version of Word remained unchanged.

Is it possible or advisable to upgrade to SP1?

I have only installed Word, Powerpoint, Excel and OneNote.  I don't want Outlook.

Config:
- Wine 
1.5.16; Playonlinux 4.2; Ubuntu 12.10
- Desktop Gnome Unity
- Intel E8400 duo on Asus P5E3 Pro MBwith Asus ATI EAH4890 graphics

Many thanks,

Nick
Ronin DUSETTE Tuesday 2 April 2013 at 17:47
Ronin DUSETTE
Admin

Well, I would try a fresh install. with SP1, instead of upgrading an existing one.

Run playonlinux from the terminal, and try to install SP1 again, and then post whatever the terminal spits out here. That should give us some more insight as to what is causing the issue.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
nmeyne Tuesday 2 April 2013 at 18:16
nmeyneAnonymous

Thanks... I'm not sure how to run playonunix from the terminal... so I started an install at the desktop instead:

install a non-listed program
manual installation
... but then it prompts for a new virtual drive - surely I don't want to do that? I assumed the SP1.exe is an update, not a whole new version of Office, and will need to update the software in the existing virtual drives.

Or shall i go ahead anyway?

Nick
Ronin DUSETTE Tuesday 2 April 2013 at 18:19
Ronin DUSETTE
Admin

Yes. It is just an update. But if you qualify for an update, you should be able to download a new version of it with SP1 already integrated into the installer.

Well, to run play on linux from the terminal, open a terminal and type playonlinux :)

Look through your application menu (most of the time in Accessories) and look for terminal or xterm or something like that. It will bring up a command prompt box.

If you are using Ubuntu, you can press CTRL+ALT+T and it will bring up a terminal.

When you get the terminal open, type playonlinux and press enter. PlayOnLinux will start, but any errors it has will show up in that terminal window, which you can copy and paste to this thread. This is a basic troubleshooting step, and its something that will be requested in the future if you have more problems, so find the terminal, and run playonlinux from there. :)

In your case, unless they have changed something, you can press CTRL+ALT+T to bring up the terminal. 

Editado por: RoninDusette


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
nmeyne Tuesday 2 April 2013 at 19:17
nmeyneAnonymous

Yes, I already tried to run it in terminal on ubuntu:

nick@neptune:~$ playonunix
playonunix: command not found

I've tried various combos of lover case and caps but no luck. Is there something that needs to be added to a path somewhere?

Nick
nmeyne Tuesday 2 April 2013 at 19:23
nmeyneAnonymous

oops playonlinux LOL!
Ronin DUSETTE Tuesday 2 April 2013 at 19:24
Ronin DUSETTE
Admin

hahahaha. yeah. the command is simply

playonlinux

All lowercase, no spaces. :)

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
nmeyne Tuesday 2 April 2013 at 19:34
nmeyneAnonymous

OK that's better!!! Now I get this in Terminal:

nick@neptune:~$ playonlinux
[main] Message: PlayOnLinux (4.2) is starting
[clean_tmp] Message: Cleaning temp directory
[Check_OpenGL] Message: 32bits direct rendering is enabled
[Check_OpenGL] Message: 64bits direct rendering is enabled
[POL_System_CheckFS] Message: Checking filesystem for /home/nick/.PlayOnLinux/
[main] Message: Filesystem is compatible
[install_plugins] Message: Checking plug-in: Capture...
[install_plugins] Message: Checking plug-in: ScreenCap...
[install_plugins] Message: Checking plug-in: PlayOnLinux Vault...
[maj_check] Message: List is up to date
Exception in thread Thread-2:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 552, in __bootstrap_inner
self.run()
File "mainwindow.py", line 107, in run
self.real_check()
File "mainwindow.py", line 88, in real_check
if(playonlinux.VersionLower(os.environ["VERSION"],self.WebVersion)):
File "/usr/share/playonlinux/python/lib/playonlinux.py", line 280, in VersionLower
if(version1[2] < version2[2]):
IndexError: list index out of range


The gui window runs OK showing excel, onenote, powerpoint and word as installed.

I checked the filesize of the SP1 download file (not windows update) for 2010 and it's about 380mb, while the original installation file was 1.1gb. So if I uninstalled the originals, it seems unlikely that the SP1 download would have all it needs.

Nick
Ronin DUSETTE Tuesday 2 April 2013 at 19:44
Ronin DUSETTE
Admin

I know that. Thats what I was saying. You need to download the FULL INSTALL that INCLUDES SP1. Of course the SP1 upgrade will not have everything that it needs. Thats why I stated earlier to get the FULL download WITH sp1 included IN THE download. :)

I mean, do you really need MS office? You do know that there are very compatible, open source and free linux alternatives, such as LibreOffice and OpenOffice, correct?

I switched to OpenOffice about 3 years ago, and never switched back to MS Office ever again. Never had any compatibility issues. I can read and save in MS formats using these native office programs.

As for the terminal output, there isnt more than that? Also, you need to actually install something to generate errors. Just running playonlinux doesnt tell us anything. You need to try and install SP1 and THEN post the terminal output. All you did was start POL, and then nothing else, which tells us nothing at all.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Tuesday 2 April 2013 at 19:46
Ronin DUSETTE
Admin

http://www.openoffice.org/

http://www.libreoffice.org/

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
nmeyne Tuesday 2 April 2013 at 20:37
nmeyneAnonymous

I'm with you there! I don't think there is any way to get a full install of a version of office 2010 that has SP1 built in without paying a fortune to MS AGAIN - Something i am sick of. The online retailer I got the original download from won't allow any more downloads from the purchased link, and then they would be the original file anyway.

I dislike MS Office, and Office 2010 even more. I prefer the simpler, better integrated LibreOffice and OpenOffice open solutions. Unfortnately other members of my family seem to insist on it for 100% compatibility with work copies, so I'm only doing this to support them. If there are any features in SP1 that they REALLY want, then I can boot into XP from another drive.

So I guess it's not worth attempting this, as the complex 2010 install upgrade won't be able to find the virtual drives that it needs to. I'll live with it as it is. I don't want to screw up what I've got working already.

Thanks for your help.

Nick
Ronin DUSETTE Tuesday 2 April 2013 at 20:56
Ronin DUSETTE
Admin

hahaha. No problem. I dont blame you. It does get expensive after a while.

Although, like I said, I have worked in IT for a loooonnnnggg time, and the last 3 years or so, I have not submitted any documents, nor read any documents sent to me (excel, powerpoint, word, etc) using any Microsoft product. OpenOffice actually, for me a quite a few others, did give 100% compatibility.

It can find the virtual drive. You just need to tell it where it is. For instance:

Open PlayOnLinux
Click Configure
Select the virtual drive you want (your office 2010 virtual drive)
Click the Miscellaneous tab on your right
Click "Run a .exe file in this virtual drive"

When the window pops up, it will ask where that SP1 installer file is. Select it, and click Next. This will tell it to install into that virtual drive.

Have you done it that way? Thats the only way it will know to install in that particular virtual drive. I think this may be why its not working. :)

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
nmeyne Tuesday 2 April 2013 at 21:31
nmeyneAnonymous

Thanks for the tip. Yes, that seems to be the correct way to run it, so that it takes the virtual drive for the whole of Office 2010 rather than an individual program. Sadly I still get an error that caused the install to fail and then crashes wine - a pity as it seemed to be working at first....

nick@neptune:~$ playonlinux
[main] Message: PlayOnLinux (4.2) is starting
[clean_tmp] Message: Cleaning temp directory
[Check_OpenGL] Message: 32bits direct rendering is enabled
[Check_OpenGL] Message: 64bits direct rendering is enabled
[POL_System_CheckFS] Message: Checking filesystem for /home/nick/.PlayOnLinux/
[main] Message: Filesystem is compatible
[install_plugins] Message: Checking plug-in: Capture...
[install_plugins] Message: Checking plug-in: ScreenCap...
[install_plugins] Message: Checking plug-in: PlayOnLinux Vault...
[maj_check] Message: List is up to date
Exception in thread Thread-2:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 552, in __bootstrap_inner
self.run()
File "mainwindow.py", line 107, in run
self.real_check()
File "mainwindow.py", line 88, in real_check
if(playonlinux.VersionLower(os.environ["VERSION"],self.WebVersion)):
File "/usr/share/playonlinux/python/lib/playonlinux.py", line 280, in VersionLower
if(version1[2] < version2[2]):
IndexError: list index out of range

Traceback (most recent call last):
File "/usr/share/playonlinux/python/configure.py", line 599, in setwinedebug
playonlinux.SetSettings('WINEDEBUG', new_winedebug, self.s_prefix)
File "/usr/share/playonlinux/python/lib/playonlinux.py", line 89, in SetSettings
fichier = open(cfile,"r").readlines()
IOError: [Errno 2] No such file or directory: u'/home/nick/.PlayOnLinux//wineprefix/default/playonlinux.cfg'
Traceback (most recent call last):
File "/usr/share/playonlinux/python/configure.py", line 599, in setwinedebug
playonlinux.SetSettings('WINEDEBUG', new_winedebug, self.s_prefix)
File "/usr/share/playonlinux/python/lib/playonlinux.py", line 89, in SetSettings
fichier = open(cfile,"r").readlines()
IOError: [Errno 2] No such file or directory: u'/home/nick/.PlayOnLinux//wineprefix/default/playonlinux.cfg'
Traceback (most recent call last):
File "/usr/share/playonlinux/python/configure.py", line 599, in setwinedebug
playonlinux.SetSettings('WINEDEBUG', new_winedebug, self.s_prefix)
File "/usr/share/playonlinux/python/lib/playonlinux.py", line 89, in SetSettings
fichier = open(cfile,"r").readlines()
IOError: [Errno 2] No such file or directory: u'/home/nick/.PlayOnLinux//wineprefix/default/playonlinux.cfg'
[POL_System_CheckFS] Message: Checking filesystem for /home/nick/Downloads/officesuite2010sp1-kb2460049-x86-fullfile-en-us.exe
[POL_Wine] Message: Running wine-1.5.16 /home/nick/Downloads/officesuite2010sp1-kb2460049-x86-fullfile-en-us.exe (Working directory : /home/nick/.PlayOnLinux)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
fixme:heap:HeapSetInformation 0x110000 1 (nil) 0
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:storage:create_storagefile Storage share mode not implemented.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:domdoc_setProperty Setting default xmlns not supported - skipping.
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:dom_pi_get_attributes created dummy map for <?xml ?>
fixme:urlmon:SecManagerImpl_ProcessUrlAction Unsupported arguments
fixme:msxml:dom_pi_get_attributes created dummy map for <?xml ?>
err:mscoree:LoadLibraryShim error reading registry key for installroot
err:mscoree:LoadLibraryShim error reading registry key for installroot
err:mscoree:LoadLibraryShim error reading registry key for installroot
err:mscoree:LoadLibraryShim error reading registry key for installroot
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
fixme:advapi:SetNamedSecurityInfoW L"C:\\\\users\\\\Public\\\\Microsoft\\\\OfficeSoftwareProtectionPlatform\\\\" 1 -2147483644 (nil) (nil) 0x2a12d0c (nil)
fixme:advapi:SetNamedSecurityInfoW L"C:\\\\users\\\\Public\\\\Microsoft\\\\OfficeSoftwareProtectionPlatform\\\\tokens.dat" 1 -2147483644 (nil) (nil) 0x2a12d0c (nil)
fixme:advapi:SetNamedSecurityInfoW L"C:\\\\users\\\\Public\\\\Microsoft\\\\OfficeSoftwareProtectionPlatform\\\\Cache\\\\" 1 -2147483644 (nil) (nil) 0x2a12d14 (nil)
fixme:advapi:SetNamedSecurityInfoW L"C:\\\\users\\\\Public\\\\Microsoft\\\\OfficeSoftwareProtectionPlatform\\\\Cache\\\\cache.dat" 1 -2147483644 (nil) (nil) 0x2a12d14 (nil)
fixme:reg:RegSetKeySecurity :(0x11c8,4,0x2a12c70): stub
fixme:reg:RegSetKeySecurity :(0x11cc,4,0x2a12c70): stub
fixme:reg:RegSetKeySecurity :(0x11d0,4,0x2a12c70): stub
fixme:reg:RegSetKeySecurity :(0x11d0,4,0x2a12c70): stub
fixme:reg:RegSetKeySecurity :(0x11d0,4,0x2a12c70): stub
fixme:reg:RegSetKeySecurity :(0x11c8,4,0x2a12c70): stub
fixme:reg:RegSetKeySecurity :(0x11cc,4,0x2a12c70): stub
fixme:reg:RegSetKeySecurity :(0x11d0,4,0x2a12c70): stub
fixme:reg:RegSetKeySecurity :(0x11d0,4,0x2a12c70): stub
fixme:reg:RegSetKeySecurity :(0x11c8,4,0x2a12c70): stub
fixme:reg:RegSetKeySecurity :(0x11cc,4,0x2a12c70): stub
fixme:reg:RegSetKeySecurity :(0x11c8,4,0x2a12c70): stub
fixme:reg:RegSetKeySecurity :(0x11cc,4,0x2a12c70): stub
fixme:reg:RegSetKeySecurity :(0x11c8,4,0x2a12c70): stub
fixme:reg:RegSetKeySecurity :(0x11cc,4,0x2a12c70): stub
fixme:reg:RegSetKeySecurity :(0x11d0,4,0x2a12c70): stub
fixme:reg:RegSetKeySecurity :(0x11d0,4,0x29762f0): stub
fixme:reg:RegSetKeySecurity :(0x11d4,4,0x29762f0): stub
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:heap:HeapSetInformation 0x110000 0 0x33fde8 4
fixme:advapi:RegisterTraceGuidsW (0x1043d32, 0x14277e8, {bf3736e4-23ae-47c3-b472-a03c2c3550fe}, 1, 0x33fdd0, (null), (null), 0x14277f0,): stub
fixme:advapi:RegisterTraceGuidsW (0x1043d32, 0x1427808, {ff1671c8-2eea-42b3-8143-a8da2634c369}, 1, 0x33fdd0, (null), (null), 0x1427810,): stub
fixme:ole:CoInitializeSecurity ((nil),-1,(nil),(nil),0,3,(nil),0,(nil)) - stub!
fixme:advapi:RegisterEventSourceW ((null),L"Office Software Protection Platform Service"): stub
fixme:advapi:ReportEventW (0xcafe4242,0x0004,0x0000,0x40000384,(nil),0x0000,0x00000000,(nil),(nil)): stub
fixme:advapi:DeregisterEventSource (0xcafe4242) stub
fixme:advapi:RegisterTraceGuidsW (0x6f01b6a5, 0x6f15e4a8, {bf3736e4-23ae-47c3-b472-a03c2c3550fe}, 1, 0xa4e320, (null), (null), 0x6f15e4b0,): stub
fixme:advapi:RegisterTraceGuidsW (0x6f01b6a5, 0x6f15e4c8, {ff1671c8-2eea-42b3-8143-a8da2634c369}, 1, 0xa4e320, (null), (null), 0x6f15e4d0,): stub
fixme:advapi:RegisterEventSourceW ((null),L"Office Software Protection Platform Service"): stub
fixme:advapi:ReportEventW (0xcafe4242,0x0004,0x0000,0x4000042a,(nil),0x0001,0x00000000,0x15f478,(nil)): stub
fixme:advapi:DeregisterEventSource (0xcafe4242) stub
fixme:advapi:RegisterEventSourceW ((null),L"Office Software Protection Platform Service"): stub
fixme:advapi:ReportEventW (0xcafe4242,0x0000,0x0000,0x40000386,(nil),0x0001,0x00000000,0x155110,(nil)): stub
fixme:advapi:DeregisterEventSource (0xcafe4242) stub
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
fixme:ole:NdrCorrelationInitialize (0x9d2da54, 0x9d2d654, 1024, 0x0): stub
fixme:rpc:NdrStubCall2 new correlation description not implemented
fixme:ole:NdrCorrelationFree (0x9d2da54): stub
fixme:ole:NdrCorrelationInitialize (0x9d2dc1c, 0x9d2d81c, 1024, 0x0): stub
fixme:rpc:NdrStubCall2 new correlation description not implemented
fixme:ntdll:NtFsControlFile FSCTL_PIPE_IMPERSONATE: impersonating self
err:rpc:I_RpcReceive we got fault packet with status 0x80070241
fixme:ole:NdrCorrelationInitialize (0x9d2d408, 0x9d2d008, 1024, 0x0): stub
fixme:rpc:NdrStubCall2 new correlation description not implemented
fixme:ole:NdrCorrelationFree (0x9d2d408): stub
err:msi:ITERATE_Actions Execution halted, action L"CAInstallSppPlugin.x86" returned 1603
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:msi:load_ttf_name_id Unable to open font file L"C:\\\\windows\\\\Fonts\\\\ARIALUNI.TTF"
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
fixme:advapi:SetNamedSecurityInfoW L"ose" 2 4 (nil) (nil) 0x52c3cc (nil)
fixme:advapi:SetNamedSecurityInfoW L"osppsvc" 2 4 (nil) (nil) 0x52c3cc (nil)
fixme:advapi:SetNamedSecurityInfoW L"osppsvc" 2 4 (nil) (nil) 0x1fc9c5c (nil)
fixme:advapi:SetNamedSecurityInfoW L"C:\\\\users\\\\Public\\\\Microsoft\\\\OfficeSoftwareProtectionPlatform\\\\" 1 4 (nil) (nil) 0x23966ac (nil)
[POL_Wine] Error: Wine seems to have crashed

If your program is running, just ignore this message.
[POL_SetupWindow_Init] Message: Creating new window for pid 22128
fixme:advapi:RegisterEventSourceW ((null),L"Office Software Protection Platform Service"): stub
fixme:advapi:ReportEventW (0xcafe4242,0x0000,0x0000,0x40000387,(nil),0x0000,0x00000000,0x84e8c4,(nil)): stub
fixme:advapi:DeregisterEventSource (0xcafe4242) stub
Ronin DUSETTE Tuesday 2 April 2013 at 21:35
Ronin DUSETTE
Admin

Hmmm. It keeps giving RPC errors, but I dont think that would cause an error.

Open Word and see if the update went through. Sometimes it will say that POL crashed, even though the install actually worked to some degree.

Also, you are getting a LOT of PlayOnLinux errors. Not from Office, but from the actual program. You may need to backup your virtual drives, delete the ~/.PlayOnLinux folder, and reinstall playonlinux. It shouldnt be giving these errors:


Exception in thread Thread-2:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 552, in __bootstrap_inner
self.run()
File "mainwindow.py", line 107, in run
self.real_check()
File "mainwindow.py", line 88, in real_check
if(playonlinux.VersionLower(os.environ["VERSION"],self.WebVersion)):
File "/usr/share/playonlinux/python/lib/playonlinux.py", line 280, in VersionLower
if(version1[2] < version2[2]):
IndexError: list index out of range

Traceback (most recent call last):
File "/usr/share/playonlinux/python/configure.py", line 599, in setwinedebug
playonlinux.SetSettings('WINEDEBUG', new_winedebug, self.s_prefix)
File "/usr/share/playonlinux/python/lib/playonlinux.py", line 89, in SetSettings
fichier = open(cfile,"r").readlines()
IOError: [Errno 2] No such file or directory: u'/home/nick/.PlayOnLinux//wineprefix/default/playonlinux.cfg'
Traceback (most recent call last):
File "/usr/share/playonlinux/python/configure.py", line 599, in setwinedebug
playonlinux.SetSettings('WINEDEBUG', new_winedebug, self.s_prefix)
File "/usr/share/playonlinux/python/lib/playonlinux.py", line 89, in SetSettings
fichier = open(cfile,"r").readlines()
IOError: [Errno 2] No such file or directory: u'/home/nick/.PlayOnLinux//wineprefix/default/playonlinux.cfg'
Traceback (most recent call last):
File "/usr/share/playonlinux/python/configure.py", line 599, in setwinedebug
playonlinux.SetSettings('WINEDEBUG', new_winedebug, self.s_prefix)
File "/usr/share/playonlinux/python/lib/playonlinux.py", line 89, in SetSettings
fichier = open(cfile,"r").readlines()
IOError: [Errno 2] No such file or directory: u'/home/nick/.PlayOnLinux//wineprefix/default/playonlinux.cfg'

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
nmeyne Tuesday 2 April 2013 at 21:35
nmeyneAnonymous

...And of course the smileys aren't mine or from playonlinx... funny escape sequences I guess!
(I like the Security 'sadface' especially)

Nick
Ronin DUSETTE Tuesday 2 April 2013 at 21:37
Ronin DUSETTE
Admin

hahahaha. I know, right? I saw that and was cracking up. Dont worry. That happens all of the time.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
nmeyne Tuesday 2 April 2013 at 21:46
nmeyneAnonymous

Amazingly it seems to have worked on all 4 programs! Clearly showing SP1! Thanks!! Do you think I really need to worry about the errors? I'm tempted to leave it and see if it is stable first, then reinstall. Or perhaps better, clean boot them install playonlinux + office + sp1 in another user on the same machine and look out for the errors again.

Nick
Ronin DUSETTE Tuesday 2 April 2013 at 21:54
Ronin DUSETTE
Admin

Excellent. Thats what I was hoping. Glad it worked. :)

Yes, I do think that you need to worry about the errors from POL. If SP1 installed, then good. What you can do is the following:

Delete your ~/.PlayOnLinux folder (backup any DATA, not programs, that you need saved)

Remove and reinstall PlayOnLinux with the newest version from the site

after reinstalling, start playonlinux from the terminal again, and see if you are still getting those PlayOnLinux errors that I posted last.

After that, reinstall Office, and reinstall that patch, just as we just did, and you should be good to go.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
nmeyne Tuesday 2 April 2013 at 22:03
nmeyneAnonymous

OK. I'll uninstall and reinstall and report back. Thanks!
Ronin DUSETTE Tuesday 2 April 2013 at 22:18
Ronin DUSETTE
Admin

No prob.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts