El Foro

Weird terminal print

upon running wineboot or League of Legends

Autor Respuestas
Firalus Friday 5 April 2013 at 17:30
FiralusAnonymous

After the last patch of League, I had to install it from scratch.

Since then, I would occasionally get this:
[code]fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x33fd30 1 C) semi-stub
fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
fixme:toolhelp:Heap32ListFirst : stubfixme:advapi:GetCurrentHwProfileW (0x33e1b0)
fixme:wininet:query_global_option INTERNET_OPTION_PER_CONNECTION_OPTION stub
fixme:wininet:query_global_option Unhandled dwOption 4
fixme:wininet:query_global_option Unhandled dwOption 5
fixme:wininet:query_global_option Unhandled dwOption 6
fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x135e3d0 1 C) semi-stub
fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x135e200 1 C) semi-stub
fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x135e4c4 1 C) semi-stub
fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x135e490 1 C) semi-stub
fixme:winsock:WSALookupServiceBeginW (0x1f5e9cc 0x00000ff1 0x1f5e9c4) Stub![/code]
when trying to launch LoL or wineboot. When this happens, I seem to be completely unable to actually get into the game - the launcher gets stuck.

I usually have to relaunch POL or run multiple wineboots until the error does not show up.

Running POL 4.1.9 under Sabayon (4.2.1 unavailable yet).

PS: setting this as solved was a purely accidental misclick.

Editado por: Firalus

booman Friday 5 April 2013 at 18:10
booman

What version of Wine are you using?
Which libraries/packages did you install?

So you tried to install patches for League of Legends and it broke your game, but did it originally run without the patches?

I've seen this happen with games before, something in a patch breaks the game in Wine.

How did you install the patch? Configuration - Run an exe?
or is there a script for LoL patch?

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Firalus Saturday 6 April 2013 at 14:22
FiralusAnonymous

The default patched wine-1.5.24.
I did not install any packages other than those included in the install script.

I tried to patch the game as usual, through the launcher application and upon the completion of patching, when I tried to launch the client, an error showed up. I tried to run the repair tool, but during the reparation process another error showed up and the launcher application did not start anymore. Prior to this patch the game ran properly. After this happened, the simplest way to make it work was a reinstall, which caused this fixmes to appear.

Sometimes these keep appearing until a system reboot, which makes it pretty annoying.
booman Monday 8 April 2013 at 2:08
booman

Yeah, I see what you mean. I havn't quite figured out why some patches work and some don't.
I installed Battlefield 2 and both of its patches... runs GREAT!
But I installed Dark Messiah and its two patches.... then it would crash before even launching.
I have tried the Repair button tool and don't exactly know what it repairs.

Do you remember which packages/libraries the script installs?

I would say for now... stick with the vanilla version without patches (if you can live with it) and keep following WineHQ until someone has a fix.
Or, keep re-installing and trying different versions of Wine until one works.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Firalus Monday 8 April 2013 at 19:02
FiralusAnonymous

The game requires to patch itself to the live version as it is a multiplayer only game.

The script installs dx9, wininet and vcrun2005 if I remember correctly, but I might be missing out on something.
booman Monday 8 April 2013 at 19:22
booman

Ah, I see... didn't realize there was no singleplayer.
Which means you can't join any updated servers without the patch.

By the way there are a lot of Gold and Bronze tests on WineHQ

Packages/Libraries:
vcrun2005
d3dx9
wininet
corefonts

I've been browsing over all the posts on WineHQ and there are a LOT of problems with League of Legends. I havn't seen any posts yet about your patching problem.

I would still suggest trial-n-error with different Wine versions and make sure those packages/libraries listed above.
Kinda sucks but this is how I troubleshoot my PC games.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained