El Foro

Unable to Find 32/64Bit OpenGL Libraries

Need help

Autor Respuestas
yakuzah Sunday 7 April 2013 at 11:36
yakuzahAnonymous

Hi, just spun up the latest version of OpenSuSe 12.3 and I am experiencing issues getting Play on Linux working correctly.

When I launch Play I get an error stating 32Bit and 64Bit OpenGL Libraries cannot be found and thjs will affect performance.

I have the latest Nvidia 310 Drivers loaded. I have also loaded Mesa and OpenGL Libararies, but there must be something missing, which I just cannot find and install to get PlayOnLinux working correctly.

Can anyone help please?

thanks in advance.
petch Sunday 7 April 2013 at 11:45
petch
Developer

Hi,
Start playonlinux from a terminal, do you get any error message?

To tell a bit more about the test used: a small C program requests an OpenGL context, then requests direct rendering access, test passes if both are granted.
Then this program has been compiled in 32 and 64bits to test both situations.

Thinking of it, what's the output of
$ glxinfo | grep rendering
and
glxinfo | grep renderer
yakuzah Sunday 7 April 2013 at 11:50
yakuzahAnonymous

Here is the output from the command you asked me to execute.

glxinfo | grep rendering
NVIDIA: could not open the device file /dev/nvidiactl (Permission denied).
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)


thanks
petch Sunday 7 April 2013 at 12:16
petch
Developer

SuSe bug: https://bugzilla.novell.com/show_bug.cgi?id=808319

Add yourself to the "video" group, and log off

Editado por: petch

yakuzah Sunday 7 April 2013 at 13:02
yakuzahAnonymous

Hi you put me on the right track, many thanks.

I ended up editing /etc/modprobe.d/50-nvidia.conf and simply set Vreg_DeviceFileMode to 0666. (Default is 0660)

Many thanks..