El Foro

Problems with League of Legends installation

Autor Respuestas
Witschi262 Sunday 7 April 2013 at 12:41
Witschi262Anonymous

Hi,
im new in Ubuntu 12.04 and with much tutorials i set PoL up and tried to install LoL. I ticked the "Download Program" and installed the software for wine which was missing.

Then the LoL installer starts. I choose my language and then the path WHERE to install it. I just pressed "next" so the installation should start. But I just see the installation window for like 2 seconds and it turn back to the install-directory-choosing-part
.
So, i cant install LoL. Does ANYone maybe had the same problem and knows how to fix or is here anybody who can help me out of this?

I dont really know how to get more information about my WINE Version etc. because I'm really new in Ubuntu. If you need just give me some information how to get this.

Thank you!
geodrummer55 Sunday 7 April 2013 at 20:48
geodrummer55Anonymous

Hi,

I'm having this problem too, I'm using Arch x86_64, and nVidia drivers with Bumblebee/Optimus. Are you using 32 bit (x86) or 64 bit (x86_64)?
EDIT: Just to add, this is using the League of Legends testing script which is using Wine 1.5.12-LeagueOfLegendsShop, and to clarify, this happens in the downloading stage of the installer, where its a downloaded the little 3.3MB file which it uses (PMB I believe) to download and install the actual game client.

I can post pastebins of log files/PoL console output if that would help somebody debug this, if its not a known issue.

Thanks

George

Editado por: geodrummer55

Witschi262 Sunday 7 April 2013 at 21:15
Witschi262Anonymous

HI,

Im really happy to see that im not alone with my problem. I have the 32 bit version installed here.

You are absolutly right that LoL is using PMB.

geodrummer55 Sunday 7 April 2013 at 21:24
geodrummer55Anonymous

Me too, I've been trying to get this working all day! Okay, so doesn't seem to be an architecture specific thing.

I've been speaking to somebody on IRC, he reckons its PMB not being actually installed, and hence there are issues with downloading, trying to confirm this now.

geodrummer55 Sunday 7 April 2013 at 21:40
geodrummer55Anonymous

Do you have a Windows install of League of Legends accessible to you? A workaround for now, since it seems to be PMB failing, is to grab the installer files that PMB downloads (to desktop by default IIRC) and manually installing that with Play on Linux.
petch Sunday 7 April 2013 at 22:34
petch
Developer

Hi,

http://www.playonlinux.com/en/issue-2064.html

I'm working on the issue.
Witschi262 Sunday 7 April 2013 at 22:39
Witschi262Anonymous

Awesome to hear! Is there a finish date?
petch Sunday 7 April 2013 at 22:48
petch
Developer

At least one successful installation with the modified script.;)

If you're in a hurry, here's a workaround:
- download the tarball that was used by the old script: http://files.playonlinux.com/LeagueOfLegends.tar
- untar it in some directory
- start the installation script, select "local" installation
- select the untarred setup.exe
That's it!
Witschi262 Sunday 7 April 2013 at 22:51
Witschi262Anonymous

Thank you! I am testing it tomorrow because now its too late and in Germany the holyday'S are over tomorrow.

Sleep well and thank you very much.
petch Monday 8 April 2013 at 23:59
petch
Developer

Now the scripts seemed to work again (no trace of Pando Media Booster anymore through, seems they switched to some kind of integrated P2P client), until the download is finished and you're left with broken file sizes and the installation crashes:

-rw-r--r-- 1 petch petch 78244649046664452 avril 8 22:58 0x0407.ini
-rw-r--r-- 1 petch petch 78244649046661084 avril 8 22:58 0x0409.ini
-rw-r--r-- 1 petch petch 78244649046663732 avril 8 22:58 0x040a.ini
-rw-r--r-- 1 petch petch 78244649046664862 avril 8 22:58 0x040c.ini
-rw-r--r-- 1 petch petch 78244649046663780 avril 8 22:58 0x0410.ini
-rw-r--r-- 1 petch petch 78244649047836651 avril 8 22:58 data1.cab
-rw-r--r-- 1 petch petch 78244649048595411 avril 8 22:58 data1.hdr
-rw-r--r-- 1 petch petch 78244651616903285 avril 8 23:39 data2.cab
-rw-r--r-- 1 petch petch 78244649047226192 avril 8 23:39 ISSetup.dll
-rw-r--r-- 1 petch petch 78244649046639290 avril 8 23:39 layout.bin
-rwxr-xr-x 1 petch petch 78244649047451472 avril 8 23:39 setup.exe
-rw-r--r-- 1 petch petch 78244649046641098 avril 8 23:39 setup.ini
-rw-r--r-- 1 petch petch 78244649046895949 avril 8 23:39 setup.inx
-rw-r--r-- 1 petch petch 78244649048308523 avril 8 23:39 setup.isn


Switching back to tarball method for the moment...

Editado por: petch