El Foro

Can't get Guild War 2 to work

Autor Respuestas
Jump to the page: 1 - 2
fernetekhd Friday 12 April 2013 at 1:22
fernetekhdAnonymous

So I'm still having trouble getting Guild Wars 2 on PoL. Although I was initially having the black-background-launcher, I now have a problem of the background technically not being black but still resulting in a graphic bug (ex. if I tabbed back into to Wine right now a fair chunk of this webpage would surround the launcher), and the launcher itself seems non-functional and doesn't seem to even try to ping the update server.

I'm running Ubuntu 32bit 12.10, the latest install of PoL, and I've tried versions 1.5.15 and 1.5.27 (I've tried others in the past, but none seem to work).

I'm running off of Nvidia drivers for my GTX 560 Ti (although using the pre-installed drivers had the same problem). I have a quad-core Intel i5-2500K CPU @ 3.30GHz. I can look for more hardware info as needed.

I appreciate any help in this endeavor!
Ronin DUSETTE Friday 12 April 2013 at 1:31
Ronin DUSETTE
Admin

If you are running Ubuntu, then you are most likely running Unity with Desktop Effects. IME, desktop effects make things go bad when trying to run games.

I suggest logging out, and at the login screen, you will see the Ubuntu logo next to the field where you enter your name. Click that, and it will show a drop-down menu, and you can choose "No Effects" or "2D" which should turn off the desktop effects for that session. Then try it again and see if you have the same issues.

Also, you should always run the proprietary Nvidia drivers when trying to play games. The open-source drivers do not work well with graphically intense applications.

Editado por: RoninDusette


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
fernetekhd Friday 12 April 2013 at 1:46
fernetekhdAnonymous

The only Ubuntu logo I saw was below the username/password UI, and it seemed to just be part of the back ground.

With a quick Google search I found this program called CompizConfig Settings Manager which should allow me to do what you're saying, albeit only by manually shutting down each feature individually.

So which features do I need to shut off for a bit?

Also, based off this video http://www.youtube.com/watch?v=QZQHO7IbvOA (albeit a different Ubuntu version and a different computer) I shouldn't have to do that. I've seen a bunch of other videos of people running it fine as well.
Ronin DUSETTE Friday 12 April 2013 at 1:55
Ronin DUSETTE
Admin

No. Its not the features that you need to shut off. Its all of compiz.

Every computer, card, driver, etc etc etc is different.

You gotta look closer at the login screen. Its there. 100%.

Look at this picture:

[img]http://farm9.staticflickr.com/8463/8076773594_e1a8db839d_b.jpg[/img]

See that little foot to the right of where its says NoobsLab? click that. A list will show up with "3D" and "2D". Choose 2D.

Im not really concerned with what others can and cant do on YouTube. :)

We are doing this for troubleshooting purposes. 

FYI, I turn off desktop effects in KDE before I run any game. It always works better. 

Editado por: RoninDusette


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
fernetekhd Friday 12 April 2013 at 1:58
fernetekhdAnonymous

That's what I'm saying; that icon doesn't exist on my end.

Do I maybe have to turn it on or something?
Ronin DUSETTE Friday 12 April 2013 at 1:59
Ronin DUSETTE
Admin

My computer rig specs:
CPU - AMD Phenom II x4 965 3.4GHz
GPU - AMD RadeonHD 6870 1GB GDDR5 (Catalyst 12.8)
RAM - 8GB DDR3 Corsair 1333MHz
OS - Ubuntu 12.04 64Bit/Windows 7 64Bit (Dual Boot)

Citar


That video authors specs are wildly different from yours.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Friday 12 April 2013 at 2:00
Ronin DUSETTE
Admin

Nope. You dont. Its there. At least its been there on every one I have seen. Post a screenshot or picture of your login screen.

Also, does your screen look anything like that at all? Did you change from LightDM to GDM or something?

Editado por: RoninDusette


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
fernetekhd Friday 12 April 2013 at 2:06
fernetekhdAnonymous

It looks exactly like that with the sole exception of that one little icon. And no, as far as I know at least, I haven't done anything since this is a completely fresh install of about 2 hours (I did shut off lightdm to install Nvidia, but I restarted it when I finished and when I attempted to do so in the terminal just to be safe it showed up fine as well).

Gimme a min, I think I'll need to go through a roundabout way to take a screenshot of it.
Ronin DUSETTE Friday 12 April 2013 at 2:08
Ronin DUSETTE
Admin

for sure. That will help. You have to have SOME sort of icon there, whether or not its a foot. There is always a way to change your session settings at login.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
fernetekhd Friday 12 April 2013 at 2:22
fernetekhdAnonymous

Alright, I won't be able to get a screenshot, no matter what method I use Gnome throws an error message along the lines of that it can't find the display (or something).

I'll look around for some settings/Google or something to figure out why it's not there.
Ronin DUSETTE Friday 12 April 2013 at 2:24
Ronin DUSETTE
Admin

Its there. It flat out has to be. Look:

Its on every picture that I see.

http://bit.ly/YrzWPK

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Friday 12 April 2013 at 2:26
Ronin DUSETTE
Admin

If anything, google search "how to run unity in 2D"

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Friday 12 April 2013 at 2:27
Ronin DUSETTE
Admin

Actually, scratch that.

Apparently a recent update removed that feature. hahaha. I cant believe that. Its ridiculous. :(

[url]http://www.omgubuntu.co.uk/2012/08/unity-2d-removed-from-ubuntu-12-10[/url]

There has to be an option to turn off desktop effects somewhere in the system settings. Im not using Unity, so I really couldnt say.

I also dont run anything but LTS versions of Ubuntu. This is a very good reason why. Im running 12.04 on every machine that I have installed, and that option is there. Sorry about that. Its really weak that they took that out. Hence the reason that I will never switch to Unity (as soon as it came out, I went back to KDE).

Editado por: RoninDusette


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
fernetekhd Friday 12 April 2013 at 2:36
fernetekhdAnonymous

Ok, so, in my attempt to figure out the problem I temporarily set my account as a standard rather than an admin (thinking that this might've made the setting appear before I saw your post).

Aaaaaand now I can't do anything since I'm not an admin and I can't make myself an admin without being admin.

Perfect.

So, TL;DR, I'll just spend the next few hours boot n' nuking (A. F***ING. GAIN.) and installing Ubuntu 12.04 whilst I quietly urge myself not to attack my computer with a large axe.

I'll let ya know how things go once I get that installed.
Ronin DUSETTE Friday 12 April 2013 at 2:46
Ronin DUSETTE
Admin

hahahaa. Yeah. You dont ever want to do that, although, you can log in as:

username: root
password: your 'sudo' password

and then you can change it back. I wouldnt reformat right now. try that first.

(I really hope you read this before reinstalling your whole system. This is why you wait for responses and read them before doing anything rash. Im still confused as to why you would change your user group anyway, but hey...)

Editado por: RoninDusette


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Friday 12 April 2013 at 2:47
Ronin DUSETTE
Admin

PS. My statements were not long, but rather informative. As a matter of fact, that link that I sent you is not longer than a couple of paragraphs...... You want to make sure always read every post. Trust me; it helps.

Editado por: RoninDusette


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
fernetekhd Friday 12 April 2013 at 3:04
fernetekhdAnonymous

I don't recall complaining about your posts being uninformative. edit: or too long.

And I changed my user group because I'm an idiot, that's why.

I haven't reinstalled it yet, but I still will have to; there is no way (at least as far as I can understand) for you to login, because the moment you remove the admin account there is no way to reaccess because of the circular logic.

Besides, it seems like most of my problems would be resolved with a switch to 12.04 anyways.

Editado por: fernetekhd

Ronin DUSETTE Friday 12 April 2013 at 3:10
Ronin DUSETTE
Admin

Um, yeah. You should be able to restart your computer, and at the login screen, login with root and your password, and you should be able to set your user account back. The root account shouldnt be locked out at all.


So, TL;DR

Citar

"Too long; didnt read"


PS. My statements were not long, but rather informative. As a matter of fact, that link that I sent you is not longer than a couple of paragraphs......

Citar



I haven't reinstalled it yet, but I still will have to; there is no way (at least as far as I can understand) for you to login, because the moment you remove the admin account there is no way to reaccess because of the circular logic.

Citar


I just told you how in the post above, and in this one. :)


Besides, it seems like most of my problems would be resolved with a switch to 12.04 anyways.

Citar


Maybe. I never run those "beta version", as I like to call them, because they are always experimenting with them through updates.


And I changed my user group because I'm an idiot, that's why.

Citar


No, just inexperienced with Linux. Everyone starts somewhere.

Editado por: RoninDusette


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
fernetekhd Friday 12 April 2013 at 3:16
fernetekhdAnonymous

There's only three options for login:

A) Rob (me)

B) Guest

C) Remote login

I can't even type in the username. Maybe another feature removed between .04 and .10?

Also, I meant the TL;DR just as "What I'm basically saying is..." not in the way you took it xD
Ronin DUSETTE Friday 12 April 2013 at 3:21
Ronin DUSETTE
Admin

Ah. I have just never heard that term used in that way.

That sucks that you cannot type in a different name. You could try to do it from the command line, although, this can be daunting if you have never done it before.

Looks like Ubuntu strikes again with experimentation. It seems as though you are right; you are locked out (unless you drop to a terminal and do it that way).

The reinstallation choice is up to you. At this point, I would do it, but I would try backup your stuff first using the LiveCD to access your drive and copy your Home folders to something. :)

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts