El Foro

Morrowind - Not Running

Autor Respuestas
Jump to the page: 1 - 2
henshu Sunday 14 April 2013 at 0:02
henshuAnonymous

I cannot get Morrowind to run. I've checked/updated my graphics drivers, and I disabled GLSL.  It brings up the launcher, I click the play button, then I get a box that says this: 

      "internal errors - invalid parameters received" 

From the debugger:

fixme:d3d_caps:select_card_intel_mesa Card selection not handled for Mesa Intel driver
fixme:d3d_caps:init_driver_info Unhandled vendor 8086.
wine: Unhandled page fault on read access to 0x00000059 at address 0x7e841cf6 (thread 001b), starting debugger...
Can't attach process 001a: error 5



Editado por: henshu

booman Sunday 14 April 2013 at 5:33
booman

I'm pretty sure "intel_mesa Card" means Linux is still using the Generic drivers bundled with Linux instead of the Intel drivers.
d3d is probably DirectX, which requires the correct drivers to run Morrowind.

Which distro are you using?
I would check with the distro first to install the proper drivers...
Or you can check here: Intel Drivers
I have not installed Linux drivers for Intel GPU's yet, but Nvidia works perfectly with Ubuntu and Mint.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
henshu Sunday 14 April 2013 at 6:24
henshuAnonymous

I did use the Intel Linux Graphics Installer.
I'm using Ubuntu, and this is the output I get from lspci | grep -i vga:
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
So it looks like I do have an actual Intel driver =/
I do appreciate your suggestions, though.
booman Monday 15 April 2013 at 4:56
booman

Cool, thanks for checking... Did you research the posts on WineHQ?
There are some interesting posts about Mesa libraries and Intel drivers here: Morrowind
Let me know if you get it working... I plan to install and test Morrowind vanilla and the expansion packs

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
henshu Monday 15 April 2013 at 5:47
henshuAnonymous

I've looked around a bit but I find them difficult to navigate.
With Wine and no PlayOnLinux I can actually manage to get the game started but it crashes as soon as I try to leave the ship. I thought I might have better luck this way, but not so far.

Just found this note on WineHQ:
In winecfg set vertex shader mode to hardware. If you've got Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (Video card), make sure you deselect "Vertex shader support" in winecfg, otherwise you won't be able to exit the ship in the beginning of the game.

I can't find a way to disable vertex shaders in winecfg, though. I'm away from home and didn't bring the disk with me, so I will try to figure this out later tonight and get back to you.

Editado por: henshu

booman Monday 15 April 2013 at 19:15
booman

I found this guide: PCLInuxOS Magazine

He's using an old version of Wine 0.9.23, but I'll check and see if these Vertex shader options are in mine.

Click on the graphics tab. Enable desktop double buffering, allow the window manager to control the windows, and emulate a virtual desktop at 800x600 resolution. Uncheck pixel shader support and scroll down to vertex shader support. Choose "NONE," then click apply. (Note, if you cannot see the "apply" button, you are probably at 800x600 resolution on your 'true' desktop. Just hold down the alt-key and click on the configuration window to move it up a bit, so you can click it)

Citar

Editado por: booman


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
booman Monday 15 April 2013 at 19:34
booman

Here is a huge list of commands for launching Wine via Terminal.
http://wiki.winehq.org/ChristianDannieStorgaard

example:
wine --vertex-shader

I don't usually run any Wine commands via Terminal, but its worth a try.
I recommend doing from the Wine configuration display tab.

Editado por: booman


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
henshu Monday 15 April 2013 at 19:56
henshuAnonymous

I just found that myself this morning, but they aren't commands for wine, they're for wine-launcher. See the examples at the bottom.

I've tried to install it, but it doesn't seem to be working -_-
booman Monday 15 April 2013 at 19:58
booman

That figures, I don't use that either.
Were you able to find the Vertex options for the display tab in Wine Configuration?

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
henshu Monday 15 April 2013 at 21:15
henshuAnonymous

I did find a way to disable pixel/vertex shading through PlayOnLinux, but I'm still getting the same errors.
I'm going to try upgrading to the beta of wine1.5 and see if it does any better.

clarification edit: I can't seem to find a way to disable vertex shading in my current version of wine(1.4) that is separate from playonlinux, I'm sure there's a way to do it manually if I could just find the darn config file. The option just doesn't appear. 

Editado por: henshu

booman Monday 15 April 2013 at 21:49
booman

Try clicking "config" in PlayOnLinux
Click Wine tab
Click "Wine Configration"

I found that Wine 1.5.25 is pretty stable for a lot of games
I always start with 1.4.1 then move up as long as my game still runs

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Monday 15 April 2013 at 21:52
Ronin DUSETTE
Admin

Its not in wine configuration. I believe you would have to edit the registry to do that.

I do the same thing when testing. Usually Ill start with 1.4.1, and if it doesnt work, Ill jump up to the newest Wine version, and then start working my way back. Doesnt really matter the order. WineHQs appDB helps a lot to determine what could be needed.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
booman Monday 15 April 2013 at 21:52
booman

I kept reading about a Display Tab in Wine configuration or Wine-Launcher.
What am I missing here?

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Monday 15 April 2013 at 21:54
Ronin DUSETTE
Admin

The display tab is in the wine-configuration (winecfg), but it doesnt have that option in there. There you will find the options for virtual desktop, window dec disable, etc..

in POL, the display tab in Configure has a bunch of display options (that are just reg entries), but that options is not in there.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
booman Monday 15 April 2013 at 22:00
booman

Found it!
Look at Wine Configuration under Direct3D


Hopefully this isn't in old Wine versions only

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Monday 15 April 2013 at 22:05
Ronin DUSETTE
Admin

Yes. Its an old system that is ONLY in old version.

Its not even in 1.4.1. Its a depericated function now, and I believe it has to be done through the registry. This was done away with a while back. Which version are you running? They removed it for a reason (i remember reading about it like, HELLLAAA long ago when it first disappeared. I dont remember why).

here is wine 1.4.1. It was gone long before this version was out.


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
booman Monday 15 April 2013 at 22:07
booman

That sucks, I'm guessing Wine removed it because its not a problem anymore.
But then again, Morrowind is an old game!

I found that screenshot online...
So either he has to use a really old version of Wine or start trying newer versions one at a time?

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Monday 15 April 2013 at 22:09
Ronin DUSETTE
Admin

Well, the thing is, wine should automatically take care of that for you. You shouldnt need to set it. Like, in Windows, you dont need to set it. Options like this were workarounds, until it could be integrated in to the main code. You can still use this option on different versions of Wine, but you will have to edit the registry.

http://wiki.winehq.org/UsefulRegistryKeys

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
henshu Monday 15 April 2013 at 22:21
henshuAnonymous

You guys win. I feel ridiculously stupid for not switching the wine versions in POL before. I set it to 1.4 and it started up fine. Music is working properly, and I made it off the boat and through character creation.
Thank you!

Editado por: henshu

Ronin DUSETTE Monday 15 April 2013 at 22:28
Ronin DUSETTE
Admin

You arent stupid. Lol. This whole wine/linux thing can be quite confusing. Just keep working with it. :)

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts