El Foro

Sound problems with Skyrim

Autor Respuestas
nematoad Tuesday 27 August 2013 at 18:07
nematoadAnonymous

Well, after successfully sorting out my DVD problems with the help of GNU_Raziel and booman I have hit another snag.

Audio was working well and then I installed a new Nvidia 2 Gb video card.  Audio now works well with Xine, Firefox and Clementine but is very distorted when playing EVE and Skyrim under POL.  There is sound, of a sort, but it is very crackly and speech does not come over at all, just ambient sounds.

My setup is:

AMD Athlon(tm) 7750 Dual-Core Processor
GF119 [GeForce GT 610]
SB Audigy
and a strange entry that was not there before and may be the cause of the problem:
GF119 HDMI Audio Controller
I'm using the emu10k1 [alsa] driver for the Audigy and for some reason snd_hda_intel [alsa] for this new
4Gb memory

running Trinity on PCLinuxOS i686

Nothing special, I know, but it's the best I can afford for now.
The setup is identical to that before I started to have this audio problem.

Any help would be appreciated.

Thank you.

nematoad Tuesday 27 August 2013 at 18:12
nematoadAnonymous

... and for some reason snd_hda_intel [alsa] for this new device.

Sorry I was called away and posted before finishing the text.

Nematoad
booman Wednesday 28 August 2013 at 0:38
booman

I am using on-board audio chip for Linux games. The only problems I have had is no sound because my default audio device was set for my HDMI on the video card instead of the integrated audio.

The only other problem is similar to yours where I played the Native Linux Psychonauts and it has very staticy/crackly sound. It would eventually fix itsself, but was very annoying.

I've done some research on it, but most people just say its Linux and driver compatibility.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
nematoad Wednesday 28 August 2013 at 8:21
nematoadAnonymous

OK, thanks for that.

Now, how do I disable this HDMI device?

I don't want it or need it.

After all, I installed a VIDEO card not an audio one. If it is interfereing with my POL stuff then out it goes. Unwanted, unneeded and definely unloved. I chose Linux because I am in charge. I hate it when someone thinks that they know better than I do what my system needs.


Sorry, but that is one thing that really gets my back up.

If anyone has an answer to getting rid of this problem thay will have my sincere gratitiude
booman Wednesday 28 August 2013 at 20:35
booman

in Mint I would go to system settings and audio devices.
Then I would select my integrated (onboard) audio device.
But like I said, this only fixed my problem with NO audio.

Sounds like you are having a totally different problem, but try setting your default audio device to integrated might be a good start.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
nematoad Friday 6 September 2013 at 12:37
nematoadAnonymous

I have solved the problem.

It turns out that it was Pulseaudio causing all the trouble and although I did disable it in previous attempts to sort things out it made no difference.

I gave it another try this morning and the audio is now clear.
booman Friday 6 September 2013 at 17:52
booman

Wow, really? So you had to disable Pulseaudio again and it "magically" worked?
Pretty cool.
Can you mark this thread as solved?
Thanks

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained