El Foro

S4 League problem.

Autor Respuestas
philldevil Monday 21 October 2013 at 5:24
philldevilAnonymous

Hello, there. Newby here.
Earlyer I installed S4 League playonlinux and the 1.7.4 Wine version, on the same vistual machine I have installed League of Legends, but before the patcher could start, it would crash.
I did a little research about it and I found out that there's an anti-hacking tool on the game that prevents me from playing it on a virtual machine, unless it's executed in windows 98 mode. I tried that, but it would still crash before it started patching.

I'm using Ubuntu 13.04
AMD Athlon(tm) 64 X2 Dual Core Processor 5000+ × 2 (32-bit)
2GB of RAM
and a Radeon HD GPU, i'm not sure wich one, though.

I've got the bug report, but I'm not sure if this is gonna help or not. Should I post it?

Anyway, thanks in advance.
booman Tuesday 22 October 2013 at 20:33
booman

I recommend installing it in a NEW virtual drive.
Then install the Packages (Components/Libraries) for S3-League.
Unfortunately its hard to figure out what Packages its going to need.
Here is a list of standard libraries I install when testing a game:

  • corefonts
  • d3dx9
  • d3dx10
  • dxfullsetup
  • registered fonts
  • tahoma
  • vcrun2005
  • vcrun2008
  • vcrun2010
  • xinput
If it still crashes or has problems, please post the Debug output and we can try to figure out what else it requires.
If its a browser-based game, then you might have to use IE8, which requires setting Wine Windows Version to Windows XP and you will need Service Pack 3.


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained