El Foro

Under A Killing Moon (GOG) sound problems

crackling, squeeking, midi

Autor Respuestas
daliz Wednesday 23 October 2013 at 6:43
dalizAnonymous

Hi,


I have installed UAKM Gog.com-version with POL. Otherwise the game seems to run perfectly, but the sounds are not okay. I get horrible crackling and weird "squeek" sounds, and it happens all the time.


I have the game also installed in Win7 and the sounds are not perfect in there either (much, much better though), but there I can use the usual dosbox.conf to tweak the sound settings. What are the options to tweak in POL, where does it read the settings?


I'm running Xubuntu 12.04 64bit, XFCE 4, C2D E8400, AMD HD6870, 4GB RAM, Creative Audigy ES sound card.


Wine version in POL is "1.4dos_support", I've tried the newer ones but the game doesn't even start with those. Is this version the only one that's supposed to work with DOS games? If not then I probably should take a look why it doesn't start with the newer ones.


Also I would appreciate a hint of where does the program read the midi device settings, as I get no midi music in-game? I haven't looked into this much yet, I'm trying to get the crackling to go away first.


Edit: Oh, forgot. I've also tried the usual cure to sound problems: kill pulseaudio. But it didn't affect this problem.


Thanks a lot


Edit2: Okay it seems that Pulseaudio didn't want to die even though I set "autospawn = no" in /etc/pulse/client.conf. I had to create a client.conf in home/xxx/.pulse/ to stop it from restarting.


Now that I actually got Pulseaudio to stay dead, I get no sound whatsoever in this game. ALSA is functioning, I get sound with other programs normally by just telling them to use ALSA. Also Silent Storm in POL works fine, no configuring needed. So any idea how can I set the UAKM game/dosbox to use ALSA directly? Now it just says "can't open /dev/dsp" and goes to nosound mode.

Editado por: daliz

booman Thursday 24 October 2013 at 23:41
booman

I actually recommend installing the Linux DosBox and then installing your game with PlayOnLinux, but use your Linux DosBox to run the executable instead of the GOG one.

I have a guide here on Linux DosBox: DosBox Guide

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
petch Friday 25 October 2013 at 0:03
petch
Developer

PlayOnLinux install scripts use Linux DosBox.
booman Friday 25 October 2013 at 0:09
booman

No way! I had no idea... that is great news.
So what if the script uses Linux DosBox but the GOG.com game has Windows DosBox bundled with it?
which one takes over the other and how?

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
petch Friday 25 October 2013 at 0:53
petch
Developer

Hi,

I have the game also installed in Win7 and the sounds are not perfect in there either (much, much better though), but there I can use the usual dosbox.conf to tweak the sound settings. What are the options to tweak in POL, where does it read the settings?

Quote from daliz

~/.PlayOnLinux/wineprefix/<prefixname>/playonlinux_dos.cfg
Hopefully some tab will be added someday to tweak this one, but time is lacking...


Wine version in POL is "1.4dos_support", I've tried the newer ones but the game doesn't even start with those. Is this version the only one that's supposed to work with DOS games? If not then I probably should take a look why it doesn't start with the newer ones.

Quote from daliz

The install script for this game uses 1.4-dos_support_0.6, which is the latest one to date.


Also I would appreciate a hint of where does the program read the midi device settings, as I get no midi music in-game? I haven't looked into this much yet, I'm trying to get the crackling to go away first.

Quote from daliz

Mmmh don't know how it got thru, but indeed ingame music is missing.

As few cards have hardware MIDI support those days, and software MIDI is seldom present, so I changed default setting to use SoundBlaster MIDI (emulated directly inside DOSBox).

If you still want to try external MIDI support, add midi_mididevice and midi_midiconfig to above playonlinux_dos.cfg.

For example, this should work with the default settings of Timidity:

[code=console]
midi_mididevice=alsa
midi_midiconfig=128:0
[/code]



Any idea how can I set the UAKM game/dosbox to use ALSA directly? Now it just says "can't open /dev/dsp" and goes to nosound mode.

Quote from daliz

Could be some 32bit library missing? Debug logs could help.

Cheers,
Pierre.
petch Friday 25 October 2013 at 0:55
petch
Developer

@booman: DOSBox support is somewhat buried in a corner of the forums:
http://www.playonlinux.com/en/topic-8747-Ultima_123_GOGcom_Edition.html

I'm collecting such URLs for the day we start a FAQ :/
booman Friday 25 October 2013 at 5:51
booman

@booman: DOSBox support is somewhat buried in a corner of the forums:
http://www.playonlinux.com/en/topic-8747-Ultima_123_GOGcom_Edition.html

I'm collecting such URLs for the day we start a FAQ :/

Quote from petch

I decided to make it easy on myself and just install the GOG game then cut-n-paste the game files to my Linux DosBox game folder.
Then I launch with Linux DosBox.

I know it seems easier to use PlayOnLinux to launch the Windows DosBox that came with GOG, but it seems like conflicts can happen when Wine is runing a DOS emulator meant for Windows in Linux.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
daliz Friday 25 October 2013 at 9:47
dalizAnonymous

Thanks for the replies. I will look into it again tonight.

The issue might be that SDL/Dosbox tries to use Pulse which isn't present since it's killed manually, and OSS emulation in Ubuntu 12.04 (and up) seems to be only done via Pulse (hence the /dev/dsp missing line):

http://askubuntu.com/questions/318396/oss-compat-package-does-not-create-dev-dsp
(ALSA-OSS compatibility modules are not present in newer Ubuntu kernels anymore)

I'll try setting SDL audio driver variable to alsa to get away from the OSS compatibility nonsense.
Ronin DUSETTE Friday 25 October 2013 at 16:11
Ronin DUSETTE
Admin

OSS is SUPER deprecated.

There should be an alsa-oss bridge, that will pass it to Pulse. Im not sure why that wouldnt work.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Friday 25 October 2013 at 16:12
Ronin DUSETTE
Admin

Maybe try Jack? It might be able to pass it to that, and OSS and a bunch of other protocols are still functional via jack. Its worth trying.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
booman Friday 25 October 2013 at 16:32
booman

Honestly, the 90+ games I have tested in Mint with PlayOnLinux... I've never had to mess with audio.
Maybe one or two games had problems, but not bad enough to make the game unplayable.
So this is pretty strange having to screw around with OSS, Pulse or Alsa.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
daliz Friday 25 October 2013 at 17:57
dalizAnonymous

Only game besides this that I've had sound troubles is Baldur's Gate on a Thinkpad laptop, and that was easily fixed by killing Pulse. Well I do get sounds when Pulse is running. But it's crackling and squeeking so much that it is unplayable. I'm trying to run without Pulse to see if that has something to do with it. The sound is a bit glitchy in Windows too, but it is just a small annoyance.

I just tried to set "export SDL_AUDIODRIVER=alsa" to bypass Pulse but dosbox still can't open any audio device.

@petch:

This is the log with Pulseaudio running:

[10/25/13 18:51:35] - Running wine-1.4-dos_support_0.6 TEX197.EXE (Working directory : /home/hkt/.PlayOnLinux/wineprefix/TexMurphyUAKM_gog/drive_c/GOG Games/Under a Killing Moon)
Dosbox front-end for PlayOnLinux
[PlayOnLinux] Working in /home/hkt/.PlayOnLinux//wineprefix/TexMurphyUAKM_gog
[PlayOnLinux] Detecting program directory to run: C:\GOG Games\Under a Killing Moon
[POL_LoadVar_ScreenResolution] [1;34mMessage:[0m Screen width: 1920
[POL_LoadVar_ScreenResolution] [1;34mMessage:[0m Screen height: 1080
DOSBox version 0.74
Copyright 2002-2010 DOSBox Team, published under GNU GPL.
---
CONFIG:Loading primary settings from config file /home/hkt/.PlayOnLinux//wineprefix/TexMurphyUAKM_gog/PlayOnLinux_DOSBox_tmp/PlayOnLinux_DOSBox.cfg
"vga" is not a valid value for variable: machine.
It might now be reset it to default value: svga_s3
MIXER:Got different values from SDL: freq 22050, blocksize 1024
ALSA:Client initialised [17:0]
MIDI:Opened device:alsa

What about the "MIXER:"-line? The SDL/Pulse/whatever settings seem to override anything I type into the ~/.PlayOnLinux/wineprefix//playonlinux_dos.cfg file. Why I'm interested in those is that there are people on GOG boards that have fixed the minor glitches of sound in Windows by tweaking those settings (in the usual dosbox.conf)

This is what happens without Pulse:

[10/25/13 18:55:35] - Running wine-1.4-dos_support_0.6 TEX197.EXE (Working directory : /home/hkt/.PlayOnLinux/wineprefix/TexMurphyUAKM_gog/drive_c/GOG Games/Under a Killing Moon)
Dosbox front-end for PlayOnLinux
[PlayOnLinux] Working in /home/hkt/.PlayOnLinux//wineprefix/TexMurphyUAKM_gog
[PlayOnLinux] Detecting program directory to run: C:\GOG Games\Under a Killing Moon
[POL_LoadVar_ScreenResolution] [1;34mMessage:[0m Screen width: 1920
[POL_LoadVar_ScreenResolution] [1;34mMessage:[0m Screen height: 1080
ALSA lib pcm_oss.c:397:(_snd_pcm_oss_open) Cannot open device /dev/dsp
DOSBox version 0.74
Copyright 2002-2010 DOSBox Team, published under GNU GPL.
---
CONFIG:Loading primary settings from config file /home/hkt/.PlayOnLinux//wineprefix/TexMurphyUAKM_gog/PlayOnLinux_DOSBox_tmp/PlayOnLinux_DOSBox.cfg
"vga" is not a valid value for variable: machine.
It might now be reset it to default value: svga_s3
MIXER:Can't open audio: No available audio device , running in nosound mode.
ALSA:Client initialised [17:0]
MIDI:Opened device:alsa
daliz Friday 25 October 2013 at 18:57
dalizAnonymous

Okay, I got it to work. I did what booman suggested, and ran the game with just dosbox.

Even with default settings, pulse running etc. there is very little sound glitching. I set the prebuffer setting to 100, and even the minor glitching is gone. It's better than in Windows with GOG settings.

Thanks, I'm off to play now for a change :)

Editado por: daliz

petch Friday 25 October 2013 at 19:19
petch
Developer

I created a bug report, I assume some library is missing:
http://www.playonlinux.com/en/issue-3270.html

Which one(s) is the real problem...