El Foro

Fallout-cant install or run

GOG version

Autor Respuestas
Pavel Thursday 17 July 2014 at 22:20
PavelAnonymous

Hello to friendly PoL community here.

Anyways,I have a problem with instalation and running of Fallout (1,2 and Tactics-same thing. every version is from GOG) and I used official POL installers- I can't install this game completely. Installer runs, and at the  end and I get following error:

 I get this same error every time.I did tried to install directly though wineprefix (without POL), the install is at least finished, but  get black screen every time I run the game. Maybe some files are corrupted but i am not sure which ones.

This is a copy of debug file (2 error messages. dont know what they mean), and I really dont know what to do:

libGL error: dlopen /usr/lib/xorg/modules/dri//r600_dri.so failed (/usr/lib/xorg/modules/dri//r600_dri.so: wrong ELF class: ELFCLASS64)
fixme:win:EnumDisplayDevicesW ((null),0,0x33d4cc,0x00000000), stub!
ALSA lib dlmisc.c:252:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so
fixme:win:alloc_winproc too many winprocs, cannot allocate one for 0x99bcbdc

 

Thank you in advance,

 

Manjaro Linux

DE:XFCE

Lenovo b575e

 

petch Friday 18 July 2014 at 18:26
petch
Developer

Dialog box makes me think (somewhat) of bug report #3735, the problem being that Fallout 1 and 2 installers already use Wine 1.6.2, so are supported to have this kind of problem fixed. Maybe it's something else, only similar.

libGL error: dlopen /usr/lib/xorg/modules/dri//r600_dri.so failed (/usr/lib/xorg/modules/dri//r600_dri.so: wrong ELF class: ELFCLASS64)

Badly installed accelerated video libraries, or maybe just missing the 32bit version of those

ALSA lib dlmisc.c:252:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so

Install libasound2-plugins:i386

fixme:win:alloc_winproc too many winprocs, cannot allocate one for 0x99bcbdc

If this happens with Fallout 2 or Fallout Tactics, it could be a case of Wine bug #32451. It happens when the installation duration is too long, so it does not always happen, but there's a known workaround.